Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-16-2011, 03:46 AM   #1
New Member




Join Date: Jul 2011
Posts: 4
Problems with Pentax Kr (similar to K-5 shutter problem)

Good day. I bay Pentax K-r 15 july 2011 and make only 15-20 photo. And now i have a problem like this: https://www.pentaxforums.com/forums/pentax-k-5-forum/144309-k-5-bug-shutter-g...ff-itself.html
Video my problem:


07-16-2011, 05:55 AM   #2
Veteran Member




Join Date: Jul 2009
Location: London
Posts: 856
Back to the shop! Get a replacement.
07-16-2011, 06:03 AM   #3
New Member




Join Date: Jul 2011
Posts: 4
Original Poster
QuoteOriginally posted by JohnX Quote
Back to the shop! Get a replacement.
I bay on Amazon.com. It is a problem back to the shop.I live in Russia.
07-16-2011, 07:15 AM   #4
New Member




Join Date: Jul 2011
Location: Zuid-Holland
Posts: 6
[langtitle=nl]Ik weet niet wat ik zie[/langtitle]

Dag,

Je film is duidelijk. Dit is een probleem dat er niet hoort te zijn. Is het een idee om je klacht voor de camera onder worden te brengen en vervolgens je klacht per brief te doen met daarin de verwijzing naar de filmpjes. Vraag een nieuwe camera naar je te sturen voordat je deze terug stuurd.
Probeer de aandacht van de directie te krijgen. En blijf glimlachen, bied Amazon de mogelijkheid dit probleem voor jou op te lossen.

Succes en voor later veel fotoplezier.

Rob (from The Netherlands)


07-16-2011, 07:27 AM   #5
Senior Member
HeavyD's Avatar

Join Date: May 2009
Location: New York
Posts: 155
Did you try a master reset or firmware update? I also remember when I had my K-7 there was a feature that when you focus in manual mode it will automatically take a picture when the subject is in focus. However, I doubt that is whats causing your issues.
07-16-2011, 08:05 AM   #6
New Member




Join Date: Jul 2011
Posts: 4
Original Poster
firmware is update to 1.10 ver. Not help.
07-16-2011, 08:46 AM   #7
Veteran Member
Philoslothical's Avatar

Join Date: May 2011
Posts: 1,723
You will need to get a replacement, or failing that, send yours in for repair. I realize this is difficult due to your location, but there's no other solution. You can't fix this yourself if re-flashing the firmware didn't help.
07-16-2011, 09:21 AM   #8
New Member




Join Date: Jul 2011
Posts: 4
Original Poster
Thank you. I try to get a replacement. I can not find in the internet problem with Pentax K-r like in my camera. I first?


07-16-2011, 09:53 AM   #9
Veteran Member
Philoslothical's Avatar

Join Date: May 2011
Posts: 1,723
It doesn't seem to be common with the K-r at all, so I think your particular copy is probably just defective.

I hope you have better luck with the next one.
07-17-2011, 07:23 PM   #10
Loyal Site Supporter
bwDraco's Avatar

Join Date: Jul 2010
Location: New York
Photos: Albums
Posts: 1,007
At 2:35 and 2:46 in the video, notice that the aperture control lever at the left side of the mount is not moving when the shutter/mirror cycles. On my K-r, this lever always moves up whenever the mirror goes up. This corresponds to the CRIS replacement of the aperture control unit on a K-5 with this problem; see post #39 of K-5 bug - Shutter going off by itself:

QuoteOriginally posted by mfutrell Quote
After 2 months a CRIS for this exact problem mine supposedly is shipping back today. They said thet they did the following

REPLACED APERTURE CONTROL UNIT
REPLACED APERTURE CONTROL CONTACT PAD AND BRUSHES

We will see if it is fixed this time....
It appears that the aperture control assembly has failed on your K-r. Try pushing up the aperture control lever in the left side of the lens mount. If this doesn't help, your camera is defective and needs to be repaired or replaced.

--DragonLord

Last edited by bwDraco; 07-17-2011 at 07:43 PM.
07-18-2011, 04:33 PM   #11
Inactive Account




Join Date: Oct 2010
Posts: 9
Sorry to hear you have exactly the same issue I've had.

I was almost crucified by other forums members, read here:

https://www.pentaxforums.com/forums/pentax-k-r-forum/147874-my-kr-dead.html

It's now sure that this issue has nothing to do with a drop...

Btw, my Kr was repaired by Pentax Canada, they replaced the circuit board. So far it's working well again.
12-12-2011, 05:21 PM   #12
Forum Member
Khoff2's Avatar

Join Date: Nov 2011
Location: Dallas, TX
Photos: Gallery | Albums
Posts: 84
same problem

Hello. After having my k-r for exactly a month, this shutter issue started yesterday. Does anyone know of a fix yet?
12-15-2011, 07:45 PM   #13
New Member




Join Date: Dec 2011
Posts: 1
Shutter problem as mentioned in the thread above

Hello. I bought a K-r about a month and a half ago. It was working fine until a couple of days ago. It now has the same problem as in the video. Following DragonLord's advice, I moved the lever up. It works fine when I do that without a lens. As soon as I put the lens in, it takes a few photos just fine and then starts the same issue all over again.

I bought the camera in New York, but I'm currently in Bali. I need a fix for this problem ASAP. It is really hard for me to send this camera anywhere at the moment.

Any help would be greatly appreciated.
01-19-2012, 08:31 AM   #14
Forum Member
Khoff2's Avatar

Join Date: Nov 2011
Location: Dallas, TX
Photos: Gallery | Albums
Posts: 84
I had the same issue, turns out it needed a new aparature control unit. Great turn around time from Pentax. Sent it in for repair (Chandler, AZ) and they received it last Wed, 1-11-12. I received it back yesterday on 1-18-12. Only one week. I'm impressed. They replaced the aparature control unit, checked my lenses, and upgraded the firmware. So far, it works great! Other than the $25 to ship it back to them (had to buy insurance), I'm impressed with the turn around time.
02-01-2012, 01:10 PM   #15
Inactive Account




Join Date: Aug 2011
Location: Memphis, TN
Photos: Albums
Posts: 14
My K-r is doing the same thing and it only seems to take a picture when the camera is pointed straight down. Just shipped it off to Chandler, AZ...hoping for the best!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-5 shutter, k-r, kr, pentax, pentax k-r, pentax kr
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Pentax KX, problem with double shutter movement leading to underexposure Tricerator Pentax DSLR Discussion 21 10-30-2011 09:01 PM
K-X shutter sound similar to K-R? jswilson64 Pentax DSLR Discussion 5 01-26-2011 07:36 PM
Problem -- Pentax 67 film advances but no shutter? sleepyhead Pentax Medium Format 5 05-15-2010 09:54 PM
Pentax Ist DS Shutter Problem Kev511 Pentax DSLR Discussion 3 04-13-2010 08:56 AM
Shutter Problems on SP1000 The Sparkly One Pentax Film SLR Discussion 9 02-06-2010 09:39 AM



All times are GMT -7. The time now is 05:18 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top