Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-23-2011, 08:05 PM   #1
New Member




Join Date: Jun 2011
Location: North Texas
Posts: 21
Video playback issues

When trying to watch videos from my K-r in Media Player Classic I can't usually get anything to play. I get a static image and no sound. Sometimes the video will play but without sound.

When I use Windows Media Player I only get sound and just a pair of sixteenth notes where the video should be.

The videos do play fine in Quicktime, though.

Has anyone else had these problems? If so, what can I do?

08-23-2011, 10:48 PM   #2
Veteran Member
Philoslothical's Avatar

Join Date: May 2011
Posts: 1,723
Sounds like you're having problems with your audio/video codecs. What version of Windows are you using?

Something like the K-Lite codec pack would probably fix you right up.
08-24-2011, 12:28 PM   #3
Senior Member
Swapnil's Avatar

Join Date: Apr 2011
Location: Bellevue
Photos: Gallery | Albums
Posts: 138
QuoteOriginally posted by monkadelicd Quote
When trying to watch videos from my K-r in Media Player Classic I can't usually get anything to play. I get a static image and no sound. Sometimes the video will play but without sound.

When I use Windows Media Player I only get sound and just a pair of sixteenth notes where the video should be.

The videos do play fine in Quicktime, though.
I always use VLC media player for playing all kind of formats. Its simply awesome; one player for all kind of files
you should try that
08-24-2011, 12:46 PM   #4
Veteran Member
Philoslothical's Avatar

Join Date: May 2011
Posts: 1,723
That's another solution, but it's not my favourite. I don't think VLC generally renders video as sharply as WMP, probably due to the choice of codecs used (and the licensing restrictions of the proprietary ones). VLC does have the advantage of being cross-platform.

MPC is another, Media Player Classic, which comes bundled with the K-Lite codec pack. I've never found a file that VLC would play that MPC wouldn't.

08-25-2011, 03:24 AM   #5
New Member




Join Date: Jun 2011
Location: North Texas
Posts: 21
Original Poster
QuoteOriginally posted by Philoslothical Quote
Sounds like you're having problems with your audio/video codecs. What version of Windows are you using?

Something like the K-Lite codec pack would probably fix you right up.

I've got the K-lite mega codec pack installed. So I figured I was covered on that front. Motion JPEG .AVI is a pretty basic codec that I assumed was standard to play. I've got other videos that are .AVI and they play just fine. I'm not sure which encoding they are, though I'm sure they are something more size efficient that Motion JPEG.
08-25-2011, 03:26 AM   #6
New Member




Join Date: Jun 2011
Location: North Texas
Posts: 21
Original Poster
QuoteOriginally posted by Swapnil Quote
I always use VLC media player for playing all kind of formats. Its simply awesome; one player for all kind of files
you should try that
I used MPC. It is my default for all video files. This is the first time I've had trouble with a video, though.
08-25-2011, 04:31 AM   #7
Veteran Member
Philoslothical's Avatar

Join Date: May 2011
Posts: 1,723
I'm really not sure what else to suggest then, sorry. If you try to play one in WMP, and in the file list you double click the error icon indicating the missing codec, followed by the web help button, does it give you a recommendation to install?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-r, kr, media, pentax k-r, player, sound, video, videos
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Are there issues with video and Sigma HSM lenses? Noisychip Video and Pentax HDSLRs 11 09-13-2010 06:21 AM
Pentax video clear of future legal issues. junyper Video and Pentax HDSLRs 7 05-03-2010 06:43 PM
K7 video issues - considerations for a prospective buyer RobG Video and Pentax HDSLRs 2 02-11-2010 05:12 AM
Can you playback video on the K-x itself with sound? manteiv Video and Pentax HDSLRs 1 12-11-2009 01:45 PM
Pentax Optio W60 playback issues. Albee Pentax Compact Cameras 1 06-12-2009 04:15 PM



All times are GMT -7. The time now is 09:35 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top