Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-12-2011, 01:38 PM   #1
Veteran Member




Join Date: Dec 2009
Location: Sacramento, CA
Photos: Gallery | Albums
Posts: 728
Anyone else have problems with pop-up flash not firing?

I had a shoot over the weekend where I was trying to get the pop-up flash to trigger an optical slave, but noticed it was not firing at all. My settings were all on manual flash and I could see the lightning icon in the viewfinder. For a sanity check, I tried triggering in Tv, Av, and even AutoPicture modes, but to no avail. I figured at the very least, AutoPicture used in a dim to almost dark setting would trigger the flash. Anyhow, since I mostly use radio triggers, I never noticed the problem until yesterday, so I have no idea how long the problem's been around. Any other K-r owners experienced anything similar? Or does anybody have other suggestions to test the flash? If not, it looks like the K-r will be making it's second trip back to CRIS (first time was for the e-dial issue), which is disappointing to say the least

09-12-2011, 04:35 PM   #2
Veteran Member
alohadave's Avatar

Join Date: Jan 2008
Location: Quincy, MA
Photos: Gallery | Albums
Posts: 2,024
Put your camera in M mode and try it again.

Are the flashes firing but not showing in the pictures, or are they not firing at all?
09-12-2011, 05:21 PM   #3
Pentaxian
Sagitta's Avatar

Join Date: Feb 2011
Location: Maine
Photos: Gallery
Posts: 2,912
Really dumb question, but were you wearing a hat? Flash won't fire unless its raised all the way. Alternatively, could you have a bit of crud on the camera preventing the flash from extending all the way?
09-12-2011, 08:58 PM   #4
Veteran Member




Join Date: Dec 2009
Location: Sacramento, CA
Photos: Gallery | Albums
Posts: 728
Original Poster
Nope, wasn't wearing a hat and pop-up flash was extended all the way. Here's a couple of photos showing my settings in Manual mode. Flash isn't firing at all. Initially I was thinking maybe my Vivitar 285hv had fried something, but the hotshoe works fine and has nothing to do with the pop-up.

Attached Images
   
09-13-2011, 11:56 AM   #5
Veteran Member




Join Date: Aug 2008
Location: Spain
Photos: Gallery
Posts: 574
My flash didnīt fire all the times. But my problem was that a I push it just a bit when I put my eye on the viewfinder. It looks like a joke, but it was real.
09-16-2011, 02:36 AM   #6
New Member




Join Date: Apr 2011
Location: Melbourne
Photos: Gallery
Posts: 17
Mine gave up the ghost after one week. Took it back and the camera plus the lens were replaced on the spot. No probs since...
09-16-2011, 01:39 PM   #7
New Member




Join Date: Aug 2011
Location: West Midlands
Posts: 8
I had this problem when using manual focus lenses with the mf/af switch in the af position (doh)
As soon as I switched it to mf it worked fine
09-17-2011, 02:35 PM   #8
Veteran Member




Join Date: Dec 2009
Location: Sacramento, CA
Photos: Gallery | Albums
Posts: 728
Original Poster
Yeah, everything's on AF and I don't have any MF lenses, so it looks like the camera's going back to CRIS at this point. It hasn't bothered bugged me since I don't ever use the pop-up flash, but I'd like to have it functional if it's ever needed.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, flash, k-r, kr, pentax k-r, pop-up, pop-up flash
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ext. Flash: Is there a way to wirelessly trigger it without firing the int. flash? dosdan Accessory and Memory Articles 3 03-19-2011 05:42 PM
k5 pop-up flash hook (that holds the flash down) broken... Thesorus Troubleshooting and Beginner Help 4 01-06-2011 08:34 PM
K7 pop up flash @#%! ordinaryimages Pentax DSLR Discussion 12 04-05-2010 02:55 PM
K2000 - Pop up flash will not pop up. tkindred Pentax DSLR Discussion 6 08-17-2009 08:54 AM
Flash Not Firing smitty Pentax DSLR Discussion 2 11-11-2007 05:28 PM



All times are GMT -7. The time now is 03:15 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top