Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-19-2011, 06:15 PM   #1
New Member




Join Date: Sep 2011
Posts: 3
Dead k-r

Problem: dead camera (k-r); will not turn on or be recognized by computer

Currently:
Age: came in mail today
Battery: fully charged; installed correctly
Lens: came with camera; installed correctly
Card: SDHC 4G; installed correctly
Dropped: Never, it had been handled for only 10 minutes

It was on long enough for me to adjust the settings (time, date, etc) and to take about 40 test pictures. Suddenly the screen turned black and no button could revive it. I tried taking the battery in and out and restarting. Nothing worked. Before it was recognized by my computer when plugged in via USB and now it is not. Interestingly, the autofocus still works when I have the camera in the ON position. I believe that means that the battery is at least working, yet somehow the camera itself will not turn on.

HELP please.

09-19-2011, 06:27 PM   #2
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,695
Sounds like the camera is actually on but you can't see that it is from the displays.
If this is the case, have it replaced, but check to see that the display brightness has not been turned all the way down (see if you can see anything in the dark).
09-19-2011, 06:42 PM   #3
New Member




Join Date: Sep 2011
Posts: 3
Original Poster
Thank you for the reply. I cannot see anything on the screen in the dark. I also might mention that the flash release button also does not work with the camera in the ON position. It is also now making strange sounds when I push the shutter release on autofocus mode. The sounds aren't the same each time either...
09-19-2011, 07:21 PM   #4
Veteran Member




Join Date: Apr 2010
Location: Tennessee
Posts: 1,994
Yep, you definitely want to replace that one. Bummer.

09-19-2011, 07:46 PM   #5
Site Supporter
Deimos's Avatar

Join Date: Oct 2010
Location: Kingdom of Wonder
Posts: 1,709
Send it back
09-19-2011, 10:01 PM   #6
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,695
Agree, this is odd and shouldn't be happening.
Have it exchanged for a new one.
09-19-2011, 10:32 PM   #7
Veteran Member
Philoslothical's Avatar

Join Date: May 2011
Posts: 1,723
Just to be sure that you haven't turned the display off, with the camera turned on, press the Info button a couple times. It cycles between three states, the third being turned off entirely.

It does sound like you have a defective camera though. That really sucks.
09-21-2011, 11:02 AM   #8
Senior Member
dragra's Avatar

Join Date: Dec 2010
Location: Ljubljana
Photos: Albums
Posts: 238
QuoteOriginally posted by JaclynB Quote
Problem: dead camera (k-r); will not turn on or be recognized by computer

Currently:
Age: came in mail today
Battery: fully charged; installed correctly
Lens: came with camera; installed correctly
Card: SDHC 4G; installed correctly
Dropped: Never, it had been handled for only 10 minutes

It was on long enough for me to adjust the settings (time, date, etc) and to take about 40 test pictures. Suddenly the screen turned black and no button could revive it. I tried taking the battery in and out and restarting. Nothing worked. Before it was recognized by my computer when plugged in via USB and now it is not. Interestingly, the autofocus still works when I have the camera in the ON position. I believe that means that the battery is at least working, yet somehow the camera itself will not turn on.

HELP please.
Erratic. Your camera seems to be half dead if the AF works. Did you try to look through the viewfinder? Is the viewfinder display working? If the VF display is on you can try to change some setting by turning the e-dial. Try to make a shot. Come back an report.

Cheers,
D

09-26-2011, 06:46 PM   #9
New Member




Join Date: Sep 2011
Posts: 3
Original Poster
Solved

Pentax told me it was a camera problem, although they were not super specific. Anyway, I returned it and received the replacement in the mail today. It is working wonders for now!

Thank you all for your feedback and support!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, computer, k-r, kr, pentax k-r
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K5 - Dead Frogfish Pentax K-5 31 06-29-2011 01:01 PM
Dead K-5 garyk Pentax K-5 27 06-27-2011 12:13 AM
Beating a dead horse DA15mm vs 12-24mm zoom Jeff Bennett Pentax SLR Lens Discussion 19 03-04-2011 11:22 PM
Dead AF? afvn72 Troubleshooting and Beginner Help 12 03-03-2011 08:25 AM
Nature i'm not dead yet..... dcmsox2004 Post Your Photos! 8 10-23-2009 11:23 AM



All times are GMT -7. The time now is 08:10 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top