Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-08-2012, 06:55 PM   #1
Junior Member




Join Date: Nov 2009
Posts: 26
Problem with Vivitar DF-283-PEN Flash

I'm having a problem getting a brand new Vivitar Df-283-PEN to work on my Kr. The flash supposedly works with many Pentax DSLRs including the Kr. I have tried just about everything I can think of (P, M, At, and Auto modes; a manual lens and an auto zoom lens, manual and auto flash modes), always with the same results: Once it starts flashing, the flash keeps on rapidly flashing until I switch it off! Can anyone help me? Please.

02-08-2012, 07:09 PM   #2
Site Supporter
JimJohnson's Avatar

Join Date: Jan 2012
Location: Lake Superior - Michigan
Photos: Gallery
Posts: 2,165
I had to return mine for the same reason. Apparently only the newest newest stock is compatible - was manufactured only a few months ago. Hope you bought from a good source.
02-27-2012, 06:45 PM   #3
Junior Member




Join Date: Nov 2009
Posts: 26
Original Poster
Vivitar Df-283-PEN problem

This is a follow up to my original post of 02-08-2012 08:09 PM.

The vendor has been exceptionally cooperative paid for the return of the original flash and promptly sent a replacement. Unfortunately, the replacement flash does the same thing, flashes continuously (like a strobe light). In the meantime since my original post, has anyone else experienced a problem with the Vivitar Df-283-PEN flash when used with a Pentax DSLR camera?
02-27-2012, 06:57 PM   #4
Site Supporter
JimJohnson's Avatar

Join Date: Jan 2012
Location: Lake Superior - Michigan
Photos: Gallery
Posts: 2,165
I didn't fool around with a second Vivitar flash. I cringed at the extra cost and purchased a Sigma flash. Once I had it, I wasn't as troubled with the extra money.

02-28-2012, 04:52 AM   #5
Junior Member




Join Date: Aug 2010
Posts: 25
Did you try setting the flash unit to manual mode instead of using P-TTL? I have the DF-383 and it worked fine with K100D.
02-28-2012, 06:11 PM   #6
Junior Member




Join Date: Nov 2009
Posts: 26
Original Poster
QuoteOriginally posted by mazinger Quote
Did you try setting the flash unit to manual mode instead of using P-TTL? I have the DF-383 and it worked fine with K100D.
Thanks for the tip, but, I'm sorry to say, it didn't fix the problem on the Kr.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
auto, camera, df-283-pen, flash, k-r, kr, lens, modes, pentax k-r, vivitar
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vivitar-383-PEN flash and K-5 mrdfred Ask B&H Photo! 4 11-13-2011 08:26 AM
Vivitar DF-283 Aknot Pentax Camera and Field Accessories 5 04-11-2011 01:52 PM
For Sale - Sold: pentax ZX-M: A 50mm f2: vivitar 283 flash ryno Sold Items 3 01-10-2009 12:08 PM
For Sale - Sold: Vivitar auto thyristor 283 Flash & MANY Accessories Curbster54 Sold Items 3 12-14-2008 07:01 AM



All times are GMT -7. The time now is 02:59 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top