Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-09-2012, 08:05 PM   #1
Inactive Account




Join Date: Feb 2010
Posts: 3
Sensor Issue?

I've navigated the forums here for a while (a year or so), but never really posted any questions. Now I'm in need of some input, and I hope you all can help me.

I have owned my Pentax k-r for almost a year now. I bought it brand new as a replacement for my k-m. For the past month or so, only when I turn it on after it's been off for a day or so, the first 5-10 images I shoot are either black or very dark, and the internal light meter reads everything as dark as well. It does clear up and register the correct light after I fire a few shots, but I'd really like to know whether or not this issue would be an easy fix or if I need to start searching for a replacement.

Any input is appreciated!!! Thanks

04-09-2012, 08:23 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,964
If you get this kind of behavior consistently, something may be wrong with the camera.

Are you use that it's not because of the way you've set up the meter (i.e. spot vs matrix), or due to changes in ambient lighting?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-09-2012, 08:33 PM   #3
New Member




Join Date: Apr 2012
Posts: 21
Hello,

Would be great if you could post a few problematic photos.

Also, a few checks to do:
1. Different lenses
2. Different metering modes
3. Different modes
4. How does it behave with different shutter speeds?
5. Have you tried factory reset?

Right now it could be shutter, light metering, sensor...
04-09-2012, 09:44 PM   #4
Loyal Site Supporter




Join Date: Jun 2009
Location: Tumbleweed, Arizona
Photos: Gallery | Albums
Posts: 5,001
... but in any event, I would check the purchase date so that you can make arrangements to send it back for repair if you still have a valid warranty.



04-10-2012, 07:06 AM   #5
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
QuoteOriginally posted by interested_observer Quote
I would check the purchase date so that you can make arrangements to send it back for repair if you still have a valid warranty.
My first thought as well.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, input, k-r, kr, light, pentax k-r, replacement
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K20D sensor issue, whats it worth? nigelorion Pentax DSLR Discussion 9 01-03-2012 06:43 AM
sending in my K-5 finally for that sensor stain issue raphtze Pentax K-5 9 04-06-2011 05:31 PM
Optio M20 light sensor issue michla Troubleshooting and Beginner Help 2 01-12-2011 11:30 PM
Pentax K-X Shutter or Sensor Issue Due to Moisture Adam B Pentax DSLR Discussion 4 11-10-2010 12:19 PM
K7 sensor dust removal issue Dr_who Pentax DSLR Discussion 20 05-26-2010 06:42 PM



All times are GMT -7. The time now is 02:37 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top