Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-28-2012, 09:20 AM   #16
Pentaxian
hnikesch's Avatar

Join Date: May 2009
Location: Michigan, USA
Photos: Albums
Posts: 1,254
I did the contact cleaner thing yesterday and it solved my problem. I just did a quick spray above and below the e wheel with the camera fully assembled then turned the dial about 10 times. Now no problems. If it happens again I will re-spray. I found the contact cleaner at the local auto parts store.

Hans

07-29-2012, 08:25 AM   #17
Veteran Member




Join Date: Nov 2010
Location: Edmonton, Alberta
Posts: 800
I bought my camera in December of 2010 and did not have any issues for the first year. Shortly after our anniversary, the e dial started acting up so I took some spray to it and it worked like a charm. About 10k shutter actuation.

But... A month later the problem came back, so I used the spray once again, problem solved.

But... A couple weeks later the problem came back, so I used the spray, fixed the issue.

But... (you see where I am going with this)

Eventually, my e-dial would not work, so I would spray it, and get a few minutes of use out of it. So, being fed up with carrying a can of cleaner around with me, I sent the camera away.

Thankfully I live in Canada where Pentax has a fabulous 2 year warranty and McBain camera willingly packaged my camera and sent it away, free of charge. I am waiting on it to come back, but is has only been 3 weeks or so.

I was using Nexxtech Contact and Head cleaner from The Source (Radio shack). It was literally the ONLY contact cleaner I could find after weeks of searching in Edmonton (without going to speciality shops that close early)
07-30-2012, 02:16 PM   #18
Pentaxian
hnikesch's Avatar

Join Date: May 2009
Location: Michigan, USA
Photos: Albums
Posts: 1,254
Mine just needed a single small spray on both sides of the e dial, Hope it works for a while. My E dial was still usable but erratic sometimes, just an inconvenience. Stay tuned

Hans
11-20-2012, 11:56 AM   #19
Inactive Account




Join Date: Aug 2010
Photos: Gallery
Posts: 16
I wanted to report my e-dial problems as well. I will say I'm a bit disappointed with Pentax.

The issue came up a few months after I bought the camera. Then went away, then came back. So I sent it in to Pentax to get fixed under warranty. They sent it back and said they repaired the e-dial. Sweet. Mistakes do happen, but they made it right so I am happy.

So maybe 6 months go by and the problem comes back! Then it went away, and now it's back for good. If I move the dial to the left the camera will think I am moving it to the right. Of course the camera warranty is over, and the previous repair is only warrantied for 90 days.

Is it too much to think Pentax would have fixed this pretty simple problem for me? I contacted them to see if they would make it right, and they said I can send it in, pay for the repair and they will try to fix it. Not the response I was hoping for. It's a pretty expensive camera and not some simple point and shoot throwaway.

I owned a DS2 for many years and didn't have any problems like this. Did the quality go down under Hoya? Or just recent cost cutting measures? Anybody know if the situation is better now under Ricoh? Would anyone say if the build quality is better with any of the newer models? I like to keep my camera for a good long time.

I guess it's time to crack it open and see if I can fix it...

thanks,
Peter

11-20-2012, 07:41 PM   #20
Senior Member
jaywes's Avatar

Join Date: Apr 2012
Location: New York, USA
Posts: 235
Original Poster
Read ALL the above post Peter. The "fix" involves the electrical contact spray. It works as others have stated. If you are comfortable, buy it & try it. Popping camera open is a different story altogether.
11-22-2012, 10:44 AM   #21
Forum Member
Eder's Avatar

Join Date: Jul 2012
Posts: 93
try to srpay before

QuoteOriginally posted by peter25 Quote
I wanted to report my e-dial problems as well. I will say I'm a bit disappointed with Pentax.

The issue came up a few months after I bought the camera. Then went away, then came back. So I sent it in to Pentax to get fixed under warranty. They sent it back and said they repaired the e-dial. Sweet. Mistakes do happen, but they made it right so I am happy.

So maybe 6 months go by and the problem comes back! Then it went away, and now it's back for good. If I move the dial to the left the camera will think I am moving it to the right. Of course the camera warranty is over, and the previous repair is only warrantied for 90 days.

Is it too much to think Pentax would have fixed this pretty simple problem for me? I contacted them to see if they would make it right, and they said I can send it in, pay for the repair and they will try to fix it. Not the response I was hoping for. It's a pretty expensive camera and not some simple point and shoot throwaway.

I owned a DS2 for many years and didn't have any problems like this. Did the quality go down under Hoya? Or just recent cost cutting measures? Anybody know if the situation is better now under Ricoh? Would anyone say if the build quality is better with any of the newer models? I like to keep my camera for a good long time.

I guess it's time to crack it open and see if I can fix it...

thanks,
Peter
Peter before you open it try to spray some degreaser directly on the wheel then spin it back and forward several times then add more spray and then spin again, repeat the process some times let it dry some minutes and check results. If not works, then watch the video here posted and clean it. Is not hard to do it but if you can avoid to open it is better.

I have read some others complaining with k-5 which is newer model, so i believe pentax is doing really bad job on fabrication process, a pitty i was going to upgrade to k-5 now i will wait
12-02-2012, 10:53 PM   #22
mva
New Member




Join Date: Jun 2011
Location: Upstate New York
Photos: Albums
Posts: 13
Home Depot Rules! Radio Shack OK.

Had this problem myself and put up with it for several months. Following advice on this thread, I went to Radio Shack and paid $15 for a 5.5 oz can of Radio Shack Precision Electronics Cleaner. Sprayed the e-dial on my K-r a few times and thumbed it back and forth. No battery in the camera while doing this. Now the e-dial works again. No taking the camera apart or sending it out for service, thank God!

Was at Home Depot and checked out the electrical section. Below the shelf called "Electrical Connectors" were different sizes of CRC QD Contact Cleaner cans. $7.99 for the bigger one and $2.99 for a small one. Who would've known?
12-03-2012, 07:31 AM   #23
Forum Member




Join Date: Oct 2010
Posts: 62
I bought a can of electrical contact cleaner in the auto section at wal Mart for around $5 and it did the trick as well.

QuoteOriginally posted by mva Quote
Had this problem myself and put up with it for several months. Following advice on this thread, I went to Radio Shack and paid $15 for a 5.5 oz can of Radio Shack Precision Electronics Cleaner. Sprayed the e-dial on my K-r a few times and thumbed it back and forth. No battery in the camera while doing this. Now the e-dial works again. No taking the camera apart or sending it out for service, thank God!

Was at Home Depot and checked out the electrical section. Below the shelf called "Electrical Connectors" were different sizes of CRC QD Contact Cleaner cans. $7.99 for the bigger one and $2.99 for a small one. Who would've known?


Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, day, issues, k-r, kr, months, pentax, pentax k-r, weekend
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear E-Dial Wouldn’t Dial. This Ever Happen to You? veezchick Troubleshooting and Beginner Help 15 11-04-2014 08:50 PM
How do you use your dial littledrawe Pentax DSLR Discussion 36 09-10-2011 02:08 PM
Front e-dial problem TaiChiTom Pentax K-5 2 08-27-2011 08:31 AM
K-x e-dial! amidtb994 Troubleshooting and Beginner Help 11 04-19-2011 09:11 AM
BG4 rear e-dial freezed Dams2One Pentax DSLR Discussion 10 08-27-2009 05:15 AM



All times are GMT -7. The time now is 04:29 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top