Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-09-2012, 03:09 PM   #1
Senior Member




Join Date: Feb 2012
Posts: 134
Weird problems with K-R and Pentax-M 100mm F4 macro lens

Hi Guys,

I've just taken delivery of a SMC Pentax-M 100mm F4 macro lens that my parents bought me for my birthday however it's working rather strangely on my K-R. No matter what I do it keeps causing the shutter to fire, pressing any button on the camera fires the shutter really fast. I am using Manual Focus and have tried all modes - Aperture Priority, Manual etc. With my other manual lenses I can press the A-E lock button (I think it's that one) and the camera works out the correct shutter speed based on the aperture chosen on the ring. Could the lens be faulty? my other manual lenses work fine. I need to try and work out if it's faulty so we can return it to the ebay seller. FYI it was used on a Canon previously and I removed the adapter, guess that shouldn't make any difference.

Any help is appreciated,

Cheers

Alex

08-09-2012, 03:50 PM   #2
Senior Member




Join Date: Feb 2012
Posts: 134
Original Poster
Ok so just had another play, it's weird when you first attach the lens I can see through viewfinder then I go to take a shot and it clicks really fast and then viewfinder is just black like mirror is locked up. Then any button on the camera just firest the shutter or moves either mirror away I can't really tell but every button makes it click. With all my other lenses it's fine, has anyone heard of this issue before?!

Really hoping this Ģ120 lens isn't screwed!

Cheers
08-09-2012, 04:03 PM   #3
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,771
Pentax-M has no contacts so I doubt it is the lens, exactly. But since everything works with other lenses then the obvious culprit is the lens.

What type of adapter did they use? Is it possible the adapter bent something on the lens that is shorting out something on the camera?
I know they sell AF confirm chips for some manual lenses but I don't know anything about them, could there be one still in the lens?

Carefully examine the lens and see if anything is located differently or out of place or bent.
Maybe post a picture of the lens mount if you want so we can see it. If the ebay listing had good pictures just post that and I'll look.
08-09-2012, 05:10 PM   #4
Veteran Member
Philoslothical's Avatar

Join Date: May 2011
Posts: 1,723
Is the mount on this lens bare metal, or painted/anodized black? If it's the lens causing the issue, then it must be a case of the lens improperly shorting some of the contacts. Try insulating the lens from the body with a small ring of paper or something, to test this idea.

08-09-2012, 05:56 PM   #5
wax
Forum Member




Join Date: Apr 2011
Location: Santiago
Photos: Gallery | Albums
Posts: 53
Again.
Itīs a over documented issue produced by the voltage of the original battery, flange distance and metering. Try AAs with a generic or original adapter and it will work better than ever.
08-09-2012, 06:34 PM - 1 Like   #6
Pentaxian
bluestringer's Avatar

Join Date: Nov 2011
Location: Cotton fields of South Georgia
Photos: Gallery | Albums
Posts: 2,438
Sounds like something is amiss with the aperture lever. I have this lens and it works fine on my K10 and K200.
08-09-2012, 10:39 PM - 1 Like   #7
Senior Member




Join Date: Feb 2012
Posts: 134
Original Poster
Phew thanks for the replies guys - I've fixed it! Turns out on closer inspection the aperture lever like bluestringer mentioned was bent. It was touching the mounting plastic and not snapping back, bent it back in line slightly and now works perfectly! good to know that wasn't Ģ100 down the drain!

Thanks for your help - now I can't wait to get out and try this lens!

Cheers

Alex
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
100mm f4 macro, aperture, button, camera, f4, k-r, kr, lens, lenses, pentax k-r, pentax-m 100mm f4, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Pentax D/FA 100mm f2.8 Macro lens GaryH Sold Items 5 04-28-2012 07:30 PM
For Sale - Sold: Pentax D FA 100mm f/2.8 WR Macro lens + smc-A 24mm f/2.8 lens (US) chemxaj Sold Items 7 07-07-2011 08:18 AM
For Sale - Sold: Pentax D-FA 100mm f/2.8 Macro Lens (CONUS) loveisageless Sold Items 4 11-15-2010 01:24 PM



All times are GMT -7. The time now is 05:18 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top