Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-25-2014, 03:19 AM   #1
New Member




Join Date: Feb 2011
Posts: 12
K-r problem solved (temporary) by pressing shutter in live view

I have a very weird problem in my underuse K-r. Whenever it is switched on after being switched off after 2 hours, the photo taken is all dark and it seems as if shutter speed is too fast and thus the darkness. With flash on, it helps brighten up a bit but still far from the normal looking photo in normal settings. The above is in looking-through lens mode.

Here is the interesting part, when I switch it to live view, the live scene on the lcd looks like with lots of noise. I will then need to take a photoshoot by pressing the shutter and voila. Everything goes back normal.

May I know what is wrong here?


Last edited by Shingkyo; 06-25-2014 at 07:38 AM.
06-25-2014, 04:15 AM   #2
Site Supporter




Join Date: Oct 2006
Location: Dayton, OH
Photos: Gallery
Posts: 3,647
I've noticed a few odd things happening when the battery in my K-r starts to run low. You've probably looked at that but I thought I would mention it anyways.

Tim
06-25-2014, 05:47 AM   #3
New Member




Join Date: Feb 2011
Posts: 12
Original Poster
Are you saying that the battery could be old nearing its end of life? Or the battery charge is not full?

My battery is fully charged... But old...
06-25-2014, 07:55 AM   #4
Site Supporter




Join Date: Oct 2006
Location: Dayton, OH
Photos: Gallery
Posts: 3,647
QuoteOriginally posted by Shingkyo Quote
Are you saying that the battery could be old nearing its end of life? Or the battery charge is not full?

My battery is fully charged... But old...
Battery charge not full.

Tim

06-25-2014, 05:42 PM   #5
Veteran Member




Join Date: Jan 2011
Location: Corinth, NY
Photos: Albums
Posts: 367
which could also come into effect at end of life. battery shows "full" but can't provide the required current.
Does the battery die fast?
06-25-2014, 09:17 PM   #6
Site Supporter
Deimos's Avatar

Join Date: Oct 2010
Location: Kingdom of Wonder
Posts: 1,707
I had a weird problem with my K-r where it would seemingly randomly once and awhile produce a very dark image like you describe as if there was a very low shutter speed. Sometimes it would do this a few times and them make images normally again (even with the exact same subject, settings). After awhile I sent it back to Pentax, they took their time with it, when I called them they said they didnt know what the problem was caused by and they sent me a new one. Which I promptly destroyed when falling off a bike. Hello K-5!

Good luck!
06-30-2014, 04:07 AM   #7
New Member




Join Date: Feb 2011
Posts: 12
Original Poster
Oh dear. Juz to update... It turns out to be battery problem... I put in AA battery case with 4x AA-sized Eneloop, I guess the Sanyo's cell is so strong that it eliminates the problem. I may need to buy new Pentax battery but I guess I will just use the battery adaptor from now on.
06-30-2014, 04:13 AM   #8
Site Supporter




Join Date: Oct 2006
Location: Dayton, OH
Photos: Gallery
Posts: 3,647
Glad to see you solved your problem.

Tim

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-r, kr, live, pentax k-r, photo, shutter, view
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-r, mirror is not going up, no Live View either d1pr3d Troubleshooting and Beginner Help 5 12-19-2016 08:27 AM
K-r : Live View focus, AF & manual madbrain Pentax DSLR Discussion 6 06-02-2012 11:55 PM
Problem with K-X Live View RyudhaPraha Pentax DSLR Discussion 4 10-07-2011 02:26 PM
Problem with k-r live view eldela1590 Pentax K-r 2 07-28-2011 12:45 AM
K-R trouble focusing in low light with Live View using Pentax 18-55 kit lens sportv Pentax K-r 8 01-02-2011 06:42 PM



All times are GMT -7. The time now is 01:05 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top