Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-13-2014, 10:53 AM   #1
New Member




Join Date: Sep 2014
Posts: 10
internal battery dead? have to set date

Hey guys, I have a annoying issue with my K-r. Every single time after changing the battery I have to set date and time, like when it was powered on for the first time. Is there a internal battery in k-r? Or is it a capacitor? Anyone had this problem before?
thanks

09-13-2014, 11:35 AM   #2
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,795
I think I've heard it is a capacitor.
It is supposed to charge up if you leave a fully charged battery in the camera for a while.
If it doesn't hold a charge any more it may need fixing.
09-13-2014, 11:53 AM   #3
New Member




Join Date: Sep 2014
Posts: 10
Original Poster
I have fully charged battery at all times - I have two batteries and when one is dead I just change them. Maybe the reason for my issue is that the second one is not original Pentax, but I don't really think so.
I can service electronics and stuff so maybe I could change the capacitor, but I don't like the idea of opening the k-r. I repaired a DLSR body only once before - it felt like an open-heart suregry, but it ended fully successfully Anyone did this?
09-13-2014, 11:54 AM   #4
Pentaxian
Fogel70's Avatar

Join Date: Sep 2009
Location: Stockholm, Sweden
Photos: Albums
Posts: 1,737
QuoteOriginally posted by hawli Quote
Hey guys, I have a annoying issue with my K-r. Every single time after changing the battery I have to set date and time, like when it was powered on for the first time. Is there a internal battery in k-r? Or is it a capacitor? Anyone had this problem before?
thanks
It might happen if you wait too long before to put charged batteries in the camera.
I believe it's a capacitor in K-r, so the "battery backup" probably work for a few days at best.

09-13-2014, 12:06 PM   #5
New Member




Join Date: Sep 2014
Posts: 10
Original Poster
Yes it should work as you say, but I just immediately change the battery so there's no way the cap could discharge.
So the cap needs to be changed - anyone did this?
09-13-2014, 02:02 PM   #6
Loyal Site Supporter




Join Date: May 2011
Location: Richmond, Virginia USA
Photos: Gallery | Albums
Posts: 2,627
One other thing to try. I was having the same issue with my q and I reformatted a card and it kept the info from that point on. Worth a try before you take it to pieces
09-13-2014, 03:11 PM   #7
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 3,898
It's probably a battery although it may be referred to as an accumulator (rechargeable battery):

See this thread:
https://www.pentaxforums.com/forums/151-pentax-k-30-k-50/200711-date-time-los...ut-batery.html
09-26-2014, 12:10 AM   #8
Senior Member




Join Date: Jan 2013
Posts: 105
I have the same problem. My k-r has done this from the first usage. I naively assumed it was a quirk of the camera!

09-26-2014, 01:00 AM   #9
Loyal Site Supporter
i_trax's Avatar

Join Date: Jan 2011
Location: Perth Western Australia
Photos: Gallery | Albums
Posts: 1,076
I was away for over 3 months and my MX-1 and the Q have lost all settings, rather disappointing.
All big bodies K30,K10,K5, K01 were fine
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, date, k-r, kr, pentax k-r, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-3 incorrectly reports battery grip battery dead tram57 Pentax K-3 26 06-03-2016 01:38 PM
Pentax K30, Kr : how to set time/date? icy Pentax Compact Cameras 2 09-18-2013 02:32 AM
K20d internal flash dead? dirtymac Troubleshooting and Beginner Help 7 03-28-2011 07:09 PM
Wrong date set in my K7, is there a way to (batch) correct the EXIF info? dgaies Digital Processing, Software, and Printing 4 06-01-2010 09:10 AM
Can we set the internal flash of K-7 not to flash while connecting wireless with 360? raider Flashes, Lighting, and Studio 12 11-15-2009 09:31 AM



All times are GMT -7. The time now is 09:33 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top