Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-01-2012, 02:52 PM   #1
New Member




Join Date: Jan 2008
Location: Barbados
Photos: Gallery
Posts: 24
Flash stuck in TTL mode

Hi,

I only recently got a 360 for my K200D and am still learning. I have used the flash before but a couple of nights ago when I powered up the flash (before mounting) it was in TTL mode. I powered it down, mounted it and the powered back up, but could not get it to change to P-TTL, no matter what I did.

About 2 minutes later, when I check it, it was on P-TTL, but when I started to take photos, if went back to TTL.

Now, when it comes on in P-TTL mode each time, I try it.

What may have been my issue with it being stuck in TTL mode?

Thanks

Steve

04-01-2012, 03:26 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 51,125
Are you shooting with manual lenses?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, KEH, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-02-2012, 11:34 AM   #3
New Member




Join Date: Jan 2008
Location: Barbados
Photos: Gallery
Posts: 24
Original Poster
No, was using the 18-55 in autofocus mode.
10-28-2012, 06:20 PM   #4
New Member




Join Date: Jan 2008
Location: Barbados
Photos: Gallery
Posts: 24
Original Poster
This issue is back again. Now the flash will not even cycle through P-TTL when not on the camera.

Does anyone have any ideas?

Thanks

10-30-2012, 05:40 AM   #5
Pentaxian




Join Date: Oct 2011
Photos: Gallery
Posts: 1,118
QuoteOriginally posted by siric Quote
This issue is back again. Now the flash will not even cycle through P-TTL when not on the camera.

Does anyone have any ideas?

Thanks
Well it's nothing to do with Halloween! I had the same thing with my 540 in the summer, then it healed itself and has been o/k ever since.

Tuggie76
10-31-2012, 08:15 PM   #6
New Member




Join Date: Feb 2011
Location: Vladivostok
Photos: Gallery
Posts: 10
Hi, i noticed that when the flash head is not in horizontal position (flash works as bounce) PTT-L mode is not working
10-31-2012, 11:50 PM   #7
Veteran Member




Join Date: Oct 2011
Posts: 819
QuoteOriginally posted by gnr2008 Quote
Hi, i noticed that when the flash head is not in horizontal position (flash works as bounce) PTT-L mode is not working
This, i suspected as so..

If i am not wrong, this is how it has been..
I've tested a Metz 50 AF-1 and the same thing happens to me..

11-01-2012, 02:27 AM   #8
Pentaxian




Join Date: Oct 2011
Photos: Gallery
Posts: 1,118
QuoteOriginally posted by gnr2008 Quote
Hi, i noticed that when the flash head is not in horizontal position (flash works as bounce) PTT-L mode is not working
Hold the 'Light' button until it reads 'SL1', or 'SL2', make sure it's on 'SL1' by hitting the 'S' button.

Tuggie76
11-18-2012, 03:29 PM   #9
Senior Member




Join Date: Jan 2009
Location: Blacksburg, VA
Photos: Albums
Posts: 284
With my 50AF1 and K5, PTTL mode must be initiated on the hotshoe and then can be taken off for wireless flash. If you start off camera, TTL is the only option. Weird, but that's the way it seems to work.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
flash, lighting, mode, p-ttl, photo studio, strobist, ttl
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
stuck in Av mode drfilgd Troubleshooting and Beginner Help 2 12-17-2011 09:05 PM
Any Good TTL flash with Auto Mode? liukaitc Flashes, Lighting, and Studio 25 03-24-2011 11:40 PM
Digital concepts 952AF/PEN flash stuck in manual mode? murphysf Flashes, Lighting, and Studio 3 01-02-2011 10:50 AM
P-TTL flash - Camera in Manual mode - ISO shouldn't change exposure right? Josť Ramos Flashes, Lighting, and Studio 5 05-29-2010 10:00 PM
TTL mode with AF-540FGZ flash gun tsmself Flashes, Lighting, and Studio 3 05-12-2009 07:24 PM



All times are GMT -7. The time now is 06:04 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top