Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-05-2014, 10:25 PM   #1
Veteran Member




Join Date: Nov 2013
Posts: 385
Problem with Cactus V5

Hi,

I have two Cactus v5 devices. On one, when I press the test button, the LED turns orange and green when fully pressed. On other device the LED turns red and then goes dark when fully pressed.

I have swapped the battery packs but the devices behave the same way. Is the one that always shows red defective. maybe?

05-06-2014, 12:24 AM   #2
Pentaxian
aurele's Avatar

Join Date: Jan 2011
Location: Paris, France
Photos: Albums
Posts: 3,182
Red is because the battery is depleted, according to the manual.
05-06-2014, 09:15 AM   #3
Veteran Member




Join Date: Nov 2013
Posts: 385
Original Poster
QuoteOriginally posted by aurele Quote
Red is because the battery is depleted, according to the manual.
I got confused because the same batteries showed red on one device but green on the other. I didn't do anything overnight and this morning both devices showed green.

So all is good for now.
05-10-2014, 10:15 AM   #4
Pentaxian
panoguy's Avatar

Join Date: Sep 2007
Location: Washington, D.C.
Photos: Gallery | Albums
Posts: 3,292
Most likely the battery drawer on the "red light" unit wasn't fitting properly. V5's have a click-in/out spring-loaded battery holder design that can wear down over time, and the batteries might not both be making contact consistently. I had to reach in and pull the spring out a bit on one of mine last year, but then I'm pretty rough on my gear...

05-10-2014, 01:07 PM   #5
Veteran Member




Join Date: Nov 2013
Posts: 385
Original Poster
QuoteOriginally posted by panoguy Quote
Most likely the battery drawer on the "red light" unit wasn't fitting properly. V5's have a click-in/out spring-loaded battery holder design that can wear down over time, and the batteries might not both be making contact consistently. I had to reach in and pull the spring out a bit on one of mine last year, but then I'm pretty rough on my gear...
That may explain why the same unit with showed the red light independently of the batteries used. I don;t know what happened but now both units show green even after changing batteries.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
cactus, devices, flash, lighting, photo studio, pressed, strobist, v5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Cactus V5 Flash Trigger Set PRICE DROP EricBrown Sold Items 2 07-10-2013 01:13 PM
[SOLVED] AF 540 FGZ with Cactus V5 problems baro-nite Flashes, Lighting, and Studio 4 06-30-2012 01:51 PM
Pentax 67 with Cactus v5 triggers rajith Pentax Medium Format 6 02-01-2012 05:28 PM
Some help with the Cactus V5, K5 and Pentax 540 jbrowning Flashes, Lighting, and Studio 10 09-02-2011 11:34 AM
cactus V4-V5 not working well with my K20D gybp Flashes, Lighting, and Studio 8 05-16-2011 06:45 PM



All times are GMT -7. The time now is 01:49 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top