Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-14-2018, 11:24 AM   #1
New Member




Join Date: Jul 2018
Posts: 8
Pentax AF-540fgz-Not Firing

Trying to locate a reliable source for Pentax flash repair. I've had this flash for several years.
Basically, everything works on the flash, except, it will not fire! The test button doesn't even light up.
I've put in fresh duracells several times, swapping one set of fresh batteries for another set of four fresh ones.

All functions seem to work fine. The mode switch works; the light switch works; the zoom functions fine.
When I press the test button, it will not fire. As I said before, the test button won't even light up!

The flash has never been abused, dropped or banged around in any way. Anyway, thanks for any advice, anyone can render!

07-14-2018, 02:58 PM   #2
Loyal Site Supporter
Loyal Site Supporter
c.perkins's Avatar

Join Date: Jun 2017
Location: New Lisbon, WI.
Photos: Gallery | Albums
Posts: 515
Did I not read something like this a couple days ago.
Ah, yes, five posts down.
Hope this helps.

AF 540 FGZ not charging on its own... - PentaxForums.com
07-14-2018, 08:35 PM   #3
New Member




Join Date: Jul 2018
Posts: 8
Original Poster
Thanks for the reply, c. perkins. But I did read that above post before posting my own dilemma.

I don't have an external power pack. Previously, four fresh duracells worked just fine.
But now, it will not fire.
07-15-2018, 04:11 PM   #4
Loyal Site Supporter
Loyal Site Supporter
c.perkins's Avatar

Join Date: Jun 2017
Location: New Lisbon, WI.
Photos: Gallery | Albums
Posts: 515
Just want to be clear on this.

So you did the work around changing the flash to PP2 charging mode ?
It still does not charge using the internal batteries ?

If so, then maybe someone else can help or it needs to go out for service.

Oh, and welcome to the forum by the way.

Clarence

07-15-2018, 07:42 PM   #5
New Member




Join Date: Jul 2018
Posts: 8
Original Poster
c. perkins: yes, I did change the flash to pp2 mode. I'm sending the flash in for service repair.
Thanks!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
button, fine, fire, flash, functions, light, lighting, pentax, pentax af-540fgz-not, photo studio, strobist, switch, test
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Super A - Film advance keeps advancing -- shutter not firing -- Help! poogene2001 Troubleshooting and Beginner Help 5 01-20-2018 03:40 AM
pentax Q10 hotshoe flash not firing shaolen Troubleshooting and Beginner Help 10 07-28-2017 06:49 AM
K1 not firing AF540FGZ off camera. Will fire on camera with Yongnuo YN 585EX! MikeDSr Troubleshooting and Beginner Help 5 07-18-2017 06:47 PM
K2 not firing up and clicking sound in camera Heinz Danzberger Troubleshooting and Beginner Help 2 01-23-2017 06:13 AM
AF 540FGZ and AF 540FGZ ii size comparison? Trey45 Flashes, Lighting, and Studio 13 02-14-2015 02:52 PM



All times are GMT -7. The time now is 11:16 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top