Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-07-2020, 06:58 AM   #16
Pentaxian
Gareth's Avatar

Join Date: May 2010
Location: South Wales, UK
Posts: 758
Original Poster
This is what I've bought, all came today.

When back home I'll re read the manual

Thanks.

Attached Images
View Picture EXIF
LYA-L29  Photo 
01-07-2020, 07:18 AM   #17
Pentaxian




Join Date: Jul 2016
Posts: 436
Hello and thanks for the pictures, I see clearer now.

The N1 trigger I see on your picture is for a Canon camera. You can use on a Pentax camera (I have some Godox triggers that are for Canon cameras and they work) to control power and trigger your ad200, but I'm afraid you will miss HSS and PTTL. Only X2T or XPro triggers supports HSS/PTTL directly on Pentax cameras.

I told you that It's supposed to work, but I was wrong, that is, it's supposed to work with the AD200 but on a supported camera, and as far as I know, there is no N1/XT1 for Pentax cameras. I suppose the trigger was included with the AD200, isn't it?


Regards.
01-07-2020, 07:31 AM   #18
Pentaxian
Gareth's Avatar

Join Date: May 2010
Location: South Wales, UK
Posts: 758
Original Poster
Cool, I'll order the Xpro-P later on and sell this trigger on 😎
01-07-2020, 11:55 AM   #19
Pentaxian
Gareth's Avatar

Join Date: May 2010
Location: South Wales, UK
Posts: 758
Original Poster
Just confirming this will work even though it's Godox please before I buy it!

Just been booked to do a home shoot on Saturday so wouldn't mind taking it along to put it through its paces

Attached Images
View Picture EXIF
LYA-L29  Photo 
01-07-2020, 02:04 PM - 1 Like   #20
Pentaxian




Join Date: Jul 2016
Posts: 436
QuoteOriginally posted by Gareth Quote
Just confirming this will work even though it's Godox please before I buy it!Just been booked to do a home shoot on Saturday so wouldn't mind taking it along to put it through its paces
Hello Gareth. This trigger willl work with your Pentax camera and your AD200. You will have HSS & PTTL too, if needed. I have exactly the same trigger (and many others ).
In my experience, with PTTL, I need to add +0.3EV. If I use HSS, then the adjustment is -0.7EV.

As you need to control only one flash, you can set the display in zoom mode, pressing the button with the +/TCM symbol. In this mode, you can control just one flash at a time but you'll see bigger characters and will control your flash quicker, needing less pressing of buttons, etc.

Don't hesitate to ask if you have problems with initial configuration, you still have some days before your booking.


Regards and good luck!


Regards.
01-07-2020, 02:09 PM   #21
Pentaxian
Gareth's Avatar

Join Date: May 2010
Location: South Wales, UK
Posts: 758
Original Poster
QuoteOriginally posted by morenjavi Quote
Hello Gareth. This trigger willl work with your Pentax camera and your AD200. You will have HSS & PTTL too, if needed. I have exactly the same trigger (and many others ).
In my experience, with PTTL, I need to add +0.3EV. If I use HSS, then the adjustment is -0.7EV.

As you need to control only one flash, you can set the display in zoom mode, pressing the button with the +/TCM symbol. In this mode, you can control just one flash at a time but you'll see bigger characters and will control your flash quicker, needing less pressing of buttons, etc.

Don't hesitate to ask if you have problems with initial configuration, you still have some days before your booking.


Regards and good luck!


Regards.

Excellent thanks! Phew, as I ordered it before you replied!!
Just to get the bare bulb working now. The speedlight head is fine but the bare bulb refuses to fire but I was trying it at 1/64 power and not full power?

Got a Bowens mount on the way as well as a reflector and softbox
01-07-2020, 02:25 PM - 1 Like   #22
Pentaxian




Join Date: Jul 2016
Posts: 436
QuoteOriginally posted by Gareth Quote
Just to get the bare bulb working now. The speedlight head is fine but the bare bulb refuses to fire but I was trying it at 1/64 power and not full power?
It's strange, the bulb should work from 1/128 up to 1/1 power. I think It's not possible to mount the bulb incorrectly, because it has pins with different thickness, but maybe you didn't push the bulb enough into the bulb head. I think you need to apply a little force first time, but not a lot really. I suppose you checked yet, but verify that the red dot on the base of the bulb match with the dot on the bulb head. I don't know what can be the cause that prevents the bulb from working.

QuoteOriginally posted by Gareth Quote
Got a Bowens mount on the way as well as a reflector and softbox
Maybe the new S-type mount? Well done!
01-07-2020, 03:15 PM   #23
Pentaxian
Gareth's Avatar

Join Date: May 2010
Location: South Wales, UK
Posts: 758
Original Poster
School boy error that it said it was in the UK when filtered search on eBay but its not lol!!

Until I get the bare bulb going then softboxes etc are no good and it's on its way - doh!

01-07-2020, 03:33 PM - 1 Like   #24
Pentaxian




Join Date: Jul 2016
Posts: 436
You could still fill a softbox with the fresnel head, but you'd need to put a (translucent) cup or similar on the fresnel head to spread light inside the softbox, avoiding a hot stop. The fresnel is just 35mm wide (fixed), not too usable 'nude', in my opinion, but it's better than nothing.
01-07-2020, 06:40 PM - 1 Like   #25
Moderator
Loyal Site Supporter




Join Date: Feb 2015
Photos: Gallery
Posts: 2,193
QuoteOriginally posted by Gareth Quote
This is what I've bought, all came today.

When back home I'll re read the manual

Thanks.
You should like the NiSi filters a lot. That's what I've settled on, the original three plus two graduated.
01-11-2020, 06:24 AM   #26
Pentaxian
Gareth's Avatar

Join Date: May 2010
Location: South Wales, UK
Posts: 758
Original Poster
Little update!
Ordered a new bulb direct from Lencarta for 32 delivered and it arrived today, put it in and we're in business so dodgy bulb.
Also the XPro trigger arrived and was pleasantly surprised when I turned it on and it found the AD200 straight away and life was good between the 2!

QuoteOriginally posted by gatorguy Quote
You should like the NiSi filters a lot. That's what I've settled on, the original three plus two graduated.
I watched a Brendan Van Son video where NiSi sent him one and he was like 'how did I ever cope without it as it's great' but I've already sold it on! Literally down the road from me is Formatt Hitech and they ran a comp where you had the chance to join a list to win the option to buy a mystery Fukubukuro lucky bag which could have up to 600 worth of filters in for 250. Had an email to say I had been lucky and picked and I've gone and done the purchase so it had to go to part fund that!
01-11-2020, 10:56 AM - 1 Like   #27
Pentaxian




Join Date: Jul 2016
Posts: 436
QuoteOriginally posted by Gareth Quote
Little update!Ordered a new bulb direct from Lencarta for 32 delivered and it arrived today, put it in and we're in business so dodgy bulb.Also the XPro trigger arrived and was pleasantly surprised when I turned it on and it found the AD200 straight away and life was good between the 2!
So the bulb was defective? What annoyance! It's good that you ordered a new one and everything is working now.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
ad200, flash, lighting, neewer, neewer ad200, photo studio, strobist, support, xpro
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
AD200 not displaying TCM properly gosman Flashes, Lighting, and Studio 3 12-26-2018 11:20 PM
Pentax K1, Godox AD200, Godox XPRO and Cactus V6 II: HSS Setting Instructions howieb101 Flashes, Lighting, and Studio 28 10-24-2018 02:23 PM
HSS with Flashpoint Evolv AD200 and Godox R2 Trigger and Cactus v6 ii combo help sureshgvv Flashes, Lighting, and Studio 8 08-15-2018 02:50 AM
AD200 and TTL McRaw Flashes, Lighting, and Studio 6 11-30-2017 05:12 PM



All times are GMT -7. The time now is 08:54 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top