Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-16-2010, 01:25 AM   #1
Senior Member
Ben Hunt's Avatar

Join Date: Oct 2008
Location: Sydney
Photos: Gallery | Albums
Posts: 147
Any else had this problem with the Metz 48

Hi Everyone!

My Metz 48 AF-1 flash just then has stopped working, it turns on and charges but will not fire either on camera or via trigger, when you press the flash button on the rear of the flash. The flash resets itself.

My flash was working fine yesterday as i was using it, It discharged this evening prior to me changing the batteries.

I have put fresh sets of batteries in the flash and partialy used sets. I have also managed to update the firmware to 1.1 but still it will not fire.

I've got a major event happening on Sunday and i will be needing this flash, has anyone else had this problem? can it be fixed without it being brough into repair?

thanks,

Ben

04-16-2010, 01:51 AM   #2
Senior Member
Ben Hunt's Avatar

Join Date: Oct 2008
Location: Sydney
Photos: Gallery | Albums
Posts: 147
Original Poster
UPDATE:
now it fails to turn on. could this be sofware or hardware?
04-16-2010, 02:59 AM   #3
Senior Member
Ben Hunt's Avatar

Join Date: Oct 2008
Location: Sydney
Photos: Gallery | Albums
Posts: 147
Original Poster
UPDATE:

Got of the phone with Metz UK and explained the porblem with them, they have told me that it's most porbably a software issue. My question is, would there be a master reset button inside the flash or a way of resetting a flash (much like resetting the BIOS in a computer?) sutpid question buy hey, maybe you might be able to, but doubt it.
04-16-2010, 07:57 AM   #4
Veteran Member




Join Date: Nov 2007
Posts: 1,553
QuoteOriginally posted by Ben Hunt Quote
UPDATE:

Got of the phone with Metz UK and explained the porblem with them, they have told me that it's most porbably a software issue. My question is, would there be a master reset button inside the flash or a way of resetting a flash (much like resetting the BIOS in a computer?) sutpid question buy hey, maybe you might be able to, but doubt it.
There is the USB port. If the flash powers up, can you do the new firmware update?

Thank you
Russell

04-16-2010, 08:06 AM   #5
Senior Member
Ben Hunt's Avatar

Join Date: Oct 2008
Location: Sydney
Photos: Gallery | Albums
Posts: 147
Original Poster
QuoteOriginally posted by Russell-Evans Quote
There is the USB port. If the flash powers up, can you do the new firmware update?

Thank you
Russell
Before it got to the phase of not displaying anything on the LCD screen, i updated the firmware to the current 1.1, after that the problem still persisted, now it seems it will not display anything on the LCD. I plugged it into my computer but now it is showing that the device is not reconised? and now all the flash will do when turned on is it displays nothing on the LCD while the backlight and AF beam remain on, i can hear the capasitor constantly charging.

so now i'm not sure if Software is to blame or if it's Hardware? with a short somewhere.

I think i may have to buy a set of torx screwdrivers and open this puppy up again (last time i did it was to replace the battery door as it broke off.)

Do you know if there is an way of resetting the flash internaly?
04-16-2010, 09:12 AM   #6
Veteran Member




Join Date: Nov 2007
Posts: 1,553
QuoteOriginally posted by Ben Hunt Quote
Do you know if there is an way of resetting the flash internaly?
Sorry, no.

Thank you
Russell
04-16-2010, 09:39 AM   #7
Senior Member
Ben Hunt's Avatar

Join Date: Oct 2008
Location: Sydney
Photos: Gallery | Albums
Posts: 147
Original Poster
QuoteOriginally posted by Russell-Evans Quote
Sorry, no.

Thank you
Russell
Thanks Russell for your help anyway,

i've managed to get the computer to reconise the flash now when i plug it in, but the metz firmware program tells me that no device is connected...furthermore the side of the flash where the USB conector is getting a tiny bit warm, i'm not sure if that is normal when you plug it into the USB port.

times like this i think to myself...Give me a Auto Thyristor flash any day :P

Ben
04-20-2010, 05:47 AM   #8
Veteran Member
rparmar's Avatar

Join Date: Jan 2008
Photos: Gallery
Posts: 8,780
I am sorry to hear of your tribulations, especially as this is a popular model... the one I would get if and when I need a flash. Please keep us updated.

Since you were on the phone with them, did you not get more specific help and instructions? I can't help thinking they should be guiding you through solving this problem.

04-20-2010, 07:42 AM   #9
Senior Member
Ben Hunt's Avatar

Join Date: Oct 2008
Location: Sydney
Photos: Gallery | Albums
Posts: 147
Original Poster
QuoteOriginally posted by rparmar Quote
I am sorry to hear of your tribulations, especially as this is a popular model... the one I would get if and when I need a flash. Please keep us updated.
Since you were on the phone with them, did you not get more specific help and instructions? I can't help thinking they should be guiding you through solving this problem.
UPDATE:
Currently after all attempts to try and fix this problem myself i have sent it into repair, I have requested that i could get some info on what exactly caused this problem, was it a software issue with the new firmware (1.1)? or was it an hardware issue where componets had failed, when i get it back, should be either Firday or Tuesday, i will let you know.
Before i sent the flash into repair i took these quick photos

Note how the flash AF beam will remain on and the flash will not respond to any user imput.

When plugged into a computer, the computer will not reconise the flash and nothing is displayed on the flash's LCD either plugged in or on to a PC.
This is a copy of an email i received from Metz

subject: Issue with Metz 48AF-1 (pentax)
text: I have the Metz 48-AF1 (pentax) flashgun (Purchased 14/7/2009 S/N 748777) and it has suddendly stopped working, the LCD displays nothing while the LCD backlight and af beam remain on when the flash is tuned on, the flash will not respond to user input and i cannot reset it by holding down the MODE button, it has the current firmware of 1.1. When turned on i can hear the capasitor constantly charging.
Have you had any reports of this happening or would you know of any way to resolve this? Is there a master reset that can be peformed?
Thank you and looking forward to your reply.
Ben Hunt
___________________________________________________
Dear Mr. Hunt,
Many thanks for your e-mail as of 16. April 2010.
We regret that you have the mentioned problems with the flash unit mecablitz 48 AF-1 digital for Pentax. Unfortunately we never heard of such problems. The reset of the flash unit only is possible by pressing the Mode button. Therefore we recommend contacting our agency for inspection of the flash unit. The complete address of them you can read below:
C.R. Kennedy & Company Pty Ltd
663 Chapel St
South Yarra
3141 Victoria
Phone: 0061-3-98231555
Fax: 0061-3-98277213
E-Mail: drulach@crkennedy.com.au
We regret that we are unable to give you a more positive reply and remain with best regards
Roland Laemmermann
Technical support

While i apreciate Roland's email i did find US importer of Metz, Bogen less helpfull.

Message: I have the Metz 48-AF1 (pentax) flashgun and it has suddendly stopped working, the LCD displays nothing while the LCD backlight and af beam remain on when the flash is tuned on, the flash will not respond to user input and i cannot reset it, it has the currnet firmware of 1.1. When turned on i can hear the capasitor constantly charging. Have you had any reports of this happening or would you know of any way to resolve this? Is there a master reset that can be peformed? Thank you and looking forward to your reply. Ben Hunt

_______________________________________________________________________
Hello,
We regret that you’ve experienced an equipment failure. You can send your unit to the following address for repair, but be sure to enclose a note describing the problem you are having, so that the service guys know what to look for.
Warranty repairs require proof of date of purchase, such as a receipt copy, and are subject to inspection.
Otherwise, estimates are free, but we can't quote them until we inspect the unit. Turn-around time can vary depending on what comes in for repair, but is usually around 8-10 business days after the estimate is approved by you.
Manfrotto Distribution
Attn: Repair Dept.
565 E. Crescent Ave.
Ramsey, NJ, 07446
(201)818-0060

Not even a formal greeting......perhaps i am being nit-picky......
Furthermore, I contacted Metz Uk via phone to ask them about this problem, they too have not heard of such an issue, so i think i must be one of thoes "excpetions" as far as this failure is concerned.

If i get any more info i will be sure to post it up and hopefully this may be of some use or help to someone out there, although i hope you never hade to experience this problem.

Ben
04-29-2010, 07:54 PM - 1 Like   #10
Inactive Account




Join Date: Jan 2010
Posts: 5
From page 84 of the manual:

14.2 Reset
The flash unit can be reset to the factory settings when delivered. Press the
Mode button for ca. 5 seconds. After ca. 5 seconds „rES“ (= Reset) is shown in the display and the flash unit is reset to the settings as delivered..
This will not affect the firmware updates for the flash unit.
Not sure if this helps with your situation (ie it wont help if you cant even turn it on) - but will hopefully at least be usefull to others.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, fire, flash, lighting, metz, photo studio, sets, strobist
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
METZ 48 - K10 Problem tiily_p Flashes, Lighting, and Studio 3 06-26-2011 11:32 PM
Metz 48 flash problem Duch Flashes, Lighting, and Studio 0 03-03-2010 10:37 AM
K7 with Metz 58AF1 WL - Problem sixstring Flashes, Lighting, and Studio 1 12-02-2009 05:33 PM
Metz 48 AF-1 problem. LeDave Flashes, Lighting, and Studio 9 12-02-2009 05:32 PM
Metz CL-1 & *istD Problem falconfixer Troubleshooting and Beginner Help 6 06-01-2009 01:16 PM



All times are GMT -7. The time now is 12:29 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top