Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-23-2011, 04:45 PM   #1
PoisonedApple
Guest




KX buttons not working.

I don't know when it started. I made pictures of a festival last month, no problems, got home, no problems, made some more pictures, still nothing going on.
But from one day till the other my buttons stopped working

LV, info, menu and the function buttons (not sure what those are called in English) are not working at all. Also the screen stays black, so I can not see my set up.
Only the limited info I get through the viewfinder (yeah, is that the correct term?)
the playback buttons does work and shows me my pictures, so the screen isnt broken.

Can anybody tell me what could be the problem here?

08-23-2011, 04:48 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,032
To me it sounds like a hardware problem (unfortunately), although I'm not 100% sure. Perhaps some of the buttons have somehow been disconnected.

If your k-x is still under warranty, you can get this repaired. Otherwise, if the repair turns out to be too expensive, the best course of action would be to get a new K-r.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-23-2011, 05:00 PM   #3
PoisonedApple
Guest




Well, it still is in warranty. So I am gonna have it checked out
I thought (well no, I had this silly hope) I might just have pushed a wrong button and disabled those buttons somehow

thanks for the quick reply
08-24-2011, 09:14 PM   #4
Veteran Member
subeeds's Avatar

Join Date: May 2010
Location: Camden County, Ga.
Photos: Gallery
Posts: 333
You might try restoring the settings to factory default. Not sure it would help, but I think it's worth a try before sending it in for repair.

09-05-2011, 07:46 PM   #5
Inactive Account




Join Date: Sep 2011
Posts: 4
I too would be interested to know if resetting your K-x back to factory settings would resolve this issue? Please report back...
09-06-2011, 10:30 PM   #6
Pentaxian




Join Date: May 2010
Photos: Albums
Posts: 652
QuoteOriginally posted by First Poster Quote
LV, info, menu and the function buttons (not sure what those are called in English) are not working at all. Also the screen stays black, so I can not see my set up.
How to reset the camera to FC if the above are not working (taking out the battery will not do that)....................


Edit: K-x manual page 23) Screen goes blank if you press the Info button couple of times consecutively.
Just hopping that is what happened to your camera, otherwise what Adam said...

Last edited by ultraviolet; 09-06-2011 at 10:41 PM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
buttons, camera, info, pentax help, pictures, screen
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-x customizing buttons spanky Pentax DSLR Discussion 4 07-29-2011 05:47 AM
Help: Pentax 645 Mode Buttons Not Working 100% Of The Time topaz Pentax Medium Format 0 07-07-2011 11:55 AM
LCD Screen and buttons not working after a shot.. aliasant Pentax K-5 7 02-07-2011 11:24 AM
expanded iso...and green/af/ae-l buttons... grinchicago Troubleshooting and Beginner Help 4 04-22-2010 03:06 AM
Fn and playback buttons get locked? a101 Troubleshooting and Beginner Help 9 03-02-2010 10:24 AM



All times are GMT -7. The time now is 03:01 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top