Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-06-2011, 12:17 PM   #1
Unregistered
Guest




K2000 Does Not power on

The camera was shutting down after 3-4 pictures and I thought maybe the batteries were going dead. Then the camera would not power on at all. I put in fresh batteries and it still will not power on. Is this a quick, easy, affordable fix? I'm way out of warrenty.

Thanks.

10-06-2011, 12:42 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,359
Are you using rechargeable batteries? If so, try with regular AA's. Your rechargeables might have worn themselves out.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

10-06-2011, 01:19 PM   #3
Unregistered
Guest




I am using AA Alkaline batteries.
10-06-2011, 01:52 PM   #4
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
I,m amazed you got any picutres at all from those. The manual specifically says those don,t wor, well, and that is indeed the case. if you like throwing money away on disposable, Energizer Lithiums are the only ones worth filling up landfills with. But for anyone who prefes saving money and not filling landfills, rechargeables are the way to go - see the many threads in thebeginner,s and SSLR fourms and then see if you can find any reaosn to buy anything but Eneloops or similar low self-discharge "hybrid" rechargeables.

10-06-2011, 02:41 PM   #5
Veteran Member




Join Date: Dec 2010
Location: Central Kentucky
Photos: Gallery | Albums
Posts: 1,415
Mine was not shutting down but it refused to turn on the other day. After sitting for a few minutes it worked fine. I don't have a clue what happened. I am using Ni-cad MH
10-07-2011, 07:08 AM   #6
Unregistered
Guest




A couple of you guys smacked me down and you were correct. I charged up a set of rechargeables and everything is working fine.

Thanks for your advice.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, pentax help, power
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to power 540FGZ flash with Alienbees Vagabond mini II portable power? shadowbecomeswhite Flashes, Lighting, and Studio 2 07-25-2011 07:17 PM
K-r Power! FuturaDC5 Welcomes and Introductions 3 06-04-2011 05:26 PM
Power Problems mrsmeisel Troubleshooting and Beginner Help 7 01-05-2010 02:33 PM
Power cord for a TR Power Pack 2 Vern Pentax Camera and Field Accessories 4 12-06-2009 08:13 AM
K7 - Noise during Power on tohcp Pentax DSLR Discussion 5 10-15-2009 07:28 PM



All times are GMT -7. The time now is 04:27 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top