Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-05-2012, 02:16 AM   #1
curavon
Guest




K20d keeps scrambling SD cards

I now have a repeat problem with my k20d which I think other people may be having a similar issue with.

On numerous occasions now when I take an image, the camera light on the back blinks for an excessive amount of time whilst attempting to render the image to disk and then errors. The usual message I get is "Cannot display image". On nearly every occasion it happens, it scrambles the card with all of the images lost as nothing is viewable on either the camera or on the computer. I originally thought it was just a dodgy card but now it is happening to many cards of different brands.

I always format the card before using on each occasion and of late have not been deleting images on the go during a days shoot. This happened to 4 different cards over the past 2 weeks whilst away on holiday including one new scandisk card I bought whilst away. I have on occasion been able to use file recovery software to restore images from a damaged card but as I use burst mode occasionally if it errors on the first shot the next shot can destroy what is on there with no chance of recovery.

Is there anyone out there with this exact same issue as I am playing Russian roulette every time I take a photo at the moment?

Thanks for taking time to read through this

Richard

06-05-2012, 01:08 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,030
Hi Richard,

Have you formatted the cards in-camera? That's your best best to make sure the filesystem is in order.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

06-05-2012, 06:39 PM   #3
Site Supporter
forensicscientist's Avatar

Join Date: Jun 2008
Location: DFW Texas and Maine - I commute :)
Posts: 889
What type of cards?

I had a similiar issue when I had K20's and used a Kingston card. It was very repeatable. I never had the issue on other cards, and when using the Kingston in either my K-X or K5, no problems at all. Have no idea what the cause was...or how to solve your issue. All I can add is what happened to me....

Mark
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, cards, image, images, issue, occasion, pentax help, recovery, shot, time, whilst
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
SD cards speed on K20D test Edvinas Pentax Camera and Field Accessories 5 03-19-2009 04:34 PM
SDHC cards & the K20D dazman Pentax Camera and Field Accessories 7 07-07-2008 11:46 AM
best 4 GB (or 8 GB) cards for K20D?? WMBP Pentax Camera and Field Accessories 23 04-29-2008 05:01 PM



All times are GMT -7. The time now is 05:31 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top