Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-24-2012, 02:27 AM   #1
hananias
Guest




Pentax kx aperture dial not working

I was shooting around with various lenses (kit & auto, and prime lenses) All of the sudden I put in an auto lens (kit lens) but the aperture displayed "f--"
I couldn't control the aperture at all. In live or video mode if in auto focus, the camera shuts off showing error "Pressing the shutter release button while Live View is on starts movie record function"... I have to press menu button or shut off or switch shooting mode to take out the error screen.
This is very frustrating! Now I can only use manual lenses or auto lenses in manual!!! Please any help will be appreciated.

09-24-2012, 08:29 AM   #2
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,535
Your lens aperture control has been moved off the "A" setting. Put it back and all will be well.
09-24-2012, 09:56 AM   #3
New Member




Join Date: Sep 2012
Posts: 3
thanks for the reply... since i had no idea which pin it is, I don't know if I'm moving the correct one or not. Is it the one on the bottom right side of the camera.
It is kind of flat with a point on the top? The pin is popping out now. My settings in the menu "Using aperture ring" = Permitted.
I have tried lots of lenses... but only One lens works correctly. That is an old Pentax 28-80 f3.5-5.6 Macro Lens! I never use it cause it's old and doesn't manual focus or zoom in out smoothly (very old)... but auto works slowly but surely.

Both kit lens 18-55mm & 50-200mm, also a Sigma 28-70mm f2.8 don't work properly (which is the lens I mainly use!!!). When the camera is in camera mode (not movie or live mode) making changes on aperture (manual mode) the properties don't change at all on the LCD display... but thru the view finder, I can see the changes displayed there. But again, outside nothing... even worst sometimes gets glitchy and starts panicking changing numbers like crazy, until I stop changing the aperture.

I have no idea what else to do! Any other suggestions, or perhaps explain in details how to fix the aperture pin correctly. Thanks in advance
09-24-2012, 10:39 AM   #4
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,535
Your latest post tells me that your on/off switch might be stuck in the O position past the On position, or you are inadvertently holding it there. If you can see the lens stop down through the finder, your camera is previewing the depth of field. Turn the camera off, then turn it on, but go only one click. Try again. If your shutter dial is not returning automatically to the On position when you take your finger off the on switch, repairs might be in order. I did not realize that your DA lenses were acting up as well.

I don't have Live View on my camera, so I do not know if you have a Live View switch that you turn on and leave on. If you do, turn it off. You can also try removing the batteries from the camera (with the power switch turned off) and leaving it for a while before putting the batteries back in and turning it on.


Last edited by Canada_Rockies; 09-24-2012 at 10:45 AM.
09-24-2012, 04:18 PM   #5
New Member




Join Date: Sep 2012
Posts: 3
Thanks again for your in put in my situation. While my camera is OFF, thru the finder I see perfectly fine thru it. The lens is focused were it was left at in the previous use. With 18-55mm Kit lens, when I turn it ON the screens starts up displaying Shooting Mode (since I'm troubleshooting Aperture I'm using Av Mode)
everything seems normal... With out pressing shutter, the camera adjusts properly to light changes while moving camera around different parts of my room. But when I manually adjust the Av using the dial... No changes to the Av are apparent in the LCD, but my Shutter is adjusting according to my dial movements. When I peek thru the finder, I see my Av moving around from f3.5 ~ f22...etc. and all the while the LCD doesn't move.

When I enter Live Mode, the Av says "F--" but again the Shutter is affected by my moving around.
Seems to be working oddly!

The real trouble comes when using video mode (which I love doing occasionally). Just starting up the on Video Mode, got the "F--" (same as Live Mode), I look thru the finder, but of course is blacked out from the shutter being open for live viewing.
When I try to focus (auto focus) on something the "Pressing the shutter release button while Live View is on starts movie record function" pops up!
Have to shut off and start up again. The crazy thing is that, when I start up and switch to manual focus... it doesn't crash as often as AutoFocus, but when I start recording, it is very dark and grainy!!! Meaning the Av is close to probably f22... so the iso cranks up to highest and get the grain.
I think I might have to get this thing checked out in a local Camera Shop today after work.

If anybody has other trouble shooting tips, please post them up. I love to try to get this little beast running fully again.
09-24-2012, 09:35 PM   #6
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,535
Sounds like it needs to be looked at by someone professional. Bummer.
09-25-2012, 12:17 AM   #7
New Member




Join Date: Sep 2012
Posts: 3
that is what I was afraid of... sigh...
actually I did go to a local store, and they think is a problem with the camera's computer components (I don't know how to describe) but probably some glitch in the software of the camera is not harmonizing or using correctly the hardware : (
So I guess is time to start saving for the upgrade... and admit defeat, sell the KX for a little more than free.
Still works for Pictures, just not video : (

Thanks for your patience, help and advices : )
10-05-2012, 06:41 PM   #8
Dash B
Guest




Pentax K-x Owner

I have the exact same problem. I sent mine back last year just before the warranty and Pentax sent it back saying they couldn't duplicate the problem. They "cleaned it and gave it a firmware upgrade". But same issue so why couldn't they duplicate the problem? Anyway I tried what the previous poster said about the A ring in the menu setting even though my Tamron lens is always set to the A ring. When I toggled it from prohibited to permitted and the moved the lens off the A setting to some of the other settings then back again. All of a sudden the dark recording in movie mode returned to normal. I still have the F--- message but at least I can use that lens again. My problem is the stock Pentax lens. It still records movie mode way to dark no matter what I do and will only show the F stop in the viewfinder not in the LCD. It takes pictures fine though. But movie mode? Nope. So for now only my Tamron with the A setting works. I already plan to purchase my next camera from one of their competitors (one of the big 2 that starts with a C). I'll give this one to my kid.

10-10-2012, 07:20 PM   #9
New Member




Join Date: Jan 2011
Location: Melbourne
Posts: 22
I had the same problem with a 170-500 lens bought off ebay. If the lens was held in a certain way, the AV setting would reappear. (This is a little easier to do with a long lens than the shorter kit lens). when held with F--- appearing, the lens was still usable and the camera would respond to various light intensities.
But it told me the problem lay with the mount on the lens. The mount was bent just so slightly that the contact pin was getting erratic contact. The mount was replaced and all good since.

As this is occurring on two lenses for you, I wonder if the same problem has occurred, but instead on the mount on the camera. Is it possible a lens was knocked whilst mounted to the camera, or maybe a bit too rough when changing lenses? Is a mount on another manual lens damaged, which in turn damaged the camera mount (which you wouldn't know till mounting an auto lens)?

Cheers Andrew
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, auto, button, camera, error, kit, lens, lenses, mode, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-x e-dial not working siva.ss.kumar Pentax DSLR Discussion 2 03-12-2012 07:03 AM
Bulb Mode, rear dial (aperture) not working mikeSF Pentax K-5 2 11-28-2011 09:09 AM
Back control dial not working? Javaslinger Pentax K-5 4 07-19-2011 06:10 PM
K-7:Rear e-dial not working correctly bulacawa Pentax DSLR Discussion 11 05-29-2010 04:13 AM
Rear Dial not Working Rondec Pentax DSLR Discussion 4 04-05-2010 02:58 AM



All times are GMT -7. The time now is 09:50 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top