Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-07-2012, 10:14 AM   #1
Xyq6Cmtx
Guest




mirror problem on k10?

I was taking pics the other day, and the camera just stopped taking pics! It would focus, but when the button was fully depressed, the camera would make a small buzzing sound and not take the picture. Fresh batteries, changed lens, changed settings and nothing made any difference. Is the mirror just not tripping for some reason? Has anyone ever had this problem? It's a k10d and I have never had any problems whatsoever with it until now!
Thank you!

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, mirror, pentax help, pics
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K5 sent back for 'mirror slop' problem but came back with much worse problem captainbert Troubleshooting and Beginner Help 24 07-10-2012 01:08 PM
K10 Mirror mechanism smurfy27 Pentax DSLR Discussion 3 01-25-2012 01:13 PM
Problem with the Av mode on K10 sewwhat Pentax DSLR Discussion 16 04-10-2010 01:42 PM
K10 shutter/mirror noise Kim Price Pentax DSLR Discussion 9 01-27-2009 11:36 AM
Strange problem on my K10! help mikerigel Pentax DSLR Discussion 2 06-26-2008 07:11 AM



All times are GMT -7. The time now is 02:00 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top