Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-19-2013, 11:48 AM   #1
Gerald
Guest




Pentax K-X not working after a lens change.

My Pentax K-X was working fine until I changed the lens on it. Now it will not focus or release the shutter even with the orginal lens on it. Other functions seem to be working fine. What could be causing this problem?

02-19-2013, 12:00 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 49,785
QuoteOriginally posted by Gerald Quote
My Pentax K-X was working fine until I changed the lens on it. Now it will not focus or release the shutter even with the orginal lens on it. Other functions seem to be working fine. What could be causing this problem?
Is it a manual lens? If so, make sure the aperture ring is set to "A", or see this article: https://www.pentaxforums.com/forums/pentax-lens-articles/110657-how-use-meter...k-x-k-7-a.html

If not, then try cleaning the lens mount as well as the contacts on the lens itself.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, KEH, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

02-19-2013, 02:35 PM   #3
Gerald
Guest




Pentax K-X not working after lens change

Both lens a auto focus lens.
02-19-2013, 03:11 PM   #4
Site Supporter
Site Supporter
sergysergy's Avatar

Join Date: Jan 2011
Photos: Gallery
Posts: 4,099
Clean the contacts and make sure the lens went all the way in.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-x, lens, pentax, pentax help, pentax k-x
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
after lens change K7 would not shoot?? phantomfantom Troubleshooting and Beginner Help 13 12-23-2012 09:34 PM
K-30 - control wheels not working after taking a picture rukeslarer Troubleshooting and Beginner Help 5 10-27-2012 09:01 AM
K-x LCD not working after firmware 1.02 upgrade navilink Troubleshooting and Beginner Help 5 08-10-2011 03:02 AM
Pentax k-x hotshoe not working in manual mode crimespree Troubleshooting and Beginner Help 6 06-17-2011 05:52 PM
Pentax k-x not working with my tamron lens, or older pentax lenses Evanmackmusic Pentax DSLR Discussion 5 06-04-2010 03:24 AM



All times are GMT -7. The time now is 11:00 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top