Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-12-2013, 04:47 PM   #1
ctcul8r
Guest




istDL black pictures

camera goes through all the correct motions, no pictures show on the screen or on the card. Batteries are freshly charged, sd card formatted, worked fine until today. What to do?

07-12-2013, 04:58 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,397
Sounds like a broken camera. Might be time to get a new one, like the k30 for instance! It would be more costly to repair your old one.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

09-03-2013, 02:16 PM   #3
New Member
cliffordapotter170's Avatar

Join Date: Sep 2013
Location: Raleigh, NC
Posts: 6
*istDL black pictures

Same issue here - All other operations on the camera have been normal, point, focus, shoot, etc..... but after the shot is taken, no image shows up in the "Preview View Finder" on
the back of the camera or on the SD Card - just a complete BLANK / Black image.

I called Tech Support and followed all their "Step-By-Step" Trouble shooting but still have not been able to obtain an image after taking a picture.
Before I send it to Pentax for diagnosis & possible repair (or not able to repair), I would like to see if anyone else has any other ideas.

Here is a list of ALL Steps Taken:

> Checked ALL SD Cards and ALL were "Unlocked" and able to be seen on a computer - as well as being able to view Previous images on the card on BOTH Computer and when inserted into the *istDL camera.
Actually tried several SD Cards of all different file sizes, types (Regular & Micro-SD with Adapters),
reformatted, and fresh out of the wrapper, etc.

> Replaced ALL Batteries several times with FRESH ones (ALL were checked with a battery tester) - several times
replacing with Standard AA's, Lithium's, and Fully Charged Rechargeable "RCR-V3 Li-ion batteries"

> Tried ALL shooting/exposure Modes on camera along with the EVERY step taken.

> Next - Then upgraded the Firmware on the camera from it's Original Current Version: 1.00 to the Latest / Current Version of 1.03.
Followed ALL the Download & Installation steps as documented and ALL were successful, but this still did not fix the "No Image" issue after taking a picture.

> Finally - Tried Resetting the entire camera back to the original Defaults or what it was straight out the box, as well as running a "Sensor Cleaning" - But still
no positive results when it came to obtaining an image after taking a picture.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, pentax help, pictures
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Formerly functional *istDL is now shooting black frames Jeremy Troubleshooting and Beginner Help 26 09-10-2013 10:08 AM
Black and White Pictures Nickster42m Pentax K-5 5 07-02-2013 08:34 AM
black dots in my pictures hadi Troubleshooting and Beginner Help 16 06-16-2012 05:04 AM
*istDL Takes Black Pictures tpx60s Troubleshooting and Beginner Help 26 01-29-2011 08:54 AM
istdL pale pictures gasket Troubleshooting and Beginner Help 16 07-10-2009 07:32 AM



All times are GMT -7. The time now is 08:49 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top