Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-11-2013, 01:42 PM   #1
Ole Odder
Guest




K-mount trouble

Hi

I have found a third party zoom lens called Travenar. It works fine on my K5, but I cannot disconnect it. When I press the button I can turn the lens counterclockwise as usual, but I cannot separate the lens from the camera! Please help.

11-11-2013, 01:44 PM   #2
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,770
A picture of the lens, especially any information printed on it would help. You might have to sign up for an account to post pictures though.

Post anything that is printed on the lens, on the body or on the front. I have a good guess what is wrong but need to confirm.
11-11-2013, 07:50 PM   #3
Site Supporter




Join Date: Sep 2011
Posts: 1,369
QuoteOriginally posted by Ole Odder Quote
Hi

I have found a third party zoom lens called Travenar. It works fine on my K5, but I cannot disconnect it. When I press the button I can turn the lens counterclockwise as usual, but I cannot separate the lens from the camera! Please help.
Likely it was a ricoh/pentax mount with the ricoh pin that gets stuck in the AF screw connection. Try engaging and disengaging af as you give it a turn
11-12-2013, 12:12 AM   #4
Ole Odder
Guest




On the front is printed: Travenar MC 1:4.0-5.6 f=60-300mm No. 6780810 62 AUTO ZOOM

On the aparture ring is printed: (A)P.22 16 ... 4 KR

Left to the (A)P is a little pin.

If you need pictures let me know.

Thanks for helping.

11-12-2013, 12:27 AM   #5
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,770
KR is the key. It is a ricoh K-mount and these often have an additional pin that gets stuck in the screwdrive slot of newer cameras.

It will come off but it might take some work. Try wiggling the lens off as you move the camera lever from auto focus to manual focus and back. You can also try an automotive feeler gauge to lift the pin.

Do a search on this forum for "ricoh pin" and you will find numerous posts about it.
11-12-2013, 01:56 AM   #6
Ole Odder
Guest




Hip hip hurra - it worked!

More thanks for helping :-)
11-12-2013, 08:11 AM   #7
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,770
Glad you got it sorted. In many cases that pin can be removed so you can use the lens. Should be a number of threads on how to do that.
01-23-2014, 11:22 AM   #8
New Member




Join Date: Jan 2014
Posts: 3
I had the same problem with a different lens and this helped me out too. Thanks!

01-23-2014, 11:36 AM   #9
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,770
QuoteOriginally posted by jamogafanny Quote
I had the same problem with a different lens and this helped me out too. Thanks!
You are welcome, and welcome to the forum as well. Hope you stick around.
02-10-2014, 02:09 PM   #10
New Member




Join Date: Feb 2014
Posts: 19
QuoteOriginally posted by jatrax Quote
You are welcome, and welcome to the forum as well. Hope you stick around.
Jatrax,

Where were you (and this forum) when I did that exact same thing?! You could have saved me $75 and lots of humiliation. Ha! I now have all of my Ricoh lens stashed away, which really lends itself to the whole debacle not happening again.
02-10-2014, 02:39 PM   #11
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,770
QuoteOriginally posted by JDelaware Quote
I now have all of my Ricoh lens stashed away, which really lends itself to the whole debacle not happening again.
There is a good write up on how to non-destructively remove the pin here: theatre of noise: Ricoh Lenses On Pentax Cameras -- The Ricoh Pin Fix

And welcome to the forum. Have a look around at the article section and the lens database, there is so much Pentax information here.
02-10-2014, 02:47 PM   #12
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,872
QuoteOriginally posted by JDelaware Quote
Jatrax,

Where were you (and this forum) when I did that exact same thing?! You could have saved me $75 and lots of humiliation. Ha! I now have all of my Ricoh lens stashed away, which really lends itself to the whole debacle not happening again.
Only a few Ricoh lenses, or third party lenses, are a danger. Removal of the 'Ricoh' pin is a completely unnecessary step for most lenses.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, lens, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Best 28mm lens for K-Mount? senchi Pentax Film SLR Discussion 33 07-06-2014 11:41 AM
Trouble Tethering K-30 hatchtp Troubleshooting and Beginner Help 4 04-22-2013 01:54 PM
trouble with an AF lens dankoBanana Pentax SLR Lens Discussion 12 02-06-2013 09:55 PM
trouble brewing: I like my kit! jimr-pdx Pentax SLR Lens Discussion 8 05-10-2012 10:05 AM
Trouble with screw Mount lenses golfing rob Troubleshooting and Beginner Help 12 04-13-2009 11:13 AM



All times are GMT -7. The time now is 05:37 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top