Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-12-2014, 06:22 PM   #1
Ray_Bombadil
Guest




"Solar Eclipse" on K10d Images

Just bought a K10d as is on eBay. Was fully aware that images from the camera had yellow discoloration on the upper left corner. This would be my first DSLR; so I was fully prepared to accept the sensor flaw in order to save some money, and just use it as a learning camera.
When I received the camera, I could see that images had a black smudge on the upper left corner, surrounded by yellow. It reminds me of a solar eclipse. I flipped the mirror up to look at the sensor surface (I suppose I was actually looking at the low-pass filter). No obvious problem that I could see. But the next 4 or 5 images after that had no discoloration at all. I was thrilled, but thereafter the problem returned, except that occasionally the discoloration was only a yellow smudge in the center of the image. Now I wonder whether there is a simple solution to the problem. Thanks for any advice.

03-12-2014, 07:26 PM   #2
Veteran Member




Join Date: Jun 2010
Location: Manteca, CA
Photos: Gallery | Albums
Posts: 1,653
Does the defect become more clear if you change your aperture to f/11 or more?
03-12-2014, 07:49 PM   #3
Veteran Member




Join Date: Jan 2009
Location: Brisbane
Photos: Gallery
Posts: 1,421
post some example images up
03-13-2014, 03:37 AM   #4
Veteran Member
chromo's Avatar

Join Date: Feb 2010
Location: North Coast NSW
Photos: Gallery | Albums
Posts: 563
Sounds like there's a foreign object floating around inside the camera.

03-13-2014, 09:30 AM   #5
New Member




Join Date: Mar 2014
Posts: 1
Image Samples

These three are consecutive images. Aperture does not appear to make any difference. Most of the time, the dark smudge in the corner is solid black and more substantial.

Maybe there is liquid trapped over the sensor. Is it feasible/advisable to remove the low-pass filter?
Attached Images
View Picture EXIF
PENTAX K10D  Photo 
View Picture EXIF
PENTAX K10D  Photo 
View Picture EXIF
PENTAX K10D  Photo 
03-13-2014, 11:12 PM   #6
Loyal Site Supporter
AquaDome's Avatar

Join Date: Jan 2014
Location: New Carlisle, IN
Photos: Gallery | Albums
Posts: 1,397
That looks like it could be liquid trapped between the filter and the sensor. Perhaps someone tried to clean their sensor with the big spray-bottle of Windex?
Theoretical treatment: Stand the camera on its edge so it can drain away from the center of the sensor and it might dry out eventually. Leave the lens and body cap off and put a sheet of newspaper over it to keep dust away.

---------- Post added 03-13-14 at 11:16 PM ----------

I don't advise attempting to operate on the sensor. I have done it to a Sony and a Nikon to convert to IR. It is major camera surgery. I couldn't imagine doing it to a camera I liked.
03-13-2014, 11:37 PM   #7
Site Supporter
forest_bear59's Avatar

Join Date: Oct 2013
Location: Idstein (near Frankfurt)
Photos: Gallery
Posts: 113
If it shows up stronger the more consecutive pictures You take I assume it has to do with sensor warming up too much.
03-14-2014, 12:29 AM   #8
Loyal Site Supporter
AquaDome's Avatar

Join Date: Jan 2014
Location: New Carlisle, IN
Photos: Gallery | Albums
Posts: 1,397
Does the K10D have a dust-removal option in the menu that vibrates the sensor? I wonder if that would shake things up a bit.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, corner, discoloration, images, k10d, pentax help, sensor, smudge
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Post your "Park Bench" "or "Picnic Table" images tessfully Mini-Challenges, Games, and Photo Stories 1345 1 Day Ago 04:22 PM
Optical differences between Pentax "K", "M", and "A" lenses 6BQ5 Pentax SLR Lens Discussion 31 01-10-2014 01:02 PM
K10D owner moving to K-7: Early "Review"/thoughts on the K-7. (link to Images) pcarfan Pentax DSLR Discussion 6 08-02-2009 07:59 PM
Pentax "A" lens and "F" 1.7X converter on K10d yyyzzz Pentax SLR Lens Discussion 4 07-09-2009 05:04 AM
New K10D, starting to record "Black" images intermittently mhuterer1 Pentax DSLR Discussion 13 12-28-2007 12:16 PM



All times are GMT -7. The time now is 01:05 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top