Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-05-2014, 02:05 PM   #1
Michael Aoun
Guest




Virus on my SD card

Hi all, my daughter asked me my USB for one day to manage some files, when she gave it back to me and tried to open all the files in it turn into a short cut, and when I clik on one of them a new window is opened. The same problem moved to my SD card and I was afraid to put it back into my cam. I scaned both the computer and the SD card and the result was no infection. I put the SD card in another digital old cam, and each time I rolled 5 or 6 pictures I get an error reading. What cam I do? Even if I buy a new SD I will obliged to put into the computer to copy the photos and the same problem will appear again. Help me plz solve this problem Thank you in advance, with respect to all.

04-05-2014, 02:41 PM   #2
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,287
No virus is going to infect your camera, so to clean the SD card try putting it in the camera and formatting it. But putting it back in your computer will then re-infect it.

The virus on your computer is another issue and depending on your computer, your operating system and your computer skills may require additional anti-virus software or a trip to the repair center to get it removed.

If you are not running good, current anti-virus software on your computer you are potentially at risk all the time.
04-05-2014, 03:08 PM   #3
Veteran Member
chromo's Avatar

Join Date: Feb 2010
Location: North Coast NSW
Photos: Gallery | Albums
Posts: 563
How do you know you have a virus ?
Do you or your daughter use the click and drag method to copy files ?
Click and drag can do strange things sometimes and I have learnt to always use right click copy/paste method to avoid errors.

Just a though, put the SD card back into that computer then open the recycle bin. If your files are in there just highlight the files, right click and click restore and they should end up back on your card.

Having said that, It does sound like a faulty SD card.

Last edited by chromo; 04-05-2014 at 03:25 PM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
cam, camera, card, computer, files, pentax help, sd
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with my SD card Ibtissam Troubleshooting and Beginner Help 16 04-20-2014 10:45 AM
Macros not on SD card Greg Schultz Visitors' Center 2 02-24-2014 05:08 PM
For Sale - Sold: Fuji F550EXR, 4GB Eye-Fi SD Card, 4GB SD Card, 2 Batt + 6BQ5 Sold Items 3 09-16-2013 08:19 PM
Crap! My new class 10 sd card run much slower than my old class 4 sd card... liukaitc Pentax Camera and Field Accessories 15 05-31-2011 01:39 PM



All times are GMT -7. The time now is 05:41 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top