Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-20-2014, 11:16 PM   #1
Kevin Wnuk
Guest




M mode on K-30 with 50mm DA lens

When I try to use the M mode, I can only take one shot!

If I want to adjust the speed or aperture, I need to go off M and then return to M.

Is this a lens / camera flaw?

Or am I doing something wrong?

Thanks!

06-20-2014, 11:38 PM   #2
Veteran Member
OregonJim's Avatar

Join Date: Mar 2009
Location: Willamette Valley, Oregon
Posts: 1,329
QuoteOriginally posted by First Poster Quote
When I try to use the M mode, I can only take one shot!

If I want to adjust the speed or aperture, I need to go off M and then return to M.
Just press the shutter button half way to re-activate the light meter. Or, rotate the front or rear dial. That's what you're doing by changing modes as well.

Last edited by OregonJim; 06-21-2014 at 12:00 AM.
06-20-2014, 11:44 PM   #3
Site Supporter
altopiet's Avatar

Join Date: Sep 2010
Location: The Great Karoo, South Africa
Photos: Gallery | Albums
Posts: 1,915
QuoteOriginally posted by Kevin Wnuk Quote
When I try to use the M mode, I can only take one shot!

If I want to adjust the speed or aperture, I need to go off M and then return to M.

Is this a lens / camera flaw?

Or am I doing something wrong?

Thanks!
What is your ISO setting M or Auto?

EDIT: With AF DA16-45, in M, with Auto ISO you actually get TAV and can change T and AV...with ISO on manual setting, fixing specific ISO, ISO is fixed and T and AV can still be ajusted...I don't understand the fact that you can only take one shot?
06-21-2014, 12:10 AM   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,959
QuoteOriginally posted by Kevin Wnuk Quote
When I try to use the M mode, I can only take one shot!

If I want to adjust the speed or aperture, I need to go off M and then return to M.

Is this a lens / camera flaw?

Or am I doing something wrong?

Thanks!
Read this article:
https://www.pentaxforums.com/forums/54-pentax-lens-articles/110657-how-use-me...k-x-k-7-a.html


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

06-21-2014, 12:34 AM   #5
Veteran Member
OregonJim's Avatar

Join Date: Mar 2009
Location: Willamette Valley, Oregon
Posts: 1,329
QuoteOriginally posted by Adam Quote
Read this article:
How to use/meter Manual & M42 Lenses on all Pentax DSLRs (K-5, K-r, K-x, K-7...)
But he said he was using a DA 50...
06-21-2014, 12:59 AM   #6
Site Supporter
altopiet's Avatar

Join Date: Sep 2010
Location: The Great Karoo, South Africa
Photos: Gallery | Albums
Posts: 1,915
QuoteOriginally posted by OregonJim Quote
But he said he was using a DA 50...
+1, but AFAIK the DA50 do not have a switch on the lens to disengage AF, which turns it into a "manual" lens, so he should get the same setting options I've mentioned, I just checked on my K-30. I can't understand the fact that he can only take one shot....
Also out of Adam's link "K-30, K-50, K-500 and K-01 users: make sure you also set your green button "action in M/TAv Mode" to Tv SHIFT. This is found under the button customization menu (page 3 of the main menu) on the K-01 or as a custom function on the K-30, K-50 and K-500. Also, avoid auto ISO."


06-21-2014, 01:37 AM   #7
Veteran Member
OregonJim's Avatar

Join Date: Mar 2009
Location: Willamette Valley, Oregon
Posts: 1,329
QuoteOriginally posted by altopiet Quote
+1, but AFAIK the DA50 do not have a switch on the lens to disengage AF, which turns it into a "manual" lens, so he should get the same setting options I've mentioned, I just checked on my K-30. I can't understand the fact that he can only take one shot....
Also out of Adam's link "K-30, K-50, K-500 and K-01 users: make sure you also set your green button "action in M/TAv Mode" to Tv SHIFT. This is found under the button customization menu (page 3 of the main menu) on the K-01 or as a custom function on the K-30, K-50 and K-500. Also, avoid auto ISO."
Ok, I'm totally lost now. What does AF have to do with setting exposure in manual mode? Or green button use with a fully automated DA lens?
06-21-2014, 02:20 AM   #8
Site Supporter
altopiet's Avatar

Join Date: Sep 2010
Location: The Great Karoo, South Africa
Photos: Gallery | Albums
Posts: 1,915
QuoteOriginally posted by OregonJim Quote
Ok, I'm totally lost now. What does AF have to do with setting exposure in manual mode? Or green button use with a fully automated DA lens?
Sorry, you're correct, I had a blond moment, trying to think why he can't take another shot...

Perhaps it's better to wait for OP to clarify exactly what he's doing and at what settings...

06-21-2014, 07:54 AM   #9
New Member




Join Date: Jun 2014
Posts: 1
Manual dials don't work after one shot.

QuoteOriginally posted by OregonJim Quote
Just press the shutter button half way to re-activate the light meter. Or, rotate the front or rear dial. That's what you're doing by changing modes as well.
Sorry! My question was not well written...and I've found the cause of the problem!

My K-30 was on M mode, using a DA 50mm lens. The ISO was not on auto. I'd adjust the speed and aperture to my liking and take a shot.

Problem - After taking the shot, I couldn't adjust the speed or aperture. I'd take another pic at the same "frozen" setting...and then be able to adjust the dials once more. So, ever second shot was adjustable!

Why? The Exposure Bracketing was on! (That's what I get for buying a reduced price demo model!)

So, all is good now!

Thanks guys!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50mm da, camera, k-30 with 50mm, lens, mode, mode on k-30, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-30 live view overexposed in M mode maltfalc Pentax K-30 & K-50 23 04-24-2014 04:00 PM
Aperture ring with manual lens on K-30 Tsuken Pentax K-30 & K-50 12 11-30-2013 09:19 PM
Pentax SMC M 50mm on K-30: Blue Tint Schmidt Pentax DSLR Discussion 15 07-28-2013 11:13 AM
K-30 Live View display in M mode Ronnie B Troubleshooting and Beginner Help 2 01-14-2013 04:07 PM
K-30 Video, Using SMC m 50mm f1.4 Manual Lens II Welfl Pentax K-30 & K-50 8 08-26-2012 04:32 AM



All times are GMT -7. The time now is 12:13 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top