Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-14-2015, 07:06 AM   #1
Type3
Guest




K-x Power Problem?

Hi there.

I've been using a K-x for the last 4 years, recently it's developed this fault. After turning on the camera the LCD screen will start flickering whilst it's set up in image taking mode. The problem is often worse when in playback mode for viewing images, the image will either display off centre with parts missing, or with the left hand side of the image displaying on the right with the right hand side of the image on the left. The screen will then usually go either black and unresponsive, or display vertical coloured lines, or dark green with light coloured lines. After a few seconds all goes black and no amount of button pushing changes this. Even switching the off button does not turn the camera off straight away, it will often take 10-20 seconds before the blue power light goes out. I would assume it's either a battery, connection or power supply problem? It has been used with Energizer AA mAh batteries, either 2450 or 2000 mAh. They are charged with an 'instant' 1 hour charger, not the best option I know but the camera has been good for 200-350 images per charge with this battery/charger combination for these past years and has been fault free. The charger itself is also only a few months old. I use two sets of these batteries, one set is only a few weeks old so I'd discounted it being a low battery problem. All battery sets were of course charged. The metal battery connections seem clean as the camera has not been used in extreme conditions.

I was thinking of trying eneloops, plus a new slower charge charger, as I believe this is what it would run on best? But there seems little point in paying out for these if it's a different issue, as any replacement camera will be unlikely to use AAs.

Any thoughts? Thanks!

07-14-2015, 07:09 AM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,950
Try different batteries- preferably just conventional alkaline or lithium- to verify that it's indeed a battery issue. It could of course also be a bigger hardware problem, so I wouldn't worry about replacing your rechargeable AA setup until we know what's going on. Eneloops are a fairly popular choice among our users, with that said.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

07-14-2015, 07:26 AM   #3
New Member




Join Date: Jul 2015
Posts: 5
QuoteOriginally posted by Adam Quote
Try different batteries- preferably just conventional alkaline or lithium- to verify that it's indeed a battery issue. It could of course also be a bigger hardware problem, so I wouldn't worry about replacing your rechargeable AA setup until we know what's going on. Eneloops are a fairly popular choice among our users, with that said.
Righto. Thanks Adam, will do. Shall let you know the results.
07-15-2015, 05:05 PM   #4
Senior Member




Join Date: Mar 2010
Location: Oklahoma City
Photos: Albums
Posts: 101
I have this problem periodically with my k-x, even turning it off doesn't do anything. I just take out the batteries and put them back in and turn the camera back on and it functions normally. It has been doing this for the past year or so. Oh and I have been using the eneloops since I bought the camera....4 years ago or so.

07-16-2015, 12:00 AM   #5
New Member




Join Date: Jul 2015
Posts: 5
QuoteOriginally posted by trevorgrout Quote
I have this problem periodically with my k-x, even turning it off doesn't do anything. I just take out the batteries and put them back in and turn the camera back on and it functions normally. It has been doing this for the past year or so. Oh and I have been using the eneloops since I bought the camera....4 years ago or so.
Thanks for replying. Sounds like it isn't a battery issue then. I have to take the batteries out sometimes too to turn it off, but often if I turn it straight back on it will still flicker and I'll be lucky to get 1 or 2 shots before it freezes up again. Some days however I can get a dozen or 2 dozen shots where everything seems fine, then it's suddenly stops again. It seems to go wrong more when in playback mode for reviewing captured images, so I've stopped it going to review after taking an image, but that only works sometimes however. I can only imagine that playback mode requires more power and this is where the camera's fault lies, somewhere to do with not being able to maintain a steady high enough power outage; but that feeling is from someone who is far from an electrician!
07-16-2015, 04:24 AM   #6
Site Supporter




Join Date: May 2012
Location: Adelaide
Photos: Gallery | Albums
Posts: 1,081
I had Energizer rechargables for a while in my K-x but didn't get a real long life out of them. Since then have used Eneloops. Have never seen a problem with the display. Inadequate current supply from the batteries could be a factor though with what you have experienced. Agree with other posters suggestions to try out alkalines or lithium. If the problem resolves, then the Energisers are in the frame as being suspect.
07-16-2015, 05:30 PM   #7
Senior Member




Join Date: Mar 2010
Location: Oklahoma City
Photos: Albums
Posts: 101
QuoteOriginally posted by Type3 Quote
Thanks for replying. Sounds like it isn't a battery issue then. I have to take the batteries out sometimes too to turn it off, but often if I turn it straight back on it will still flicker and I'll be lucky to get 1 or 2 shots before it freezes up again. Some days however I can get a dozen or 2 dozen shots where everything seems fine, then it's suddenly stops again. It seems to go wrong more when in playback mode for reviewing captured images, so I've stopped it going to review after taking an image, but that only works sometimes however. I can only imagine that playback mode requires more power and this is where the camera's fault lies, somewhere to do with not being able to maintain a steady high enough power outage; but that feeling is from someone who is far from an electrician!
Yeah, The only problem with my camera is that is has is the screen will have those weird lines and sometimes the screen goes completely blank. I usually just take batteries out and put them back in and the problem is solved. like I said this is really intermittent, but it maybe because I am using eneloops?? You may try specifying the actual battery type "Select Battery Type" in the menu. I think the default is 'auto' detect, but you can specify alkaline or lithium...

Hope you get your problem resolved.
07-17-2015, 02:25 AM   #8
New Member




Join Date: Jul 2015
Posts: 5
Thanks for sharing your experiences guys. Was out shooting yesterday, screen went all funny again with the lines, camera unresponsive. I opened the battery compartment door slightly, cutting the power supply, closed it back up again and it went on without fault for the rets of the day, around 50 shots. Ref: battery type I have tried selecting both Auto & Nimh, doesn't seem to alter how the camera performs. Will try getting a set of non rechargeable non Energizer batteries and see if it makes any difference.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, battery, button, camera, charge, charger, image, light, pentax help, power, sets
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax k-x problem brz Troubleshooting and Beginner Help 7 07-31-2015 09:42 AM
K-x has a problem photolady95 Troubleshooting and Beginner Help 5 09-04-2014 07:05 PM
Sanyo Eneloop Power Pack - 1 x Charger / 8 x AA / 2 x AAA / 2 x C-spacers / 2 x D-spa ultraviolet Pentax Price Watch 7 08-02-2013 09:18 PM
Power Zoom Lens on a K-x Alizarine Pentax SLR Lens Discussion 10 07-16-2013 09:19 AM
Pentax K-X Quiescent Power Drain srankin1826 Pentax DSLR Discussion 6 12-12-2010 03:23 PM



All times are GMT -7. The time now is 01:14 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top