Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-28-2016, 04:21 AM   #1
shem Ferguson
Guest




Power Issue

good day,
Am having an issue when I switch on my pentax wg-3 camera, Pantax comes on the screen and after approximately after 3 seconds I hear 3 quick beeps and it then powers off. Can you advise on the issue here?? the battery is fully charged.

shem

04-28-2016, 04:43 AM   #2
Moderator
Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 5,250
QuoteOriginally posted by shem Ferguson Quote
good day,
Am having an issue when I switch on my pentax wg-3 camera, Pantax comes on the screen and after approximately after 3 seconds I hear 3 quick beeps and it then powers off. Can you advise on the issue here?? the battery is fully charged.

shem
Moved to Troubleshooting and Beginner Help section.
04-28-2016, 04:49 AM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,999
QuoteOriginally posted by shem Ferguson Quote
good day,
Am having an issue when I switch on my pentax wg-3 camera, Pantax comes on the screen and after approximately after 3 seconds I hear 3 quick beeps and it then powers off. Can you advise on the issue here?? the battery is fully charged.

shem
It's possible that the battery is no longer holding its charge. I'd order another battery (D-li68 I believe) and see if that helps.

Was the camera working fine recently?

QuoteOriginally posted by MarkJerling Quote
Moved to Troubleshooting and Beginner Help section.
Can't do that because this is a guest post

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-28-2016, 05:53 AM   #4
Moderator
Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 5,250
QuoteOriginally posted by Adam Quote
It's possible that the battery is no longer holding its charge. I'd order another battery (D-li68 I believe) and see if that helps.

Was the camera working fine recently?



Can't do that because this is a guest post
Sorry Adam!

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax Q Power Up Issue Smash Pentax Q 30 02-24-2017 09:29 PM
K-3 Power-on issue rskura Pentax K-3 141 05-17-2016 04:10 AM
Pentax Q: Auto shutoff issue upon power on ecnerwal1201 Troubleshooting and Beginner Help 4 04-04-2015 02:18 AM
Smc fa 100-300 power zoom issue CigarLT Pentax SLR Lens Discussion 3 11-29-2013 02:58 PM
Power issue with Yongnuo Flashes/Eneloops philbaum Flashes, Lighting, and Studio 7 10-30-2012 10:21 PM



All times are GMT -7. The time now is 03:39 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top