Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-12-2019, 07:44 PM   #1
don nicholson
Guest




pentax ist D won't power on

wont start up. I put in new batteries but when I turn it on the battery symbol just flashes.

10-13-2019, 01:03 AM   #2
Site Supporter
Site Supporter




Join Date: Jul 2011
Location: Melbourne
Photos: Gallery | Albums
Posts: 542
QuoteOriginally posted by don nicholson Quote
wont start up. I put in new batteries but when I turn it on the battery symbol just flashes.
Normal alkaline batteries don't work well, I find Lithium cells work better or eneloop ( panasonic ) rechargeables seem to work too.
I hope that helps
10-13-2019, 04:52 AM   #3
Site Supporter
Site Supporter




Join Date: Sep 2006
Location: Mississippi, USA
Photos: Gallery
Posts: 780
Make sure battery contacts are clean. Fresh batteries. Exercise the on/off switch in case crude has formed.
10-15-2019, 12:51 PM   #4
Pentaxian
ChipB's Avatar

Join Date: Nov 2007
Location: Austin, TX area
Photos: Gallery | Albums
Posts: 2,268
QuoteOriginally posted by garywakeling Quote
Normal alkaline batteries don't work well, I find Lithium cells work better or eneloop ( panasonic ) rechargeables seem to work too.
I hope that helps
I second using Eneloop batteries - I've had lots of success with them.

10-15-2019, 10:50 PM - 1 Like   #5
Site Supporter
Site Supporter
MalcS's Avatar

Join Date: Jun 2011
Location: Virginia
Photos: Albums
Posts: 27
Had the same problem with my ist*D with a new set of lithium AAs. The fix was to put the AAs in a flash, charge it up, fire once, and then put the batteries back in the camera, after which it worked fine from then on. Not sure if this is a fault with the camera or what exactly, but it seems it doesn’t draw enough power to ‘wake up’ the new lithiums initially. If you don’t have a flash, any device that draws a bit of power should do the trick (assuming the problem you are having is the same). Wierd...
10-16-2019, 10:28 AM   #6
Pentaxian
ChipB's Avatar

Join Date: Nov 2007
Location: Austin, TX area
Photos: Gallery | Albums
Posts: 2,268
QuoteOriginally posted by MalcS Quote
Had the same problem with my ist*D with a new set of lithium AAs. The fix was to put the AAs in a flash, charge it up, fire once, and then put the batteries back in the camera, after which it worked fine from then on. Not sure if this is a fault with the camera or what exactly, but it seems it doesn’t draw enough power to ‘wake up’ the new lithiums initially. If you don’t have a flash, any device that draws a bit of power should do the trick (assuming the problem you are having is the same). Wierd...
Good tip - thanks for sharing!
10-16-2019, 09:51 PM   #7
Site Supporter
Site Supporter




Join Date: Jul 2011
Location: Melbourne
Photos: Gallery | Albums
Posts: 542
QuoteOriginally posted by MalcS Quote
Had the same problem with my ist*D with a new set of lithium AAs. The fix was to put the AAs in a flash, charge it up, fire once, and then put the batteries back in the camera, after which it worked fine from then on. Not sure if this is a fault with the camera or what exactly, but it seems it doesn’t draw enough power to ‘wake up’ the new lithiums initially. If you don’t have a flash, any device that draws a bit of power should do the trick (assuming the problem you are having is the same). Wierd...
OK I will keep that tip in my hint box, thank you
10-17-2019, 12:19 AM   #8
Pentaxian




Join Date: Jun 2010
Location: Genf
Posts: 736
I had same problem with my k-x some time ago. I did not manage to fix it

10-17-2019, 02:18 AM   #9
Site Supporter
Site Supporter




Join Date: Mar 2014
Posts: 135
I have an ist DS and it seems it powers on select type of batteries and not all. Eneloops have always been reliable. I have some different brand batteries and they dont work.
10-30-2019, 05:38 PM   #10
Site Supporter
Site Supporter




Join Date: Aug 2018
Photos: Gallery | Albums
Posts: 232
Make sure to check those contact. If you can't clean them send off for a service.
10-30-2019, 07:27 PM   #11
Moderator
Site Supporter
Loyal Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 12,315
QuoteOriginally posted by ChipB Quote
I second using Eneloop batteries - I've had lots of success with them.
Third. Eneloop black or white.
11-21-2019, 01:05 AM   #12
Veteran Member
Steve Beswick's Avatar

Join Date: Apr 2009
Location: Ontario, California
Photos: Gallery
Posts: 1,627
The IKEA rechargeable AA batteries work well in mine, if you happen to be near an IKEA.
11-22-2019, 11:34 AM   #13
Pentaxian




Join Date: Jan 2012
Location: United States
Posts: 651
The IST Dl is very finicky towards batteries. It would only accept fully charged batteries. Any Alkaline AA battery that was sitting around which lost its charge wouldn't turn on the camera. Try using a fresh charged rechargeable or the non-rechargeable Lithium (not Lithium-Ion rechargeable) and it should power on. BTW this question is how I ended up in PentaxForums and the rest is history.
11-22-2019, 11:39 AM   #14
Veteran Member
Steve Beswick's Avatar

Join Date: Apr 2009
Location: Ontario, California
Photos: Gallery
Posts: 1,627
I was thinking of my O.G. D, and it occurred to me that the D is the only Pentax model to have a separate clock battery. Is it possible that it is what is causing OP problems? Just an idea.....
11-22-2019, 02:15 PM   #15
Pentaxian




Join Date: Jul 2011
Photos: Gallery | Albums
Posts: 2,362
Had same problem with mine... I decided to just let it sit overnight with the batteries in it (off position) and it fired up the next day and has been fine since.
could be the wake up the battery thing, could be caps in the camera got lazy.

For what its worth, I've got an ancient gray Honeywell potato masher flash, and those old Nicad's and Caps still work!

So I guess you mileage may vary with older electronics.

Eric
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Pentax K-x + 18-55mm, Pentax K-50, Pentax-A 50mm, Pentax 55-300mm, Pentax 18-135mm PatronX Sold Items 10 05-04-2017 10:46 PM



All times are GMT -7. The time now is 05:26 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top