Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-26-2012, 11:15 PM   #1
Site Supporter
Biro's Avatar

Join Date: Jan 2009
Posts: 1,182
Q Manual Focus?

It's been a busy month at my house, what with Hurricane Sandy and all. I haven't had much time to play with and learn my Q since getting it. But today, I updated the firmware (which went just fine). Then, because I was all kinds of excited about focus peaking, I quickly looked into switching the camera to MF mode.

I followed the manual's instructions about activating MF in the control panel but the AF option is greyed out. If I go to focus settings in the menu, there are plenty of focus-method options but none for manual focus. However, if one attempts to manual focus by twisting the focus ring on the 01 prime, it works fine - just like quick-shift on some modern K-mount lenses (and the focus peaking is terrific!).

Am I missing something? Perhaps my mind is adled by a month of storm-damage control and recovery (and a lack of sleep). Is it supposed to work like this? Did the firmware update change anything? Maybe it's just the 01 prime? Frankly, if it's supposed to work this way, it would suit me just fine. I suspect I'm overlooking something very obvious.

11-26-2012, 11:23 PM   #2
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,797
Try a different mode other than Auto, SCN, BC - AV, TV, M, P should let you switch the focus mode.
11-27-2012, 05:43 AM   #3
Loyal Site Supporter
baro-nite's Avatar

Join Date: Aug 2011
Location: North Carolina, USA
Photos: Gallery | Albums
Posts: 4,364
Did you update the lens firmware as well?
11-27-2012, 07:45 AM   #4
Site Supporter
Biro's Avatar

Join Date: Jan 2009
Posts: 1,182
Original Poster
Doh! Switching out of auto into program, Av, TV or manual did the trick. Thanks. BTW, I am unaware of a firmware update for the 01 prime. But I'll check around to see if one exists.

EDIT: I've found all of the updates, installed version 1.01 for the 01 prime and 02 zoom... And then reinstalled version 1.10 for the camera. All seems well. I notice, however, that I have to turn the camera off and then on again after switching from AF to MF or back again before things get working properly. No real big deal but it struck me as a bit odd. Thanks for your help.


Last edited by Biro; 11-27-2012 at 08:31 AM.
11-27-2012, 09:32 AM   #5
New Member




Join Date: Apr 2012
Location: Maryland, USA
Posts: 8
You shouldn't have to turn it off when switching between MF and AF and back... I wish I could offer a suggestion but I've never experienced this. Perhaps you could explain in more detail what's not working properly that causes you to turn it off.
11-27-2012, 10:03 AM   #6
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,797
Agreed, you should not have to cycle the power. Does it work from the info screen?
11-27-2012, 12:05 PM   #7
Site Supporter
Biro's Avatar

Join Date: Jan 2009
Posts: 1,182
Original Poster
It works fine if I do it the long way via the menu. If I try to do it via the info button/control screen, it appears to make the switch but the screen goes black if I menu out via the info button again. I think the problem is I was hitting the info button to menu out of the control screen. But if I hit the menu button to menu out it's fine. A bit non-intuitive (I figured I'd use the same button to get out of the control panel as I used to get into it) but now that I know it works that way, it's fine.
11-27-2012, 12:15 PM   #8
New Member




Join Date: Apr 2012
Location: Maryland, USA
Posts: 8
QuoteOriginally posted by Biro Quote
It works fine if I do it the long way via the menu. If I try to do it via the info button/control screen, it appears to make the switch but the screen goes black if I menu out via the info button again. I think the problem is I was hitting the info button to menu out of the control screen. But if I hit the menu button to menu out it's fine. A bit non-intuitive (I figured I'd use the same button to get out of the control panel as I used to get into it) but now that I know it works that way, it's fine.
I see what you are saying. For what it's worth, I switch back and forth from AF to MF quite often. I use the info button to get to settings and since it is already selected on the last setting you used (again, since I use AF->MF most it is almost always on that setting) and one click of the wheel and I am on the opposite focus setting and then I usually just tap the shutter release button and it brings me right back into shooting mode.

I did try what you were saying and hit the info button again and I too got the black screen (I don't feel like it always did this... maybe something changed with the new firmware or maybe I just never noticed it.) However, I found that hitting the info button a second time brought it back out into shooting mode.

At the end of the day you will and should do whatever works best for you as far as changing settings goes. I mostly just wanted to give you some feedback on your post. Good luck and have fun taking photos with the Q!

11-27-2012, 12:27 PM   #9
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,797
Info button cycles the display to on/settings/no display.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, control, firmware, focus, mf, mirrorless, month, pentax q, pentax q10, pentax q7, q10, q7
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-5 Manual Lens Front Focus & Focus Beep woes fixed kneonx Pentax K-5 14 04-12-2014 03:47 PM
Can't change from Manual focus to Auto Focus kellyy17 Pentax K-r 11 03-06-2013 09:37 AM
How Well Does the K-5 Focus With Old Manual Focus Lenses? TomBrooklyn Pentax K-5 14 07-21-2011 05:16 AM
Confirm my understand of metering w/ manual lenses focus hyperfocal focus DeadJohn Pentax SLR Lens Discussion 4 03-25-2011 12:31 PM



All times are GMT -7. The time now is 04:33 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top