Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-31-2013, 01:05 PM   #76
Site Supporter




Join Date: Sep 2006
Location: midwest, United States
Photos: Gallery
Posts: 3,252
Downloaded the FW the evening of the day it was posted. Q did not loose count of file numbers. Still at approx 7k. After upload forgot to change file from date to Pentax. Instead of 108- now on 109. After FW update, I used the same SD card with shots on it. Camera picked up proper continuous file numbering. Haven't found any other bugs.
thanks
barondla

03-31-2013, 01:19 PM   #77
Veteran Member




Join Date: Mar 2007
Location: Alexandria VA USA
Posts: 315
So I did a quick side-by-side comparison between the bootleg 1.11 and the now-official 1.11. IMO, the AF in the 'now-official' version is noticeably slower than the bootleg version but not outrageously slow. I went back to the bootleg version. I also did a quick check on focus accuracy with the bootleg version and it seems OK.

It didn't seem to do any harm to switch back and forth between versions. The two files are almost identical - the only difference I could find was that the Windows 7 Properties of the 'now-official' version shows a create date of March 18, 2013, 1:17:21 AM, a modified date of March 12, 2013 12:55:40 AM, and an accessed date of March 18, 2013, 1:17:36 AM. The bootleg version has those three dates identical at March 12, 2013, 1:55:40 PM. Otherwise, the two files seem to be identical - file size of both is 15,597,792 bytes.

Recommend others post their observations, especially with regards to both speed and accuracy of the AF as well as any differences in JPEG processing to confirm or disprove my observations.

TIA RG
03-31-2013, 03:31 PM   #78
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 19,973
The original FW Upgrade definitely definitely reset my File_Count to 0000. Per Shutter Count, Camera Software Version = Pentax V. 1.11 Shutter Count = 0019.

If I ever sell one or the other I'll just note the situation on the FS Post - +1000 on the briefcase body and +425 on the converter body, based onmemory and file numbering.
03-31-2013, 03:41 PM   #79
Pentaxian
hnikesch's Avatar

Join Date: May 2009
Location: Michigan, USA
Photos: Albums
Posts: 1,248
QuoteOriginally posted by Rob22315 Quote
So I did a quick side-by-side comparison between the bootleg 1.11 and the now-official 1.11.

TIA RG
Where did you get the "bootleg" version sounds interesting, I just checked the Japan site still has "temporary not available". on the firmware update for the Q and the US site has no notice and the download is available. I would assume the US site was not updated to add the temporary not available notice because of the holiday and might be changed to temporary not available on Monday. Just a guess on my part but I don't think the US site has a new copy of the firmware because all the files I downloaded JP & US have the same dates.

Hans

03-31-2013, 03:43 PM   #80
Veteran Member




Join Date: Mar 2007
Location: Alexandria VA USA
Posts: 315
QuoteOriginally posted by hnikesch Quote
Where did you get the "bootleg" version sounds interesting, I just checked the Japan site still has "temporary not available". on the firmware update for the Q and the US site has no notice and the download is available. I would assume the US site was not updated to add the temporary not available notice because of the holiday and might be changed to temporary not available on Monday. Just a guess on my part but I don't think the US site has a new copy of the firmware.

Hans
I got the bootleg version off this site a day after the official websites pulled the file. I think I downloaded the new-official version off the USA Pentax website earlier today (scroll to the bottom) - Downloads & Literature - PENTAX Imaging USA.
03-31-2013, 04:06 PM   #81
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 4,989
QuoteOriginally posted by Rob22315 Quote
I got the bootleg version off this site a day after the official websites pulled the file. I think I downloaded the new-official version off the USA Pentax website earlier today (scroll to the bottom) - Downloads & Literature - PENTAX Imaging USA.
Don't think the USA ever pulled the file in the first place. If they are going to release a new official version, it will probably have a new number...
03-31-2013, 04:13 PM   #82
Loyal Site Supporter
drougge's Avatar

Join Date: Jan 2010
Location: Malmö
Photos: Gallery
Posts: 787
I can see no sign that there have even been different versions of the zip file. I didn't download the exe (as I have no use for it), but I've downloaded several supposedly different zip files and they are identical. (In the strict sense of being the exact same sequence of bits. The MD5 sum is bec31d5779f8babc46f2723ef1575d2e.)
03-31-2013, 04:21 PM   #83
Site Supporter




Join Date: Sep 2006
Location: midwest, United States
Photos: Gallery
Posts: 3,252
Monochrome, did you use a formatted memo card after the FW update or did it have files on it? Mine had hundreds of shots on it and that may be why the file count took off from where it stoped, without missing a step. The first 3 digits probably would have likely worked, if I had remembered to re- tick file type to Pentax insead of the default date.
thanks
barondla

03-31-2013, 04:27 PM   #84
Pentaxian
hnikesch's Avatar

Join Date: May 2009
Location: Michigan, USA
Photos: Albums
Posts: 1,248
Well it's back to waiting for the new file, I am glad that Pentax Ricoh is still thinking of the Q with new firmware, I would love to see focus peaking on my Kr

Hans
03-31-2013, 04:28 PM   #85
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 19,973
@Barondla: I formatted the card in camera after the FW.bin file was installed from and shot directly to it almost immediately.

I tend to transfer my files to storage drive quite often and format the cards. Apparently the FW Upgrade cleared the root incrementer in the camera ROM somewhere. I suppose if I transferred a prior .dng file back to the SD card I might get a proper increment (or closer now).

I need Pentax to explain just what has happened here. What was the upgrade for: what was the bug; is the bug harmful; what is the corrected FW upgrade; what does it do; was the bug fixed?


We didn't do anything wrong - especially those of us who updated FW before the bug was discovered. Most of the time I am quite forgiving of Pentax's quirky culture - but from time to time their abject lack of concern for and understanding of the feelings of their customers is truly astonishing. I get actually angry at a damned company!!

I could buy cameras made by a company with a full system, warranty and global in-store availability and be treated the same way.

Last edited by monochrome; 03-31-2013 at 04:38 PM.
03-31-2013, 04:36 PM   #86
Veteran Member
VisualDarkness's Avatar

Join Date: Nov 2011
Location: Uppsala, Sweden
Photos: Gallery
Posts: 4,440
QuoteOriginally posted by monochrome Quote
@Barondla: I formatted the card in camera after the FW.bin file was installed from and shot directly to it almost immediately.

I tend to transfer my files to storage drive quite often and format the cards. Apparently the FW Upgrade cleared the root incrementer in the camera ROM somewhere. I suppose if I transferred a prior .dng file back to the SD card I might get a proper increment (or closer now).
Same here, went to zero and I used a the same card but formatted.
03-31-2013, 05:26 PM   #87
Site Supporter




Join Date: Sep 2006
Location: midwest, United States
Photos: Gallery
Posts: 3,252
I also usually move files from card to computer often. Bought the Q the day it came out and it was laughed at by many. To combat this I kept the best images on the card to show people. Because of this I have many friends with a Q.
Putting shots back on card would probably reset it. Have accidentally put different Pentax camera card in and set to a higher file number.
thanks
barondla
03-31-2013, 05:31 PM   #88
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 19,973
QuoteOriginally posted by barondla Quote
Have accidentally put different Pentax camera card in and set to a higher file number.
Hah hah! Me too. I guess that's what happens when we have so many cameras.

I thought the K-01 was a blast, but these Q's are just a hoot! I'm having way too much fun with these cameras. (Or so my wife harumphs).
03-31-2013, 06:33 PM   #89
Site Supporter
arnold's Avatar

Join Date: Aug 2012
Location: Queensland
Photos: Gallery | Albums
Posts: 3,289
QuoteOriginally posted by monochrome Quote
The original FW Upgrade definitely definitely reset my File_Count to 0000. Per Shutter Count, Camera Software Version = Pentax V. 1.11 Shutter Count = 0019.
No change there for me on both cameras for numbering. Did have to reset settings.
03-31-2013, 08:26 PM   #90
Pentaxian
hnikesch's Avatar

Join Date: May 2009
Location: Michigan, USA
Photos: Albums
Posts: 1,248
QuoteOriginally posted by barondla Quote
I also usually move files from card to computer often. Bought the Q the day it came out and it was laughed at by many. To combat this I kept the best images on the card to show people. Because of this I have many friends with a Q.
Putting shots back on card would probably reset it. Have accidentally put different Pentax camera card in and set to a higher file number.
thanks
barondla
Guys all my Pentax cameras do this, I have put my Q card into my Kr and the file numbers of the next images in the Kr have changed to the next numbers on the card from the Q, then replaced the card in the Kr with a blank card and the Kr continues with the Q numbers until I put a card in the camera with a different number sequence, this also happens with my K2000. In fact this also happens with my Canon P&S cameras. I have had to put the camera name on the cards to prevent this, I have several cards for each camera. This is not new behavior you just need to format the card in the computer before using it in a different camera

Hans
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, firmware, mirrorless, pentax, pentax q, pentax q firmware, pentax q10, pentax q7, q10, q7
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K7 Firmware Updating to Version 1.11 Vadym Visitors' Center 2 02-07-2012 07:46 PM
K-r new firmware ver 1.11 murviper Pentax K-r 65 01-20-2012 09:49 PM
K-5 Firmware 1.11 on its way? kdre Pentax K-5 107 07-27-2011 10:53 PM
Problem Found with 1.11 Firmware on SilkyPix Infilllight Pentax Medium Format 2 07-25-2011 09:03 AM
Pentax K7 1.11 Firmware suggestions LaurenOE Pentax DSLR Discussion 26 06-21-2011 07:08 AM



All times are GMT -7. The time now is 08:46 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top