Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-03-2013, 11:41 PM   #1
New Member




Join Date: Nov 2013
Posts: 1
Pentax q issue

Hi all,

I was wondering if you could help me with a problem, I tried searching the forums but I couldn't seem to find anything.

I have a Pentax Q camera which I've had for almost a year, It doesn't get a great deal of use. However now it seems to have some sort of software glitch. I've tried formatting it, updating its firmware and returning it to factory default settings, none of which have worked.

The screen seems to be working but the image is entirely black, as if the lens cap is off, and when I take a photo the image also comes out entirely black (and yes I have the lens cap off). Also some of the modes don't seem to register, when I'm adjusting the dial it only seems to register manual mode and movie mode, everything else registers as aperture priority mode. Also as soon as I open the SD card latch (whether there is a card in there or not) it turns off.

Any suggestions?

Cheers,
Joshua

11-04-2013, 12:06 AM   #2
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,795
QuoteOriginally posted by joshman5k Quote
Also as soon as I open the SD card latch (whether there is a card in there or not) it turns off.
This is the easy one - this is supposed to happen, all Q's will not work if the SD card door is open.

QuoteOriginally posted by joshman5k Quote
The screen seems to be working but the image is entirely black, as if the lens cap is off, and when I take a photo the image also comes out entirely black (and yes I have the lens cap off). Also some of the modes don't seem to register, when I'm adjusting the dial it only seems to register manual mode and movie mode, everything else registers as aperture priority mode.
This can happen if the lens is not recognized, the M AV Movie are typical when a toy or manual lens is used.
If you are using lens 01, 02 06 - perhaps the contacts are dirty or have gotten damaged some how.
Make sure they are cleaned, and that the lens is fully engaged.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, cap, card, image, lens, mirrorless, mode, pentax, pentax q, pentax q10, pentax q7, q10, q7
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax Q Power Up Issue Smash Pentax Q 30 02-24-2017 09:29 PM
For Sale - Sold: Pentax Q body(SOLD), Pentax Q 01 lens(SOLD), Pentax Q Fisheye lens, adapters atcoombs Sold Items 4 11-03-2013 03:06 PM
Q playback issue... Rollin' Hand Pentax Q 3 03-05-2013 06:50 AM
Issue With Q and OEM Adapter polachekphotography Pentax Q 7 02-26-2013 07:49 PM
Fotodiox Q to K with Pentax DA 40mm f/2.8 Lens on Pentax Q SonDa5 Pentax Q 3 12-26-2012 06:29 PM



All times are GMT -7. The time now is 01:43 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top