Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-16-2013, 06:17 PM   #1
New Member




Join Date: Dec 2013
Posts: 8
Q won't turn on after firmware 1.13

Just got a second hand Q in great shape. Had the original firmware and it seemed to be working fine.

I followed the instructions completely to update the firmware to 1.13, saw the 'complete' message at the end and now the camera will not turn on.

If I take the battery out and put it back in, when I push the power on it sounds like the lens makes some sound but then nothing happens.

Anyone have a clue? Is my camera bricked? Will Pentax do anything for me even though it is outside the 1 year warranty?

Thanks

12-16-2013, 06:38 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,367
Does anything happen when no lens is mounted? I'm not sure if Pentax warrants firmware updates gone wrong, but it might be worth a shot.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

12-16-2013, 06:48 PM   #3
New Member




Join Date: Dec 2013
Posts: 8
Original Poster
No the camera doesn't do anything without a lens mounted.

I sent an email to Pentax yesterday. Hopefully they will have something I can try.
12-16-2013, 06:57 PM   #4
Site Supporter
p38arover's Avatar

Join Date: Mar 2012
Location: Western Sydney, Australia
Photos: Gallery | Albums
Posts: 3,078
I had exactly the same problem with my upgrade of my Q to V1.12 - that's why I haven't upgraded since.

See https://www.pentaxforums.com/forums/136-pentax-q/221933-pentax-q-firmware-1-1...ml#post2358564

The camera had to go back to Japan for repair.

Ron

12-16-2013, 07:02 PM   #5
New Member




Join Date: Dec 2013
Posts: 8
Original Poster
Thanks Ron. Do you mind giving me a heads up on how much that cost?

Andrew
12-16-2013, 07:03 PM   #6
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 4,989
Hmmmm...I'm reminded that I haven't done latest update. Maybe I don't want to...
12-16-2013, 07:08 PM   #7
Site Supporter




Join Date: Sep 2006
Location: midwest, United States
Photos: Gallery
Posts: 3,241
Bummer. Try without a lens, as Adams said. If that doesn't work try leaving the battery out for four to five days and see if it will reset. If none of this works it will have to go in for repair.

Friend had this problem with his K-7. It did half the FW update, and got stuck. Instructions said not to turn camera off. Battery died- basically turning camera off, hours later. Pentax US fixed his camera (it was in warranty). You have a used camera so they may not fix it for free.

good luck
barondla
12-16-2013, 07:18 PM   #8
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 4,989
QuoteOriginally posted by barondla Quote
Bummer. Try without a lens, as Adams said. If that doesn't work try leaving the battery out for four to five days and see if it will reset. If none of this works it will have to go in for repair.

Friend had this problem with his K-7. It did half the FW update, and got stuck. Instructions said not to turn camera off. Battery died- basically turning camera off, hours later. Pentax US fixed his camera (it was in warranty). You have a used camera so they may not fix it for free.

good luck
barondla
On the other hand, maybe I better do it while I'm still under warranty...

12-16-2013, 07:22 PM   #9
New Member




Join Date: Dec 2013
Posts: 8
Original Poster
Will leaving the battery out for a few days really reset it?

Yeah take advantage of the warranty if you've got it!
12-16-2013, 08:54 PM   #10
Emperor and Senpai
VoiceOfReason's Avatar

Join Date: Jun 2010
Location: Nashville, IN
Posts: 5,273
Try holding down on the power button for 30 seconds while the battery is out, then fully charge the battery, and then try it again.
12-16-2013, 09:24 PM   #11
New Member




Join Date: Dec 2013
Posts: 8
Original Poster
QuoteOriginally posted by VoiceOfReason Quote
Try holding down on the power button for 30 seconds while the battery is out, then fully charge the battery, and then try it again.
No luck.
12-16-2013, 09:25 PM   #12
New Member




Join Date: Dec 2013
Posts: 8
Original Poster
QuoteOriginally posted by p38arover Quote
I had exactly the same problem with my upgrade of my Q to V1.12 - that's why I haven't upgraded since.

See https://www.pentaxforums.com/forums/136-pentax-q/221933-pentax-q-firmware-1-1...ml#post2358564

The camera had to go back to Japan for repair.

Ron
Thanks Ron. Do you mind giving me a heads up on how much that cost?

Andrew
12-16-2013, 11:24 PM   #13
Loyal Site Supporter




Join Date: Nov 2013
Location: Alabama
Posts: 2,450
From experience flashing phones, it sounds like a corrupted firmware file. What happened immediately after the complete message?
12-17-2013, 04:24 AM   #14
Site Supporter
p38arover's Avatar

Join Date: Mar 2012
Location: Western Sydney, Australia
Photos: Gallery | Albums
Posts: 3,078
QuoteOriginally posted by ajhill287 Quote
Thanks Ron. Do you mind giving me a heads up on how much that cost?

Andrew
As I noted in that thread, it was done free of charge. Pentax Australia have been very good.

https://www.pentaxforums.com/forums/136-pentax-q/221933-pentax-q-firmware-1-1...ml#post2453192
12-17-2013, 05:05 AM   #15
New Member




Join Date: Dec 2013
Posts: 8
Original Poster
QuoteOriginally posted by dansamy Quote
From experience flashing phones, it sounds like a corrupted firmware file. What happened immediately after the complete message?
The camera turned off, which I think it was supposed to do.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, firmware, mirrorless, pentax q, pentax q10, pentax q7, q10, q7
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
k30 Firmware Problem / Now camera won't turn on aniro Troubleshooting and Beginner Help 7 11-27-2013 02:11 AM
K-5 won't turn on sophie100 Pentax K-5 16 06-01-2013 02:16 PM
K-x won`t turn on Rick43 Pentax DSLR Discussion 6 03-25-2012 04:26 PM
K5 won't turn on! ozlizard Pentax K-5 10 03-14-2012 02:35 PM
Ricoh camera won't turn on after batteries installed penney General Talk 4 07-26-2009 07:13 PM



All times are GMT -7. The time now is 05:22 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top