Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-09-2014, 11:13 AM   #1
Veteran Member




Join Date: Nov 2006
Location: Norway
Photos: Gallery
Posts: 385
Question regarding the mount shield lens

I bought the 07 mount shield lens a few months ago and last time I used it, Q asked for the focal length. I am not able to remember if it has been like this from new or started with this recently. Wondering if the electronics in the lens are broken already

How are yours?

04-09-2014, 11:53 AM   #2
Site Supporter




Join Date: Jan 2008
Location: Middle of Everywhere
Photos: Gallery
Posts: 1,169
The 07 does not ask for any input when mounted to my Q, or Q7.

Cheers... M
04-09-2014, 01:26 PM   #3
Veteran Member




Join Date: Nov 2006
Location: Norway
Photos: Gallery
Posts: 385
Original Poster
OK. I suppose I just remove the circuit board in the lens because it seems to make my little Q freeze occasionally.
04-09-2014, 03:39 PM   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,118
QuoteOriginally posted by StigVidar Quote
OK. I suppose I just remove the circuit board in the lens because it seems to make my little Q freeze occasionally.
Why not get it replaced under warranty? Sounds like a defective contact or circuit.


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-09-2014, 04:52 PM   #5
Veteran Member




Join Date: Jan 2009
Location: Brisbane
Photos: Gallery
Posts: 1,421
Definitely something up, send it back for a replacement!
04-09-2014, 10:21 PM   #6
Veteran Member




Join Date: Nov 2006
Location: Norway
Photos: Gallery
Posts: 385
Original Poster
Bought it on ebay from China so it's not replaceable.
05-27-2015, 02:24 PM   #7
New Member




Join Date: Oct 2013
Location: California
Posts: 3
have you tried cleaning the contacts?
you can use a pencil eraser (probably as rare as a film canister these days).
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, lens, mirrorless, mount, pentax q, pentax q10, pentax q7, q10, q7, shield
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K5 Question regarding F stop on manual lens old4570 Pentax K-5 11 04-24-2017 07:58 PM
07 mount shield lens available in AU now i_trax Pentax Q 2 07-20-2013 01:50 AM
New 07 Mount Shield Lens Phil A Pentax News and Rumors 40 06-13-2013 04:41 PM
Caution regarding the varifocal 2.8-12mm c-mount lens from AliExpress GibbyTheMole Pentax Q 9 03-26-2013 06:09 AM
Question Regarding T-Mount Adapters Mikhail Pentax Camera and Field Accessories 4 01-30-2008 07:56 AM



All times are GMT -7. The time now is 06:42 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top