Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-07-2015, 06:01 AM   #1
Loyal Site Supporter
blackcloudbrew's Avatar

Join Date: Mar 2009
Location: Cotati, California USA
Photos: Gallery | Albums
Posts: 3,782
Q7 SD Card will not stay in

Well my 2 year old Q7 has developed an issue - the card will not stay in. My work around is to push it in and close the door on it but I get an occasional memory card error. I suspect it will need professional repair.

Anyone else have this issue? or have gotten this fixed? Just wondering what I may be expecting.

05-07-2015, 06:46 AM   #2
Pentaxian
Rimfiredude's Avatar

Join Date: Oct 2014
Location: Washington
Photos: Gallery
Posts: 2,174
Not that problem, but since we are on the subject of problems. Every time I change the battery I lose the year, date, time etc. and have to reset them. Is this a common problem or does "Homer" my Q have something wrong with him?
05-07-2015, 07:47 AM   #3
Loyal Site Supporter
blackcloudbrew's Avatar

Join Date: Mar 2009
Location: Cotati, California USA
Photos: Gallery | Albums
Posts: 3,782
Original Poster
Not seen that problem but I recall that if the battery is out of my Q (or Q7) for awhile it will loose the time. Try having multiple batteries and change them quickly.
05-07-2015, 09:10 AM - 3 Likes   #4
Senior Member
Ontarian50's Avatar

Join Date: Mar 2015
Posts: 205
You've got something stuck in there

There's an 8 out of 10 chance that your SD card won't lock in because there's something blocking the locking mechanism. Most likely it is a small piece of plastic broken off one of your cards.
Getting it out without doing damage is the trick. And don't keep poking a card in and out - it may just make it worse.

If you can see what's going on (you need a good light source and a magnifier) you may spot the little bit of debris, either stuck down behind the gold contacts that hang down from the slot's "ceiling" or trapped up behind the spring release mechanism. It helps if the broken bit is Sandisk blue. Harder to spot black pieces.

Someone with good dexterity and the right probe might be able to dislodge the piece and shake it out.

The good news is if you do get it out, the thing will usually work like new. Occasionally, the pushing and shoving will have bent the contacts, causing the camera to not recognize the card, or to call every card "locked". If this happens the camera has to come apart and the contacts might be fixable. Worst case, you need a new circuit board with card reader.

05-07-2015, 09:31 AM   #5
Loyal Site Supporter
blackcloudbrew's Avatar

Join Date: Mar 2009
Location: Cotati, California USA
Photos: Gallery | Albums
Posts: 3,782
Original Poster
+1 no +5! Well I'll be damned! That is exactly correct. I have an orange Eye-FI card with just a small chip (about as wide as one contact) broken out of the top of it and I can see it stuck in the Q7's slot. I have some jeweler's tools at home that I believe I can extract the broken piece from. Actually the old paper clip did the trick just now. I don't recommend that as YMMV but it worked and it's fixed. Many thanks.
05-07-2015, 11:28 AM   #6
Pentaxian
Rimfiredude's Avatar

Join Date: Oct 2014
Location: Washington
Photos: Gallery
Posts: 2,174
QuoteOriginally posted by blackcloudbrew Quote
Not seen that problem but I recall that if the battery is out of my Q (or Q7) for awhile it will loose the time. Try having multiple batteries and change them quickly.
Thanks. It worked.
05-07-2015, 11:49 AM   #7
Lens Buying Addict
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 19,449
QuoteOriginally posted by blackcloudbrew Quote
+1 no +5! Well I'll be damned! That is exactly correct. I have an orange Eye-FI card with just a small chip (about as wide as one contact) broken out of the top of it and I can see it stuck in the Q7's slot. I have some jeweler's tools at home that I believe I can extract the broken piece from. Actually the old paper clip did the trick just now. I don't recommend that as YMMV but it worked and it's fixed. Many thanks.
I've had 4 Eye-Fi cards and every one of them has lost one of those little orange fingers. I call that a design fault.
05-07-2015, 12:17 PM   #8
Loyal Site Supporter
blackcloudbrew's Avatar

Join Date: Mar 2009
Location: Cotati, California USA
Photos: Gallery | Albums
Posts: 3,782
Original Poster
Very interesting. Mine has a crack near the card lock area too.

05-07-2015, 02:34 PM   #9
Lens Buying Addict
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 19,449
I don't think they're designed to be removed and reinstalled often - I think the design standard is probably install and leave in. That works OK for jpg transfers and esp. on local a Wi-Fi- Network - but who ever wants to transfer RAW by radio?

I thought I'd try to use an Eye-Fi in the jpeg slot in the K-3 and a a Sandisk in the RAW slot but I never got around to figuring it out. I just stuck the Eye-Fi's in Q's and Q7's and left them there - and the Q's were given to children.

My wife never figured out Wi-Fi at all, so I converted her back to regular SD cards, which she sticks in the slot in her MacBook and let's Apple do all the work.
05-07-2015, 02:44 PM   #10
Site Supporter
Sandy Hancock's Avatar

Join Date: Feb 2012
Location: Adelaide Hills, South Australia
Photos: Gallery | Albums
Posts: 5,245
Hey Tim, I have the same problem with my much newer K-S1. I was about to mail it off to B&H for warrantee repair, but this gives me hope I might be able to find a bit of rogue SD card avoid the downtime and postal expense.

Thanks Ontarian50!
05-07-2015, 09:54 PM   #11
Loyal Site Supporter
blackcloudbrew's Avatar

Join Date: Mar 2009
Location: Cotati, California USA
Photos: Gallery | Albums
Posts: 3,782
Original Poster
QuoteOriginally posted by monochrome Quote
I don't think they're designed to be removed and reinstalled often - I think the design standard is probably install and leave in. That works OK for jpg transfers and esp. on local a Wi-Fi- Network - but who ever wants to transfer RAW by radio?

I thought I'd try to use an Eye-Fi in the jpeg slot in the K-3 and a a Sandisk in the RAW slot but I never got around to figuring it out. I just stuck the Eye-Fi's in Q's and Q7's and left them there - and the Q's were given to children.

My wife never figured out Wi-Fi at all, so I converted her back to regular SD cards, which she sticks in the slot in her MacBook and let's Apple do all the work.
Well, that may be the problem, because I'm doing a 365 project with my Q7 and that card is coming in and out every day.

---------- Post added 05-07-2015 at 09:55 PM ----------

QuoteOriginally posted by Sandy Hancock Quote
Hey Tim, I have the same problem with my much newer K-S1. I was about to mail it off to B&H for warrantee repair, but this gives me hope I might be able to find a bit of rogue SD card avoid the downtime and postal expense.

Thanks Ontarian50!
Also interesting. Hope you get it resolved as easily as I did.
05-08-2015, 02:24 AM   #12
Veteran Member
drypenn's Avatar

Join Date: Nov 2012
Photos: Albums
Posts: 948
QuoteOriginally posted by Rimfiredude Quote
Not that problem, but since we are on the subject of problems. Every time I change the battery I lose the year, date, time etc. and have to reset them. Is this a common problem or does "Homer" my Q have something wrong with him?

Actually, this is a common Q problem. It's the internal capacitor. I was quoted for around $200 to replace that thing. Yes, $200!!!

Mine already quickly loses the time settings even if I hurriedly replace the battery (less than 15 seconds)
05-08-2015, 02:58 AM   #13
Banned




Join Date: Feb 2015
Posts: 10
Indeed a great piece of useful information ! Now I am aware of the possible causes whenever memory card will not be just fixing inside!
05-08-2015, 04:36 AM   #14
Pentaxian
Rimfiredude's Avatar

Join Date: Oct 2014
Location: Washington
Photos: Gallery
Posts: 2,174
QuoteOriginally posted by drypenn Quote
Actually, this is a common Q problem. It's the internal capacitor. I was quoted for around $200 to replace that thing. Yes, $200!!!

Mine already quickly loses the time settings even if I hurriedly replace the battery (less than 15 seconds)
200 buckeroonies??? I am not laughing!
05-09-2015, 07:02 AM   #15
Loyal Site Supporter
blackcloudbrew's Avatar

Join Date: Mar 2009
Location: Cotati, California USA
Photos: Gallery | Albums
Posts: 3,782
Original Poster
Oh, dear...a follow up here on my problem. I 'thought' I had this fixed but no. I was able to use the camera until yesterday when now, shortly after start up, I'm getting a 'memory card error' and the camera powers down. This doesn't mater which card is in there and I think this one had to go to get repaired. Had to do a calculation of getting it repaired versus a new Q-S1. So far the repair is the more cost effective way to go. So off to the shop and going back to my original Q to continue my 365 project. Ugg.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, hope, issue, mirrorless, pentax q, pentax q10, pentax q7, q-s1, q10, q7, q7 sd card, sd, slot, wi-fi
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
sd card works in camera, but is not recognised by pc pieterpost Pentax DSLR Discussion 25 02-21-2016 02:24 PM
Macros not on SD card Greg Schultz Visitors' Center 2 02-24-2014 05:08 PM
For Sale - Sold: Fuji F550EXR, 4GB Eye-Fi SD Card, 4GB SD Card, 2 Batt + 6BQ5 Sold Items 3 09-16-2013 08:19 PM
SD sdhc card will not download largea Troubleshooting and Beginner Help 5 05-23-2011 07:00 AM
SD Card will not stay in RParks Pentax DSLR Discussion 7 08-02-2010 02:35 PM



All times are GMT -7. The time now is 09:26 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top