Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-30-2016, 12:16 PM   #1
Senior Member
Professor Batty's Avatar

Join Date: Aug 2012
Posts: 118
Anyone ever have a broken Q series camera or lens?

bye-bye


Last edited by Professor Batty; 01-10-2017 at 05:44 PM. Reason: not needed
11-30-2016, 01:36 PM   #2
Pentaxian
Audi 5 cyl's Avatar

Join Date: Mar 2015
Location: France
Photos: Gallery | Albums
Posts: 353
QuoteOriginally posted by Professor Batty Quote
Looking through the other forum categories, there seems to be endemic problems with some Pentax bodies and lenses: aperture control, lens compatibility problems, lock-ups, Mode dial issues, SDM failures etc…

I never notice any of these problems with the Q series. Are they that trouble free, or are there issues I don't know about?

Just wondering.
They are dying alright. I do not have a good written proof of it, but have stumbled on stories of Q cameras loosing date and settings, not working at all after months of shelf life, not turning on for unknown reasons. The thing is, nobody is repairing those after the warranty is up. For lenses I really would not know, but I guess they need to age a bit before the problems would appear at a larger scale. It is a young system after all.
11-30-2016, 02:46 PM   #3
Moderator
Loyal Site Supporter
Loyal Site Supporter
BigMackCam's Avatar

Join Date: Mar 2010
Location: North East of England
Posts: 6,814
I've also heard stories of Q's dying... but: (1) the number Q's compared to DSLRs is tiny, and (2) there's less to go wrong; very little mechanically, that's for sure...
11-30-2016, 05:35 PM   #4
Veteran Member




Join Date: Sep 2013
Photos: Gallery
Posts: 1,715
Losing date and settings sounds like the watch battery inside the camera's main board lost its charge. That should be a relatively easy fix, and happens with many different kinds of neglected electronics.

12-04-2016, 11:06 PM   #5
Pentaxian
wolfiegirl's Avatar

Join Date: Oct 2011
Location: Outside of Canberra, Australia
Photos: Gallery
Posts: 4,075
I lost two original qs. One refuses to switch on, the other refuses to recognise a sd card.

In both cases they were sitting on the shelf for a while. It may (or may not) have impacted on the result.

I ended up upgrading to a qs1, as i was told it would cost about the same to have both investigated, before even sorting out the problem.

So far, one week in, i am happy with my decision.

I have also had a dud 06 lens - which i didn't realise until i used the qs1 - where it seems the 06 will only do manual focus and not af. Don't know if that's user error or not though
12-05-2016, 10:43 AM   #6
Pentaxian




Join Date: Nov 2014
Location: South Bend, IN, USA
Photos: Gallery | Albums
Posts: 3,012
QuoteOriginally posted by Professor Batty Quote
Looking through the other forum categories, there seems to be endemic problems with some Pentax bodies and lenses: aperture control, lens compatibility problems, lock-ups, Mode dial issues, SDM failures etc…

I never notice any of these problems with the Q series. Are they that trouble free, or are there issues I don't know about?

Just wondering.
I took 50 pictures with my Q-7 at a Madrigal Dinner last night. I had to do a hot reboot {battery out then back in} twice, the first time I've ever had to do that. In both cases the symptoms were the same - suddenly the camera wouldn't focus, and didn't respond to the on/off button either.
12-06-2016, 02:46 AM   #7
Junior Member




Join Date: May 2014
Location: Paris, France
Posts: 42
I had 2 Q lenses that died without any reason. a 06 and a 08. The autofocus was dead for both lenses. Replaced by new lenses under warranty by Pentax
12-21-2016, 03:20 PM   #8
Pentaxian
hnikesch's Avatar

Join Date: May 2009
Location: Michigan, USA
Photos: Albums
Posts: 1,254
I had an 06 that was replaced by Pentax

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, issues, mirrorless, pentax q, pentax q10, pentax q7, q-s1, q10, q7, series, series camera
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
anyone have a good comparison of the Q line? Mothballs Pentax Q 30 12-28-2015 02:22 PM
Anyone have 2 or more Q's? kshapero Pentax Q 14 05-12-2013 09:07 AM
Have you ever broken a lens mount? Sagitta Pentax SLR Lens Discussion 23 10-14-2012 06:33 PM
Anyone ever mounted a K-mount super-telephoto on a Q? GibbyTheMole Pentax Q 12 10-02-2012 02:40 AM
anyone have a cure for a broken heart and soul? séamuis General Talk 45 04-01-2011 03:13 PM



All times are GMT -7. The time now is 04:24 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top