Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-16-2019, 01:28 PM   #1
Site Supporter
Site Supporter
shaolen's Avatar

Join Date: May 2012
Location: Phoenix AZ
Posts: 1,016
interesting malfunction

I must have had my 03 fisheye lens not mounted all the way or something as it was taking photos and I could see the edge of the lens in the corners. Took it off and back on and it fixed itself. I guess this certainly isn't capable of being mounted on a 1 inch sensor

Attached Images
View Picture EXIF
PENTAX Q7  Photo 
04-16-2019, 01:39 PM - 1 Like   #2
Senior Moderator
Loyal Site Supporter
Loyal Site Supporter
BigMackCam's Avatar

Join Date: Mar 2010
Location: North-East of England
Posts: 13,327
QuoteOriginally posted by shaolen Quote
I must have had my 03 fisheye lens not mounted all the way or something as it was taking photos and I could see the edge of the lens in the corners. Took it off and back on and it fixed itself. I guess this certainly isn't capable of being mounted on a 1 inch sensor
I'm assuming you're using the lens on a Q-7 or later model, in which case I'd guess this is due to the lens and mount contacts not not making connection - either because the lens wasn't fully turned into position, or perhaps dust or dirt on one or both sets of contacts. The 03 fisheye lens image circle covers the original Q sensor just fine, but not the later models which have slightly bigger sensors. So, when the camera identifies that lens, it records a cropped area of the image. If it can't identify the lens, though, it'll record the entire sensor area...
04-16-2019, 01:39 PM   #3
Loyal Site Supporter
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 15,489
QuoteOriginally posted by shaolen Quote
I must have had my 03 fisheye lens not mounted all the way or something as it was taking photos and I could see the edge of the lens in the corners. Took it off and back on and it fixed itself. I guess this certainly isn't capable of being mounted on a 1 inch sensor
Is that one of the toy lenses? If I recall they only cover the original sensor size not the larger size of the later q series bodies.

My guess is that the lens to body communication got cliches and it didn't turn on the crop needed assuming this wasn't on the original q.
04-16-2019, 02:18 PM - 1 Like   #4
Pentaxian
Cipher's Avatar

Join Date: Jan 2016
Location: Minnesota
Posts: 444
You will get this effect if you put a piece of paper over the contacts when you mount the lens, you also gain about 20° of coverage.

See this thread: Fish-Eye Options for the Q - PentaxForums.com

04-16-2019, 08:30 PM   #5
PJ1
Site Supporter
Site Supporter
PJ1's Avatar

Join Date: Jul 2012
Location: Mosquito Creek, Australia
Photos: Gallery | Albums
Posts: 2,856
As others have said, the 03 has full coverage only on the original Q or Q10. I had a speck of dust in mine and dismantled it to remove the dust. Not difficult but on the first re-assembly it was distinctly unsharp. I went back in and really tightened all the screws, and then it was fine. So it is a simple piece of gear but you will know if it is not happy.
04-16-2019, 08:47 PM - 1 Like   #6
Senior Member




Join Date: Jan 2018
Posts: 229
Blocking the contacts deliberately on the 03 fisheye is to obtain as much fov as possible. The very corners being dark is just an easy crop or slight de-fish but often I just opt to leave it. A great hack for 03 owners in my opinion.
04-18-2019, 12:24 PM   #7
Pentaxian
h4yn0nnym0u5e's Avatar

Join Date: Mar 2016
Location: Cambridgeshire, UK
Photos: Albums
Posts: 320
And the EXIF says it's a 48mm lens (221mm equiv) with 1/6 sec exposure. So the SR won't have got it right, either...
04-18-2019, 09:00 PM   #8
Senior Member




Join Date: Jan 2018
Posts: 229
QuoteOriginally posted by h4yn0nnym0u5e Quote
And the EXIF says it's a 48mm lens (221mm equiv) with 1/6 sec exposure. So the SR won't have got it right, either...
When you cover up the contacts of the 03 and mount it, you boot up the camera and get to manually input the focal length for EXIF purposes and also the IBIS to know how to behave accordingly.

Works fine with max field of view.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, lens, mirrorless, pentax q, pentax q10, pentax q7, q-s1, q10, q7
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K3/14mm lens malfunction 49tandrew Pentax K-3 2 03-14-2019 01:47 PM
K-1 Card 2 slot malfunction dnabs Troubleshooting and Beginner Help 9 06-14-2018 01:40 PM
Malfunction when shooting with 100mm macro WR? Dericali Pentax SLR Lens Discussion 2 11-12-2017 07:21 AM
Camera won't turn on. Lens Malfunction? KAULD Troubleshooting and Beginner Help 3 05-20-2017 11:42 AM
k7 SR malfunction pentaxmx Pentax DSLR Discussion 10 10-19-2010 12:10 PM



All times are GMT -7. The time now is 01:05 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top