Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-06-2023, 11:14 PM   #1
Site Supporter
Site Supporter




Join Date: Sep 2021
Location: Tucson, AZ
Posts: 13
Help! Think I broke my Q7

So I have a full spectrum Q7, modded with a bare sensor. Today I tried an m12 lens on it and screwed it in too far. �� And stupidly I tried to unscrew the adapter instead of unscrewing the lens. Think I jammed something.

The sensor itself looks fine, no contact was made with it.

Now the Q will not turn on for more than a moment and it makes a groaning noise, which I assume is due to the fact that I previously had the antishake on.

The screen won’t come on if there is a dumb adapter attached. The red light turns on and stays on. It groans and turns off.

The screen does come on briefly if I attach a Q lens, but the camera groans and the red light at the top right stays on, and buttons don’t respond, so I can’t enter the menus to turn off the shake reduction system. Then the camera turns off again.

What’s the prognosis, guys? Think I can fix it? I’m open to any ideas. Willing to take it apart if there’s a chance.


Last edited by spiffariffic; 12-07-2023 at 11:36 AM.
12-07-2023, 03:06 PM   #2
Pentaxian
Paul the Sunman's Avatar

Join Date: Aug 2011
Location: Melbourne
Photos: Gallery
Posts: 4,796
Cringe! Good luck with it.
12-08-2023, 12:29 AM   #3
kwb
Site Supporter
Site Supporter




Join Date: Mar 2015
Location: Pacific North West
Photos: Gallery | Albums
Posts: 1,214
Sorry to hear that.
Are you saying that you put an enormous torque to your Q-C adapter without pressing the lens release button? If so, if I were you I'll first check if the lens lock pin looks undamaged. Usually that pin is on a leaf spring, the release button presses the spring to disengage the pin, and there's a sensor to monitor if the pin is engaged or disengaged. If the lock pin was tilted enough (or even bent) and deformed/bent the spring, maybe the sensor can misbehave? I have no real wisdom but anyway that's one thing to check.
12-09-2023, 11:18 PM   #4
Site Supporter
Site Supporter




Join Date: Sep 2006
Location: midwest, United States
Photos: Gallery | Albums
Posts: 5,703
So the rear of the lens ran into the sensor shield? You might try leaving the battery out for a week. That will hopefully do a factory reset and allow you to go into the menu and change settings.

I've been considering converting a Q to full spectrum. Have to ask how well did it work before the accident? Imagine IR is no problem, I'm more interested in UV. I have a K1 full spectrum.
Thanks,
barondla

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
adapter, camera, lens, light, mirrorless, pentax q, pentax q10, pentax q7, q-s1, q10, q7, screen, sensor
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
I think I broke my Spomatic f vader28957 Troubleshooting and Beginner Help 2 02-12-2021 01:38 PM
Comparison of the 03 fisheye on Q and Q7 and Q7 with third party raw converter Altglas Pentax Q 14 02-02-2015 10:59 PM
Help! Something broke in my Tokina 90/2.5. jeffshaddix Pentax SLR Lens Discussion 9 02-26-2013 05:44 AM
help, bad firmware broke my new camera :( spystyle Troubleshooting and Beginner Help 36 01-22-2011 07:42 AM
Help! My DA* 16-50mm just broke! SA Photo Pentax SLR Lens Discussion 17 12-10-2009 03:33 PM



All times are GMT -7. The time now is 03:42 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top