Forgot Password
Pentax Camera Forums Home
 

Closed Thread
Show Printable Version Search this Thread
05-28-2012, 09:07 AM   #31
Veteran Member
Anvh's Avatar

Join Date: Sep 2011
Posts: 4,616
I also changes lenses with the power on, never had a problem so far (3 years) so i'm sceptical that changing the lens once in this fashion will break the whole camera.

05-28-2012, 09:31 AM   #32
Pentaxian
bobmaxja's Avatar

Join Date: Mar 2010
Location: Laval, Quebec Canada
Posts: 1,698
Change lens all the time with Power on on K-X and K-5 , never have a single problems
05-28-2012, 12:12 PM   #33
Lens Buying Addict
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 19,429
I believe that if you do not fully mount the lens until it clicks you will not engage the AF screw drive. The camera might then read the lens as a MF lens. My K-01 K-mount is tighter than other cameras with my DA40Ltd. Perhaps your 40mm lens has the same character and needs a bit of extra oomph to be fully mounted.

It would still be statistically improbable that the error would happen three times on three cameras during the second lens mounting (the first time was when you mounted the lens after you took it out of the packaging), but more likely than a malf.
06-08-2012, 06:31 AM   #34
New Member




Join Date: May 2012
Posts: 18
Original Poster
DUMB & DUMBER = EVEN DUMBER!!!

Yay! Got my K-01 back from Pentax (I picked it up). Turns out the lens wasn't 'clicking' into place, I had to use more force because the small lens didnt allow for much 'torque' when attaching it compared to a 'normal' sized lens. Anyway I feel positively stupid beyond belief that I couldn't work that out.... but not as stupid as the people in the camera store who sell cameras for a living and couldnt work it out either!
So to my relief I can get my K-01 cranking this long weekend, and just to let all the paranoid forum members know that it wasnt a conspiracy by canon, nikon or aliens to drag Pentax name through the mud.
Happy shooting & less time talking....

06-08-2012, 08:19 AM   #35
Veteran Member
Anvh's Avatar

Join Date: Sep 2011
Posts: 4,616
Glad it got solved =]
06-08-2012, 08:24 AM   #36
Lens Buying Addict
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 19,429
QuoteOriginally posted by Robski Quote
DUMB & DUMBER = EVEN DUMBER!!!

Yay! Got my K-01 back from Pentax (I picked it up). Turns out the lens wasn't 'clicking' into place, I had to use more force because the small lens didnt allow for much 'torque' when attaching it compared to a 'normal' sized lens. Anyway I feel positively stupid beyond belief that I couldn't work that out.... but not as stupid as the people in the camera store who sell cameras for a living and couldnt work it out either!
So to my relief I can get my K-01 cranking this long weekend, and just to let all the paranoid forum members know that it wasnt a conspiracy by canon, nikon or aliens to drag Pentax name through the mud.
Happy shooting & less time talking....
As one of the initial "conspiracry theorists" (deleted not quickly enough, and immediately reteracted) - actually, the prononent of statistical improbability, looking for a simpler explanation - my sincerest apologies for any perceived aspersions. I'm very happy for you that you have a simple explanation, and that is the one I cited in my post directly above yours.

As I noted, my DA40/2.8 Limited is also a tighter mount on the K-01 than my other lenses. I consider this a minor fault of the K-01.
06-08-2012, 08:45 AM   #37
Veteran Member
Anvh's Avatar

Join Date: Sep 2011
Posts: 4,616
QuoteOriginally posted by monochrome Quote
As one of the initial "conspiracry theorists" (deleted not quickly enough, and immediately reteracted) - actually, the prononent of statistical improbability, looking for a simpler explanation - my sincerest apologies for any perceived aspersions. I'm very happy for you that you have a simple explanation, and that is the one I cited in my post directly above yours.

As I noted, my DA40/2.8 Limited is also a tighter mount on the K-01 than my other lenses. I consider this a minor fault of the K-01.
You don't really practice what you preach it seems

The DA40 mounts tighter on the K-01 than your other lenses, since the other lenses are okay then how can it be the K-01 faults, it's much more likely the DA40.
06-08-2012, 10:05 AM   #38
Veteran Member
riff's Avatar

Join Date: Jun 2011
Photos: Albums
Posts: 1,408
QuoteOriginally posted by Robski Quote
Turns out the lens wasn't 'clicking' into place
Sheesh I was going to ask about that. I'd had a situation with my K5 every time I went LV the camera would become totally unresponsive. As I was removing the lens to examine it for problems I noticed it seemed to easy to remove, remounted and everything was as it should be. It was an A lens in M mode.

06-08-2012, 10:10 AM - 1 Like   #39
Veteran Member




Join Date: Aug 2009
Photos: Gallery
Posts: 1,236
QuoteOriginally posted by monochrome Quote
As one of the initial "conspiracry theorists" (deleted not quickly enough, and immediately reteracted) - actually, the prononent of statistical improbability, looking for a simpler explanation - my sincerest apologies for any perceived aspersions. I'm very happy for you that you have a simple explanation, and that is the one I cited in my post directly above yours.
Look at the thread title. I don't think we have anything to apologize for. It's fine asking for help with an issue and most of us would gladly give that help, but there is a way to do it without alienating people.

Anyways, I'm glad the original poster got that sorted out. That 40mm lens is really thin, so it takes a bit more effort to lock into place than a large lens.
Closed Thread

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
40mm, af, auto, camera, fine, k-01, k01, lens, mirrorless, pentax, pentax k-01, pentaxian, store, weeks
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disaster Phootoshoot at the Beach pwrlogic Photographic Technique 41 08-03-2011 12:26 AM
Prices going up because of the disaster? chukers Pentax K-r 12 03-14-2011 07:38 AM
F*300mm on Ebay - disaster yusuf Pentax SLR Lens Discussion 26 12-25-2010 06:46 PM
55-300 Disaster slowdive101 Pentax SLR Lens Discussion 7 10-01-2010 07:48 PM
Faulty equipment or faulty photographer? (K-x) mamba909 Pentax DSLR Discussion 22 02-15-2010 12:16 PM



All times are GMT -7. The time now is 11:38 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top