Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-11-2012, 10:43 PM   #31
Site Supporter
sunny16's Avatar

Join Date: Oct 2010
Location: Maryland, USA
Posts: 267
I hardly ever use my WR Zooms (18-55mm & 50-200mm) on the K-01. After firmware update I can confirm that focus is noticeably faster on both of these lenses. I tested under indoor compact fluorescent lighting, which is usually more problematic in my experience. In medium to well lit areas, both lenses locked focus pretty quickly. In dark areas, the focus was slower and hunted some, but it locked every time. Previously (under generally good lighting) both lenses would hunt at the long end and, if my memory serves me right, would hardly ever lock focus in difficult light.

I am happy that this update has come through. I am also happy for the green button/m42 lens fix. Realistically I will still probably continue to use my prime lenses more. BUT... now that they work better, I would definitely consider using the zooms. (P.S. my DA 10-17mm has always worked well on the K-01.)

10-11-2012, 10:49 PM   #32
Veteran Member




Join Date: Jan 2010
Location: Durham, nc
Photos: Albums
Posts: 887
Big questionoes the K01 support the GPS module now?

Charles
10-12-2012, 12:05 AM   #33
Forum Member




Join Date: Dec 2008
Location: Newbury, England
Posts: 50
A further update on my own experiences with FW Version 1.01 and AF.

I'm still convinced that the new FW improves AF - but not necessarily consistently. There is a vast improvement in my Tamron 18-250 F3.5-6.3 LD DiII. It's always been my favourite lens on my Samsung GX-10 and now seems to work fast and accurately in all lighting conditions. My Samsung 50-200mm (same as Pentax DA 50-200mm) still hunts unsuccessfully in low light. The DA 35 F2.4 positively whizzes along (but it was quite fast before hand). My Tamron 70-300mm seems to work better since the upgrade but I'm not sure it's radically so.

One lens I hadn't tried before I did the upgrade (as I don't see myself using it on the K-01) is my Sigma 120-400mm F4-5.6 Even pointing near a strong light source it just hunts and hunts and never locks. This is my only SDM lens so I'm not sure whether this is normal - it certainly doesn't have any such problems on my GX-10. I don't know that I'll bother investigating this further

Neil
10-12-2012, 02:45 AM   #34
ogl
Banned




Join Date: Dec 2007
Location: Siberia
Photos: Gallery | Albums
Posts: 7,114
old

new


10-12-2012, 02:46 AM   #35
ogl
Banned




Join Date: Dec 2007
Location: Siberia
Photos: Gallery | Albums
Posts: 7,114
old

new
10-12-2012, 02:51 AM   #36
Pentaxian
Michi Joel's Avatar

Join Date: Mar 2012
Location: Catalonia
Photos: Albums
Posts: 403
Tnx! its much better with the other lens
10-12-2012, 04:29 AM   #37
ogl
Banned




Join Date: Dec 2007
Location: Siberia
Photos: Gallery | Albums
Posts: 7,114
My DFA100 is slower at my K200D than CDAF of K-01 now.
10-12-2012, 07:21 AM   #38
New Member
semislashcolon's Avatar

Join Date: Oct 2012
Posts: 20
QuoteOriginally posted by sunny16 Quote
I hardly ever use my WR Zooms (18-55mm & 50-200mm) on the K-01. After firmware update I can confirm that focus is noticeably faster on both of these lenses. I tested under indoor compact fluorescent lighting, which is usually more problematic in my experience. In medium to well lit areas, both lenses locked focus pretty quickly. In dark areas, the focus was slower and hunted some, but it locked every time. Previously (under generally good lighting) both lenses would hunt at the long end and, if my memory serves me right, would hardly ever lock focus in difficult light.
Good to know, I'm considering getting WR Zoom lens. Thanks!

10-12-2012, 08:01 AM   #39
Pentaxian
RonHendriks1966's Avatar

Join Date: Jan 2009
Photos: Gallery
Posts: 8,556
QuoteOriginally posted by ChopperCharles Quote
Big questionoes the K01 support the GPS module now?

Charles
It already did, since I put it on my K-01 once.
10-12-2012, 08:14 AM   #40
Veteran Member
AndrewG NY's Avatar

Join Date: Dec 2006
Location: Chappaqua, NY
Photos: Gallery
Posts: 678
I haven't had a chance to try this yet, was about to return my K-01 -- is the ability to lock focus in low light even with the DA40 XS significantly improved? While I liked most things about the K-01 it's a problem for me to have this monster high-ISO sensor but inability to autofocus -- was at a wedding reception and had to give up and manually focus most shots while everybody with mobile phones or $150 P/S were snapping away. I can live with a little sluggishness but taking 20 seconds to try-try-try-try-switch to manual is no good -- and this with a reasonably fast f/2.8 lens.

The ur-Q suffers a bit from this too -- I'm really hoping Pentax updates the AF for that camera as well when they update firmware for compatibility with Q-to-K adapter. Even better if they throw in focus peaking a-la Q10. I don't know that I want to buy a Q10...really want my Q to work better.
10-12-2012, 04:24 PM   #41
Pentaxian
raider's Avatar

Join Date: Jul 2007
Location: Perth, Australia
Photos: Gallery
Posts: 1,931
QuoteOriginally posted by reivax Quote
I would really appreciate that. I really want these things to work well. I just barely started using the K-01 recently. I'm hoping it's my error and not the equipment.
Hi reivax, I did a quick test this morning...and YES. you are right all along. Maybe I didnt pixel peep my early tests with the Tamron 70-200 but it does seem like there are some issues with the Tamron 70-200. When I focus on the K-01, the focusing part will suddenly go out of focus when i press the shutter button. I tried the same lens also on my K-30...no problems.

Here a comparison shot.

Tamron 70-200 with K-01 @ f5.6 ISO100 handheld
Name:  IMGP0609.JPG
Views: 1297
Size:  194.9 KB

Tamron 70-200 with K-30 @ f5,6 ISO100 handheld
Name:  IMGP0749.JPG
Views: 1220
Size:  279.7 KB

So there's nothing wrong with your K-01
10-12-2012, 06:46 PM   #42
Site Supporter
reivax's Avatar

Join Date: Jun 2011
Location: California
Posts: 720
QuoteOriginally posted by raider Quote
Hi reivax, I did a quick test this morning...and YES. you are right all along. Maybe I didnt pixel peep my early tests with the Tamron 70-200 but it does seem like there are some issues with the Tamron 70-200. When I focus on the K-01, the focusing part will suddenly go out of focus when i press the shutter button. I tried the same lens also on my K-30...no problems.

Here a comparison shot.

Tamron 70-200 with K-01 @ f5.6 ISO100 handheld
Attachment 143234

Tamron 70-200 with K-30 @ f5,6 ISO100 handheld
Attachment 143236

So there's nothing wrong with your K-01
Thanks. That is the exact same result I have been getting with my 70-200. The pictures appear just a little too out of focus. It definitely is an improvement with the auto focus though. It would hunt non stop with the old firmware.
10-12-2012, 07:04 PM   #43
Pentaxian
raider's Avatar

Join Date: Jul 2007
Location: Perth, Australia
Photos: Gallery
Posts: 1,931
I have a feeling that the K-01 does not work too well with 3rd party zoom lenses in general. I tried the sigma 17-70 and while it does not have the same kind of issues experienced by the Tamron 70-200, certain shots are a tad out of focus too. Interestingly, i tried the DA18-135 with the K-01 and experienced none of the above issues.

I also tried out the DA35 Ltd macro extensively this morning....and i have to say, focusing speed in good light is at least 70% as fast as on my K-7 and/or K-30. I am very pleased. Previously it will hunt back and forth before locking focus. It is now a lot faster.

Now if Pentax can make this kind of improvement to K-01 CDAF, I would like to think that the K-5IIs will be awesome.
10-12-2012, 07:13 PM   #44
Site Supporter
Sandy Hancock's Avatar

Join Date: Feb 2012
Location: Adelaide Hills, South Australia
Photos: Gallery | Albums
Posts: 5,251
With this firmware update I'm a little regretful I sold my DA55-300....
10-12-2012, 08:26 PM   #45
New Member




Join Date: Dec 2011
Location: Brisbane
Posts: 8
Wow. Focus is so much quicker with my DA L 55-300 now
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
firmware, k-01, k-01 firmware, k01, mirrorless, pentax k-01, performance, stability
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K5 Firmware update fishnuts Pentax K-5 2 06-28-2011 04:57 AM
Firmware Update jwpinnacle Troubleshooting and Beginner Help 5 05-28-2011 02:16 AM
K5 firmware update rechmbrs Pentax K-5 41 03-10-2011 03:51 PM
Firmware update for K-x and K-7 elg Pentax News and Rumors 26 01-27-2011 01:44 PM
K-7 Firmware update? LDBennett Pentax DSLR Discussion 5 12-30-2010 04:13 PM



All times are GMT -7. The time now is 12:21 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top