Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-16-2012, 11:14 AM   #1
New Member
TaylorRiverGuy's Avatar

Join Date: Sep 2012
Location: Broken Arrow, Oklahoma
Posts: 13
K-01 e-dial not working

My new K-01's e-dial stopped working today while taking some photos. It does not work in capture mode (i.e., changing the aperature or shutter speed) or in playback mode (zooming in on photos). I have tried to re-set the camera to the default settings, but this did not solve the problem. Any idea what is causing this? Do I need to send it back?

Many thanks to anyone who can help me with this problem.

12-16-2012, 11:40 AM   #2
Pentaxian
RonHendriks1966's Avatar

Join Date: Jan 2009
Photos: Gallery
Posts: 8,714
Take the battery out for a moment and back in. Maybe some resetting would help. Offcourse it also can be broken, but haven't seen more off these issues.
12-16-2012, 12:02 PM   #3
New Member
TaylorRiverGuy's Avatar

Join Date: Sep 2012
Location: Broken Arrow, Oklahoma
Posts: 13
Original Poster
Thanks for the advice Ron. Unfortunately, the battery pull did not solve the problem. I just read elsewhere on the forums that there were some similar problems with the K-7 and the K-R that were caused by excessive lubricant shorting out the contacts.
02-08-2013, 03:03 PM   #4
New Member




Join Date: Feb 2013
Posts: 4
I was having issues with a zippy e-dial when trying to set shutter speed. If I started at shutter speed of 125 and then wanted to go to 200 the shutter setting would zip all over the place (125 to 200 to 50). Removing the battery did nothing. What did help was reading the manual and learning that I could reset what each e-dial did. I was using the front e-dial to set shutter speed when the zippiness occurred. When I switched the E-Dial Progamming so that the back e-dial controlled shutter speed the zipping around stopped.

02-10-2013, 12:38 PM   #5
New Member
TaylorRiverGuy's Avatar

Join Date: Sep 2012
Location: Broken Arrow, Oklahoma
Posts: 13
Original Poster
I ended up sending mine back for an exchange. No complaints yet on the replacement.

At < $300, the K-01 must easily be the best IQ bang for your buck in the photographic universe.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
e-dial, k-01, k01, mirrorless, mode, pentax k-01, photos
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-7 front e-dial repair? or not? steve1307 Pentax DSLR Discussion 2 09-20-2012 09:48 PM
K-x e-dial not working siva.ss.kumar Pentax DSLR Discussion 2 03-12-2012 07:03 AM
Back control dial not working? Javaslinger Pentax K-5 4 07-19-2011 06:10 PM
K-7:Rear e-dial not working correctly bulacawa Pentax DSLR Discussion 11 05-29-2010 04:13 AM
The e-dial on my "new" K100D is not working NorthPentax Pentax DSLR Discussion 6 05-17-2009 08:14 AM



All times are GMT -7. The time now is 05:56 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top