Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-25-2012, 03:36 PM   #1
Senior Member
geezer52's Avatar

Join Date: Jul 2009
Location: High Desert, California
Photos: Gallery
Posts: 231
Problem with K-01 and AF Lens

Have tried using my Sigma 18-125 HSM lens on my K-01 but it won't find focus it just cycles thru and never locks. Am I just missing a setting? Pentax lenses all work really well but even regular non-HSM Sigma lenses seem to work not quite as well. Thanks in advance for all help

12-25-2012, 03:48 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,275
What kind of light are you shooting in? It could be that there simple isn't enough, as the lens should definitely work otherwise.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

12-25-2012, 03:55 PM   #3
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,695
There also may not be enough contrast in the subject you're aiming the focus point on.
12-25-2012, 04:42 PM   #4
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,533
First what firmware to you use? The latest firmware included a nice AF enchancement.

Second, I advise to use centre focus point. It will help IMO.

Lastly Adam and Ash pointed nicely that you need to have enough light and contrast to AF lock with a slow zoom (like yours). This is normal.

Hope that the comment may help.

12-25-2012, 04:43 PM   #5
Senior Member
geezer52's Avatar

Join Date: Jul 2009
Location: High Desert, California
Photos: Gallery
Posts: 231
Original Poster
Tried it in brightly lit rooms and outside in daylight. Sometimes (not always) the image in the lcd looks like focus is achieved, but I never get the green square for lock on. I should mention that my K-5 has no problem getting focus to lock with this lens on under the same conditions. The K-5 even locks focus with this lens under poor lighting conditions. On the other hand the K-01 finds focus with the Pentax 35 mm f 2.4 lens quickly even under poor lighting (firmware is 1.01). I'm only having trouble with the Sigma HSM lenses.
12-25-2012, 05:43 PM   #6
Banned




Join Date: Mar 2012
Location: Charleston & Pittsburgh
Photos: Albums
Posts: 1,683
QuoteOriginally posted by geezer52 Quote
only having trouble with the Sigma HSM lenses
I own every existing copy of the Sigma lens' including the one that the OP mentioned; the...

Sigma 18-125mm f/3.8-5.6 DC HSM Zoom Lens 853109 B&H Photo Video

The problem is in two different areas. I've explained them both in the past, but please let me briefly recover them both again...

The K-01 actually needs more light than most any slr or interchangeable lens camera. This would be reason one btw. The k-01 works great, but to a point. It also works better if the lens itself is a better lens - as in better... Better meaning in aperature ranges which also typically also means better costing as in money from your pocket. It also typically means a larger and heavier lens.

The K-01 works great at better aperatures - to a point. That point is typically at about aperature f4.5- f5.0... Anything below that and one very well might run into problems. Not very major problems - as they are very easily adapted to.

The second issue... The K-01 actually also works better in spot focusing mode most of the time.

Try those two items and see where it goes.

It's most definately not the hsm system; the Sigma variation of the Pentax sdm. As I've found that the Sigma motors are actually considerably faster, more accurate, and also far more reliable
12-26-2012, 02:09 AM   #7
Senior Member
geezer52's Avatar

Join Date: Jul 2009
Location: High Desert, California
Photos: Gallery
Posts: 231
Original Poster
My Sigma HSM lenses work just fine, excellent in fact, on my K-5. I do not have a problem with HSM lenses per se, but they won't lock focus on my K-01.

My firmware is 1.01, I use only spot focus mode with my K-5 and K-01.

I would understand the light issue better except....

I put my Pentax 55-300, F 4-5.8, on the K-01. Aimed it at a darkened section of my room and it locked focus easily. To indicate how dark, the exposure for the picture was ISO 3200, F 4, at 1/4 sec. The picture was a little blurry for the shutter speed, but exposure was spot on and the K-01 did lock focus. Tried same with a Sigma 17-70, 2.8-4.5 (the non-HSM version) with similar results. Same with the Pentax WR 18-55 kit lens.

But put the aforementioned HSM lens on my K-01, and it won't lock focus in bright daylight. That suggests to me that light itself is not the problem.

I also have more expensive lenses, but the cost of the lens does not seem related to the problem either.

I don't have to use this lens on this camera but I would like to be able to. It just seems like a very odd issue.
12-26-2012, 02:59 AM   #8
New Member




Join Date: Apr 2012
Posts: 9
I own both cameras and I have the same sigma lens and the same problem... Try to use the lens on K-5 in Liveview mode on CDAF an you will see that the lens dont lock.. same like on the K-01. Need a firmware update for the lens.. My lens is now on the way to sigma repair center.

12-26-2012, 07:49 AM   #9
Veteran Member




Join Date: Jan 2007
Location: Northern California
Posts: 475
QuoteOriginally posted by geezer52 Quote
My Sigma HSM lenses work just fine, excellent in fact, on my K-5. I do not have a problem with HSM lenses per se, but they won't lock focus on my K-01.

My firmware is 1.01, I use only spot focus mode with my K-5 and K-01.

I would understand the light issue better except....

I put my Pentax 55-300, F 4-5.8, on the K-01. Aimed it at a darkened section of my room and it locked focus easily. To indicate how dark, the exposure for the picture was ISO 3200, F 4, at 1/4 sec. The picture was a little blurry for the shutter speed, but exposure was spot on and the K-01 did lock focus. Tried same with a Sigma 17-70, 2.8-4.5 (the non-HSM version) with similar results. Same with the Pentax WR 18-55 kit lens.

But put the aforementioned HSM lens on my K-01, and it won't lock focus in bright daylight. That suggests to me that light itself is not the problem.

I also have more expensive lenses, but the cost of the lens does not seem related to the problem either.

I don't have to use this lens on this camera but I would like to be able to. It just seems like a very odd issue.
Can't speak for the 18-125, but my Sigma 17-50 and 50-150 HSM lenses work fine on my K01 (latest K01 firmware). Both are relatively new lenses bought just a couple of months ago however, so it could be that the lenses have newer firmware revisions than older HSM lenses.

Ray
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-01, k01, lens, lenses, mirrorless, pentax k-01, sigma
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible problem with new K-01 rkboid Pentax K-01 13 03-16-2013 11:18 AM
Problem with new K-01 pentaxian_tmb Pentax K-01 3 11-14-2012 09:54 AM
K-01 , no AF fine adjustment , is this a problem ? kamisu Pentax DSLR Discussion 17 03-24-2012 10:52 AM
problem with K-X and K mount manual lens shinjitsu Troubleshooting and Beginner Help 10 05-12-2011 11:34 AM
Yet another K-r AF test (with both 1.00 and 1.01) EricT Pentax K-r 229 03-02-2011 07:29 AM



All times are GMT -7. The time now is 01:12 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top