Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-26-2012, 08:04 AM   #1
Marketplace Reseller
innivus's Avatar

Join Date: Dec 2011
Location: Bronx NY
Posts: 324
2 k-01 issues

2 issues have arose with a brand-new k-01:

1 - e-dial stopped working. I thought I reset it (though tough to determine if I did, since the settings barely moved). Also took out battery.

2 - focus doesn't always catch. Using a tamron 28-70 2.8 dg lens, and sometimes it searches for focus, other times it whirs and the focus doesn't shift; it's almost like the lens doesn't catch.

Any suggestion for either or these?

12-26-2012, 11:08 AM   #2
Pentaxian
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 10,863
How did the e-dial stop working? What mode is your camera in? Is the button mechanically broken, or does the camera not recognize what is going on?
Is the AF/MF switch set correctly? Contrast detect AF isn't the fastest and might not always lock. You can try upgrading the firmware, but I would wait with that if i were you, in case you want to return it under warranty due to the e-dial issue.
12-27-2012, 01:20 AM   #3
nah
Senior Member




Join Date: May 2008
Location: New Westminster, Canada
Photos: Gallery
Posts: 280
One annoying thing is that somethings the lens' screwdrive is quick and other times it's super slow, like it's out of power...

Anyone know what's up? I'm guessing when it's going slow it's looking for focus?
12-27-2012, 02:22 AM   #4
Pentaxian
RonHendriks1966's Avatar

Join Date: Jan 2009
Photos: Gallery
Posts: 8,714
Returning for warrenty should not be a problem to update your firmware. I have only one non-pentax lens, my sigma zoom, and that works better with the new firmware.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
catch, focus, issues, k-01, k01, lens, mirrorless, pentax k-01
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
issues with K-01 built-in flash dstructor Pentax K-01 11 03-30-2013 11:52 AM
K-01 AF issues Jim Beverlin Pentax K-01 17 12-03-2012 03:54 PM
M&K lenses on K-01 issues dstructor Pentax K-01 6 10-21-2012 05:34 PM
Focusing issues with K-5 & 35/2.4? treebeard Pentax K-5 11 09-02-2012 07:26 AM
K-01 and 50/1.2 Boris Pentax K-01 21 03-25-2012 08:10 AM



All times are GMT -7. The time now is 07:36 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top