Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-02-2013, 10:55 PM   #1
New Member




Join Date: Dec 2012
Posts: 21
Does this flashing yellow and red have something to do with exposure?

I just updated my firmware to v1.2. For whatever reason I'm now getting flashing yellow grain (on dark areas) and flashing solid red (on the brights) and I don't think I was before the update. As a disclaimer, I'm a complete newbie with photography in general and the K-01 in particular.
So I'm wondering this: did something change when I updated, or did I unknowingly make the change? And, can I turn this off until I understand what it means and how to use it?

02-02-2013, 11:03 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,118
QuoteOriginally posted by rkymtnrider Quote
I just updated my firmware to v1.2. For whatever reason I'm now getting flashing yellow grain (on dark areas) and flashing solid red (on the brights) and I don't think I was before the update. As a disclaimer, I'm a complete newbie with photography in general and the K-01 in particular.
So I'm wondering this: did something change when I updated, or did I unknowingly make the change? And, can I turn this off until I understand what it means and how to use it?
The firmware update probably reset a setting that was previously disabling this. The setting is called "show bright and dark areas", I believe.

And yes, it does have something to do with exposure: yellow areas are too dark while read areas are too bright and if you see any, you'll want to adjust your exposure so that they go away (or at least so that one of them goes away), or try bracketing.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

02-02-2013, 11:19 PM   #3
New Member




Join Date: Dec 2012
Posts: 21
Original Poster
Thanks Adam. I'm confused on why I can get my meter to read "0" but yet these areas are still flashing at me. It's particularly annoying. Also the shutter, aperture, and ISO settings flash red no matter what my meter is reading. Not sure what's going on after the update, but things have certainly changed.
02-03-2013, 01:40 AM   #4
Inactive Account




Join Date: Dec 2008
Location: North Carolina
Photos: Albums
Posts: 1,720
QuoteOriginally posted by rkymtnrider Quote
I'm confused on why I can get my meter to read "0" but yet these areas are still flashing at me.
You won't get everything perfectly exposed in many situations. You just need to pick what you want properly exposed, there isn't just one correct exposure setting, it depends on what you want the final image to look like.

The red and yellow on the LCD are just telling you what areas of the image will not have proper exposure, if you want something that is flashing red to be exposed properly then you need to speed up your shutter or stop down the aperture, but you'll lose more in the dark areas. If you see something flashing yellow that you want to be exposed properly then you need to slow down your shutter or open the aperture to brighten that area, but you'll lose more in the bright areas. If your main subject is properly exposed and you're fine with the other areas being under and overexposed, then you don't need to change anything.

You can't always capture everything in one exposure, cameras have limited dynamic range, which is why exposure stacking, also known as HDR exists.

02-03-2013, 08:54 AM   #5
New Member




Join Date: Jan 2013
Posts: 17
QuoteOriginally posted by rkymtnrider Quote
Thanks Adam. I'm confused on why I can get my meter to read "0" but yet these areas are still flashing at me. It's particularly annoying. Also the shutter, aperture, and ISO settings flash red no matter what my meter is reading. Not sure what's going on after the update, but things have certainly changed.
It could be that your settings got changed somehow, though the update didn't change my settings.

If your K-01 is brand new, it might just be that you haven't noticed it before. To turn it off, go to the third page of the menu, and under Live View, uncheck the box marked Bright/Dark Area. I find that that option is about as useless as the histogram.

I don't know why your shutter, aperture, and ISO settings would flash red if you have the camera pointed at a normal scene. It might mean that there is something wrong with your camera.
02-03-2013, 09:09 AM   #6
Pentaxian
JinDesu's Avatar

Join Date: Jun 2011
Location: New York City
Photos: Gallery
Posts: 5,626
QuoteOriginally posted by jim6522 Quote
It could be that your settings got changed somehow, though the update didn't change my settings.

If your K-01 is brand new, it might just be that you haven't noticed it before. To turn it off, go to the third page of the menu, and under Live View, uncheck the box marked Bright/Dark Area. I find that that option is about as useless as the histogram.

I don't know why your shutter, aperture, and ISO settings would flash red if you have the camera pointed at a normal scene. It might mean that there is something wrong with your camera.
He may have spot metering on and pointing at something white or black.
02-03-2013, 09:40 AM   #7
New Member




Join Date: Dec 2012
Posts: 21
Original Poster
Thank you for your feedback. The Bright/Dark setting in Live View was on, as was the histogram. Metering was set to auto.
I was looking through the settings right before the firmware update, so I could have made some changes unknowingly.
Either way, thanks for your help! All systems seem to be normal once again.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
change, k-01, k01, mirrorless, pentax k-01
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with mirror lens on K-01...red flashing F-- slackercruster Pentax K-01 2 07-11-2012 01:20 PM
What Does Talent Have to Do with It? benjikan Photographic Industry and Professionals 3 01-28-2012 06:06 PM
Red, yellow, and black blinking colors in review pics can't find anything about this. buckskin Troubleshooting and Beginner Help 7 05-11-2010 10:32 AM
flashing yellow and red in KX trishytee Pentax DSLR Discussion 21 05-01-2010 01:35 PM
Does anyone have a link to the K10d review featuring this picture? quattro Pentax DSLR Discussion 2 01-13-2009 06:54 PM



All times are GMT -7. The time now is 06:24 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top