Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-10-2013, 07:24 PM   #1
Junior Member
pony.rojo's Avatar

Join Date: Apr 2011
Location: Las Vegas, Nevada
Photos: Gallery | Albums
Posts: 31
Count Me In

I just wanted to jump in and say that I, too, could not pass up the deal for the K-01. $299 for essentially a K-5 sensor, one of the best rated APS-C sensors on the market? Yes, please.

I've been pouring over all the K-01 forums here and I'm very satisfied with what I've been reading, I can't wait! Ordered it from B&H, should be coming in this Friday. I got it without the pancake lens, I've got a couple old school manual focus prime lenses that I'm excited to try with the K-01's focus peaking.

I do have one question, though, about the firmware.

How can you tell what firmware it is being shipped with? It wouldn't be the most recent update, would it?

And, since there seems to be some hesitation in the forums, should I install the latest firmware when I get the camera? Or just leave it for now?

Many thanks!

02-10-2013, 07:51 PM   #2
Site Supporter
jimr-pdx's Avatar

Join Date: May 2010
Location: 1hr north of PDX
Photos: Gallery | Albums
Posts: 3,491
Wrench menu #3, at the bottom - from there you can view and/or update firmware. The K-01 seems to allow for firmware down-dates* if you choose not to fall in love with the latest - though I have it and it seems AF has improved its hit rate over earlier FW. Still loving my white model, it cannot do everything my K-5 can do but at this price I could kill two K-01s and still be in OK shape... but I don't intend to

edit - of course I can't say where to find a copy of FW 1.00 so you can only back up so far!
02-10-2013, 08:03 PM   #3
Loyal Site Supporter
THoog's Avatar

Join Date: Aug 2012
Location: North Carolina
Photos: Gallery | Albums
Posts: 3,447
Firmware 1.01 came out in early October, and I think the last K-01 was produced a couple months before that (if anyone can prove me wrong, please do!). So any new-in-box K-01 will have firmware 1.00. You definitely should update it to at least 1.01 - AF performance was a huge improvement.

Edit: Some of the latest puchases, that required waiting for the backordered units to come from Asia, show September build dates.

I haven't had any issues with 1.02 - I think the reception has been lukewarm because it doesn't really improve on 1.01 (unless you have the new DA 560, but at MSRP $7000, I don't think too many people will be putting that on a K-01. Or anything else.).

Last edited by THoog; 02-12-2013 at 11:17 AM.
02-10-2013, 08:39 PM   #4
Site Supporter




Join Date: Jan 2010
Location: Michigan
Photos: Gallery
Posts: 2,101
Thanks, jim and pony,
I have been using K-01 for 4 days
Ver 1.00........... and getting very sharp shots in sunlight.
Today I did indoor portrait session with a little backlight. 43 mm on the 18~55 kit lens iso 800 f/8 and 1/6 th sec on tripod.
The AF was as busy as a one legged ass kicker and the shots are not sharp.
I switched to MF and the focus peaking - still no good.
I had the Ricoh KR-5 with 1:1.4 50 mm on another tripod alongside with iso 800 Fuji , I am sure it will be OK and sharp of course.
I used ist ds in same situation with same lens many times - What am I doing wrong with the k-01 ?
Any help will be appreciated, thanks

02-10-2013, 11:17 PM   #5
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,501
QuoteOriginally posted by wombat2go Quote
TVer 1.00...........
Please update your firmware to 1.02. The latest firmware is a major improvement and you should install it. This may solve some of your problems.

Once you install 1.02, redo the same tests and see if the problem persists

By the way, if you use a tripod do make sure that the SR (Shake Reduction) is OFF.

Hope that the comment may help.
02-11-2013, 10:12 AM   #6
Senior Member




Join Date: Dec 2011
Location: Ohio
Posts: 231
My K-01 with 40XS just arrived....I am looking forward to putting it thru the paces
02-11-2013, 10:20 AM   #7
New Member




Join Date: Jan 2013
Posts: 17
QuoteOriginally posted by wombat2go Quote
I switched to MF and the focus peaking - still no good.
Did you use the OK button to magnify the display, and e-dial to determine the amount of magnification? That has always worked for me.

Then again, I'm not using the 18-55mm kit lens.
02-11-2013, 10:32 AM   #8
Site Supporter




Join Date: Jan 2010
Location: Michigan
Photos: Gallery
Posts: 2,101
hcc, Thanks
Now updated to 1.02 and SR is off for tripod use
The camera is now focussing in low light without hunting and the image is sharp.

By the way, the update can be done on Linux using the mac download, however the permissions of the sd card must be opened:
chmod -r 777 /media/K-01

jim, Thanks
Now I am using the OK to zoom to manual focus precisely.

02-12-2013, 10:09 AM   #9
Senior Member




Join Date: Dec 2011
Location: Ohio
Posts: 231
QuoteOriginally posted by THoog Quote
Firmware 1.01 came out in early October, and I think the last K-01 was produced a couple months before that (if anyone can prove me wrong, please do!). So any new-in-box K-01 will have firmware 1.00. You definitely should update it to at least 1.01 - AF performance was a huge improvement.

I haven't had any issues with 1.02 - I think the reception has been lukewarm because it doesn't really improve on 1.01 (unless you have the new DA 560, but at MSRP $7000, I don't think too many people will be putting that on a K-01. Or anything else.).
Just got mine and it is the ver. 1.00. If I update to ver. 1.02, I assume that includes the 1.01 update?
02-12-2013, 11:15 AM   #10
Loyal Site Supporter
THoog's Avatar

Join Date: Aug 2012
Location: North Carolina
Photos: Gallery | Albums
Posts: 3,447
QuoteOriginally posted by mdodrill Quote
Just got mine and it is the ver. 1.00. If I update to ver. 1.02, I assume that includes the 1.01 update?
That's correct!
02-12-2013, 02:12 PM   #11
Junior Member
pony.rojo's Avatar

Join Date: Apr 2011
Location: Las Vegas, Nevada
Photos: Gallery | Albums
Posts: 31
Original Poster
This is going to be a dumb question, but after you download the update onto the formatted SD card, is it a pretty straightforward install?
02-12-2013, 02:14 PM   #12
Senior Member




Join Date: Dec 2011
Location: Ohio
Posts: 231
QuoteOriginally posted by pony.rojo Quote
This is going to be a dumb question, but after you download the update onto the formatted SD card, is it a pretty straightforward install?
Just did the update and yes
02-16-2013, 09:43 AM   #13
Junior Member
pony.rojo's Avatar

Join Date: Apr 2011
Location: Las Vegas, Nevada
Photos: Gallery | Albums
Posts: 31
Original Poster
Ladies and Gentlemen, The Brick has landed.













So, after the ritual unboxing ceremony, I hand the camera to my wife who immediately says, "That is one ugly camera. I'm sorry, but that's just ugly." Yup. It's a love it or hate it thing, lol.

I wussed out and got it in black. Part of me really wanted the yellow, just as even a more in-your-face gesture to the Canikon crowd, but at the end of the day I just didn't have the spine. That said, I think the black looks pretty sweet, especially with the silver highlights. It's weird, but looking at the K-01 next to the K-1000, I can totally see now where Newsome got a lot of his styling cues.

I've updated the firmware as well, V 1.02 is installed. I've shot just a couple of frames with my DA f/2.4 35mm, and it seems like it's going fine.

However, I do have a question about using older, manual focus lenses. On my K-x, when I'm using my older lenses (50mm f/2.0 SMC-M, for instance), I'm able to hit the AV button and the camera adjusts the exposure accordingly by resetting the shutter speed.

Does the K-01 have a similar feature?

Last edited by pony.rojo; 02-16-2013 at 09:53 AM.
02-16-2013, 10:06 AM   #14
Loyal Site Supporter
THoog's Avatar

Join Date: Aug 2012
Location: North Carolina
Photos: Gallery | Albums
Posts: 3,447
The behavior is different depending on whether the lens is a M42 or a K/M, but for an M lens, if the K-01 is in M-manual mode and the ISO is manually selected, pressing the green button will set the shutter speed.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
firmware, focus, forums, k-01, k01, mirrorless, pentax k-01
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Pentax k30 - 841 shutter count The dog walker Sold Items 5 01-25-2013 02:36 PM
Starting the Count Again missimoo_2 Pentax K-5 4 07-29-2011 02:16 AM
A Week in Washington DC - 18 (count 'em) images Sailor Post Your Photos! 5 06-30-2008 07:13 PM
:( Sox fan in NY (high picture count) fun things you see when your team is losing. vievetrick Post Your Photos! 3 09-05-2007 05:20 AM



All times are GMT -7. The time now is 08:19 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top