Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-21-2015, 06:51 AM   #91
Site Supporter




Join Date: Jan 2008
Location: Connecticut, USA
Posts: 871
My dial fell off too. Want to get the consensus here on the best process to reattach it.

07-21-2015, 07:31 AM   #92
Senior Member
Professor Batty's Avatar

Join Date: Aug 2012
Posts: 118
When mine fell off I carefully cleaned off the old adhesive and put a piece of hi-tack print mount on the top of the shaft and pressed the dial back on it. It's held well so far, I would think that any double-sided tape would work. I wouldn't use glue—too much of a chance that it could make a mess and it might not be removable in the future.
07-21-2015, 05:30 PM   #93
Pentaxian
Transit's Avatar

Join Date: Aug 2007
Location: Whanganui NZ
Photos: Gallery | Albums
Posts: 4,010
I risked the glue, with a cleanup then careful wipe of contact adhesive on each.
seems ok.
07-21-2015, 06:22 PM   #94
Pentaxian




Join Date: Jun 2011
Location: NJ
Photos: Gallery | Albums
Posts: 4,790
I had to re-attach mine several months ago. I used Krazy Glue, working perfectly so far.

07-21-2015, 06:30 PM   #95
Pentaxian
furryurry's Avatar

Join Date: Nov 2011
Location: CA
Photos: Gallery | Albums
Posts: 722
I lost mine too :/
03-09-2016, 11:03 AM   #96
Junior Member




Join Date: Dec 2012
Posts: 30
Lost my Mode Dial on a trip to Yosemite. Found one on ebay for $35, though that listing is now showing $135.

Just ran across one here as well, though it's listed as out of stock at the moment;
Pentax K-01 Digital Mirrorless Camera Dial 77560.0A331
03-09-2016, 10:09 PM   #97
Pentaxian
furryurry's Avatar

Join Date: Nov 2011
Location: CA
Photos: Gallery | Albums
Posts: 722
$135!!!!!!!!!!!!!!!!!!!!!!!! ill just keep shooting without it lol

P.S. $135+shipping!

Last edited by furryurry; 03-09-2016 at 10:25 PM.
03-10-2016, 10:04 AM   #98
Site Supporter
shiner's Avatar

Join Date: Jan 2009
Location: N GA USA
Photos: Gallery | Albums
Posts: 1,402
Re-attached both of mine with small amount of "3M super strength adhesive". Seems secure.

03-10-2016, 10:07 AM   #99
Junior Member




Join Date: Dec 2012
Posts: 30
QuoteOriginally posted by shiner Quote
Re-attached both of mine with small amount of "3M super strength adhesive". Seems secure.
Wish I had done the same.

I think its a good idea to give a little tug on the dial for anyone who owns a K-01, to make sure it's on securely.
03-10-2016, 12:11 PM   #100
Junior Member




Join Date: Dec 2012
Posts: 30
QuoteOriginally posted by furryurry Quote
$135!!!!!!!!!!!!!!!!!!!!!!!! ill just keep shooting without it lol

P.S. $135+shipping!
Just a guess, but I think the seller is out and put the price where no-one would buy it, rather than letting the listing drop out.
03-10-2016, 02:44 PM   #101
Site Supporter




Join Date: Mar 2009
Location: Toronto, Ontario, Canada
Photos: Albums
Posts: 63
Mine popped off last month. 430xxxx serial. I suggest this will be a failure on all K-01's as the adhesive dries out with age.
03-12-2016, 06:07 PM   #102
Site Supporter
ronniemac's Avatar

Join Date: Apr 2011
Location: Oxford
Photos: Albums
Posts: 118
Mine came off my silver K-01, found it and holding it on with blue tack just now. Yellow and black are fine.
03-12-2016, 06:42 PM   #103
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 20,049
I bought a second one in the box a couple months ago to get the battery and DA40XS. It had 126 actuations (it was FW 1.0 so it hadn't reset) and it was perfect - except the Mode Dial came off as I removed the plastic
03-12-2016, 07:45 PM   #104
Site Supporter
shiner's Avatar

Join Date: Jan 2009
Location: N GA USA
Photos: Gallery | Albums
Posts: 1,402
QuoteOriginally posted by ronniemac Quote
Mine came off my silver K-01, found it and holding it on with blue tack just now. Yellow and black are fine.
Pop the other two off and re-glue them immediately! Mine seemed OK until I tested them. They will pop right off! Everyone should remove and re-glue their dials NOW, if they haven't lost them yet. It's not hard, only takes a few minutes- and a variety of adhesives will work. Anything is better than leaving the OEM glue in place, because it is just ticking the days away before it will catch you by surprise.

---------- Post added 03-12-16 at 09:47 PM ----------

QuoteOriginally posted by monochrome Quote
I bought a second one in the box a couple months ago to get the battery and DA40XS. It had 126 actuations (it was FW 1.0 so it hadn't reset) and it was perfect - except the Mode Dial came off as I removed the plastic
The DA40XS is one of the best things Pentax ever made.
03-31-2016, 03:28 PM   #105
Senior Member




Join Date: Mar 2007
Location: Scio, Oregon
Photos: Gallery
Posts: 103
All you K-01er's out there: I was contacted by pixelvandal about the lost mode dial issue because I had done some 3D printing for the Q. He wanted to know if a replacement is possible. I have modeled (image below) and test printed a replacement dial that looks pretty cool. Problem is I have no K-01 to test it on nor do I know anyone to test it on. While I could mail to pixelvandal for a test fit, but then we would have to keep mailing dials back & forth until it is correct. Is there anyone in the Salem/Albany Oregon area willing to do a test fitting? The problem is the pin to key the dial orientation. I don't know exact size and location. I have it pretty close, and perhaps good enough, but it needs a test fitting to be correct.
Attached Images
 

Last edited by K10Perry; 03-31-2016 at 03:31 PM. Reason: edit
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
cap, cards, cement, da40xs, dials, fit, k-01, k01, knob, mine, mirrorless, mode, pentax k-01, pin, pop, rubber, screw, service, silver, tech
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K-01 : Problem in video mode with manual lenses minilink Pentax K-01 53 10-28-2013 10:56 AM
K20D Mode Dial Problem ChucK20D Troubleshooting and Beginner Help 6 11-20-2012 07:37 PM
K-5 mode dial physically stuck jaitas Pentax K-5 4 02-21-2012 04:05 AM
Mode dial problem on K10d Plornt Pentax DSLR Discussion 13 03-16-2011 10:46 PM
k100d mode dial problem song_hm Pentax DSLR Discussion 15 03-14-2011 01:14 AM



All times are GMT -7. The time now is 11:41 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top