Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-01-2013, 12:51 AM   #16
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,294
AF in Movie mode works fine with my DA 18-55

03-01-2013, 08:09 AM   #17
Senior Member
jwc77's Avatar

Join Date: Nov 2010
Location: Rolla, MO
Posts: 265
I still have version 1.01....do I need to upgrade to 1.02 before 1.03 or can I just go straight to the new version?
03-01-2013, 08:24 AM   #18
Veteran Member
mrNewt's Avatar

Join Date: Nov 2011
Location: ON, RH
Posts: 2,170
QuoteOriginally posted by jwc77 Quote
I still have version 1.01....do I need to upgrade to 1.02 before 1.03 or can I just go straight to the new version?
You can upgrade to 1.03 without issues.
03-01-2013, 09:02 AM   #19
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 20,434
Not Enough Battery Capacity to Perform Upgrade

Here's a pleasing little info nugget. Last night I stuck the card with the .BIN file in my K-01, Menu'ed over to Install V.1.03 and -- the camera warned me I didn't have enough battery capacity to perform an upgrade. I had forgotten to check that since the K-01 battery seems to last for weeks. Huh. That's interesting.
  1. This is a very small, but very thoughtful, user-centered protection built into the FW Upgrade routine that really resonated positively with me. I've never bricked a camera but I know people who have.
  2. There were two bars visible. It seems if Pentax is going to write the code they decided to require a FULL battery. Very smart.
An hour later I upgraded - took about 60 seconds.


Last edited by monochrome; 03-01-2013 at 01:31 PM.
03-01-2013, 12:45 PM   #20
Junior Member
SergioFromSF's Avatar

Join Date: Dec 2009
Location: San Francisco
Photos: Albums
Posts: 45
Please correct me if I am misunderstanding: I switch camera to Movie mode, press halfway on the shutter - AF works, press fully, recording starts, move camera around - focus doesn't change.

I thought AF in movie mode meant that as I move closer or further focus automatically adapts to distance, am I wrong?
So to have things in focus while recording, I need to manually focus - no AF.
03-01-2013, 02:46 PM   #21
Senior Member




Join Date: Feb 2011
Location: Chicago, IL
Photos: Gallery
Posts: 168
QuoteOriginally posted by SergioFromSF Quote
Please correct me if I am misunderstanding: I switch camera to Movie mode, press halfway on the shutter - AF works, press fully, recording starts, move camera around - focus doesn't change.

I thought AF in movie mode meant that as I move closer or further focus automatically adapts to distance, am I wrong?
So to have things in focus while recording, I need to manually focus - no AF.
You are wrong. You have to hit the AF button to refocus when you want too. It doesn't AF for you.
03-01-2013, 03:24 PM   #22
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,294
Apologies, SergioFromSF. I misunderstood what you were meaning.
The K-01 doesn't do continuous Auto Focus *during* movie capture.
03-01-2013, 07:00 PM   #23
Senior Member




Join Date: Nov 2012
Posts: 104
Once the camera starts recording, you'll need to manually refocus using the lens, half pressing the shutter button again while recording won't do anything.

03-01-2013, 07:04 PM   #24
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 20,434
Quick Shift with the 40 Limited is great for this - but care should be taken manually focusing a screw-drive lens if screw-drive AF is engaged.
03-02-2013, 03:30 PM   #25
Junior Member




Join Date: Jul 2012
Posts: 36
Incredible, love my K-01 and I am a loyal Pentaxian.
03-02-2013, 03:47 PM   #26
Site Supporter
jimr-pdx's Avatar

Join Date: May 2010
Location: 1hr north of PDX
Photos: Gallery | Albums
Posts: 3,550
QuoteOriginally posted by monochrome Quote
Here's a pleasing little info nugget. Last night I stuck the card with the .BIN file in my K-01, Menu'ed over to Install V.1.03 and -- the camera warned me I didn't have enough battery capacity to perform an upgrade. I had forgotten to check that since the K-01 battery seems to last for weeks. Huh. That's interesting.
  1. This is a very small, but very thoughtful, user-centered protection built into the FW Upgrade routine that really resonated positively with me. I've never bricked a camera but I know people who have.
  2. There were two bars visible. It seems if Pentax is going to write the code they decided to require a FULL battery. Very smart.
An hour later I upgraded - took about 60 seconds.
I was hit with the same thing - most grateful to them for keeping me honest
05-04-2013, 06:11 AM   #27
Pentaxian
PiDicus Rex's Avatar

Join Date: May 2013
Location: Melbourne, Australia
Posts: 1,126
QuoteOriginally posted by monochrome Quote
Not Enough Battery Capacity to Perform Upgrade
I'll second that,.. I've bricked stuff that required all sorts of effort to unbrick, that's a simple little bit of code from Pentax that shows the Engineers really do care about the product and the user experience.

There's a heck of a lot of companies that could learn from that example.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
firmware, k-01, k01, mirrorless, pentax k-01
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New firmware: v1.13 for K-5/645D, v.1.12 for K-7/K-r, v1.03 for K-x Adam Pentax News and Rumors 71 05-15-2012 01:42 PM
Comparison of K-5 low light focus accuracy with v1.01 and v1.03 of firmware tram57 Pentax K-5 3 03-20-2011 08:13 PM
K-5 Firmware v1.03 on Pentax Japan site nixifo Pentax K-5 292 03-18-2011 12:36 PM
New Firmware V1.03 for K-5! HermanLee Pentax News and Rumors 30 03-16-2011 10:50 AM
K-5 FW v1.03 now available on Pentax USA web site. areidjr Pentax K-5 0 03-11-2011 11:31 AM



All times are GMT -7. The time now is 05:41 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top