Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-01-2013, 11:24 AM   #1
Junior Member




Join Date: Mar 2013
Photos: Albums
Posts: 41
Autofocus disengaged intermittently

Hi everyone,
Just got my K-01 with 40mm XS and loving it. But for some reason, while the switch is still at AF it sometimes goes into manual focus - the display shows MF and half pressing shutter button doesn't produce any focusing action. I'd have to turn the ring slightly for AF to work again. I've tried cleaning the contact points on both lens and body with rubbing alcohol, and that helped reduce the frequency of the problem but didn't eliminate it. Firmware is also updated to 1.03. Don't know if I have defective lens, body, or both. Anyone experienced this?

Thanks!

03-01-2013, 11:36 AM   #2
Loyal Site Supporter
THoog's Avatar

Join Date: Aug 2012
Location: North Carolina
Photos: Gallery | Albums
Posts: 3,486
When you mount the lens, are you turning it until the lens lock clicks into place? Some have reported problems with tight-fitting lenses, where they are aren't turning them all the way and the screw-drive for AF works intermittently or strangely.
03-01-2013, 11:43 AM   #3
Junior Member




Join Date: Mar 2013
Photos: Albums
Posts: 41
Original Poster
QuoteOriginally posted by THoog Quote
When you mount the lens, are you turning it until the lens lock clicks into place? Some have reported problems with tight-fitting lenses, where they are aren't turning them all the way and the screw-drive for AF works intermittently or strangely.
Thanks Todd. I've tried remounting it several times with same result. I turned it slowly all the way until click. It'll do AF just fine for a while, then suddenly drops into MF. I'd turn the ring slightly and AF is back.
03-01-2013, 11:54 AM   #4
Veteran Member




Join Date: Nov 2006
Location: Cincinnati, OH
Posts: 419
Last week I actually had the MF/AF switch on my K-01 accidentally positioned just perfectly so the AF screw would sometimes engage the lens that was mounted and sometimes not. Double check the AF switch on the camera body is indeed all the way to AF.

03-11-2013, 11:36 PM   #5
Junior Member




Join Date: Mar 2013
Photos: Albums
Posts: 41
Original Poster
Update for those who might have similar problem - I had to return it and exchange for another kit. Something was wrong with the contacts between the body and lens. Sometimes it didn't recognize the lens and asked me to input focal length. Manual focus with peaking even missed a few times - everything came out blurry to my surprise. Probably the anti-shake wasn't functioning right.
The new kit just came today. I just tried out for a few minutes, and even with default firmware, it focuses reasonably fast and very accurate. Love this camera. Time to hit Ebay for some sweet vintage lens
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, body, k-01, k01, lens, mirrorless, pentax k-01
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Autofocus switch stuck on AF.S and will not autofocus! pauldiebel Pentax DSLR Discussion 3 09-19-2009 08:59 PM
Help with my intermittently dead K100D? funkatron Pentax DSLR Discussion 8 09-22-2008 10:39 AM
For Sale - Sold: FS: Autofocus film cameras and autofocus lenses Not Registered Sold Items 15 03-17-2008 07:08 AM
In-Body autofocus vs In-Lens autofocus Gooshin Pentax DSLR Discussion 7 02-05-2008 11:10 AM
New K10D, starting to record "Black" images intermittently mhuterer1 Pentax DSLR Discussion 13 12-28-2007 12:16 PM



All times are GMT -7. The time now is 07:40 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top