Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-19-2013, 07:42 AM   #1
Junior Member
jessecad's Avatar

Join Date: Jan 2008
Location: Lat. N35°19'87" Long. W97°27'27"
Posts: 31
Computer fails to read SD card..

I have many pictures on a Lexar Professional 128gb card which I have used several times in the K7, K5 and I am using it now in the K-01 - shooting RAW. Before using the card in the K-01 I formatted it in the K-01.

I have put the card in the computer several times before to transfer files and for the first time the computer displayed a message "in order to use this card it first must be formatted".

After a few times of this I put the card back in the K-01, viewed all the images (they were all fine), then decided to take another shot, I viewed the image in the camera, then put the SD card back in the computer and now the computer sees the files (Windows 8). I just thought I would pass this info on in case it ever happens to someone else. I have FW 1.03 in K-01

JC


Last edited by jessecad; 03-19-2013 at 07:43 AM. Reason: Missing text
03-19-2013, 08:04 AM   #2
Veteran Member




Join Date: Dec 2010
Location: Central Kentucky
Photos: Gallery | Albums
Posts: 1,415
The only time I experienced a similar problem my card reader was going bad. From what I will never know because I just use those 99 cent USB sized ones until they die and throw them away.
03-19-2013, 08:48 AM   #3
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,770
Happens occasionally if the reader is a little sloppy. The card is just misaligned enough to not be recognized so the driver asks to format it. I have seen this several times, take the card out and re-insert and all is good. If it happens more than rarely I would be looking for a new reader though.
03-19-2013, 09:05 AM   #4
New Member




Join Date: Jan 2010
Posts: 3
Usually it is card reader problem, buy a new card reader and test it. Hope this helps....

03-19-2013, 12:03 PM   #5
Loyal Site Supporter
THoog's Avatar

Join Date: Aug 2012
Location: North Carolina
Photos: Gallery | Albums
Posts: 3,486
I had this happen with one card, and under close inspection found that the little plastic ridge between two of the contacts had split off. On my PC and laptop, the sliver of plastic would get pushed over and block the contact, but never with my camera. I trimmed off the sliver and have had no problems since.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
card, computer, files, k-01, k01, mirrorless, pentax k-01, sd, times
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
SD Card won't Read/Write in Camera bobell69 Troubleshooting and Beginner Help 3 02-05-2013 08:52 PM
K10 can't read SD card saladfunky Troubleshooting and Beginner Help 2 07-19-2011 01:54 PM
Crap! My new class 10 sd card run much slower than my old class 4 sd card... liukaitc Pentax Camera and Field Accessories 15 05-31-2011 01:39 PM
My computer won't read my memory card Pål Jensen Pentax Camera and Field Accessories 7 07-29-2009 11:32 AM



All times are GMT -7. The time now is 02:32 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top