Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-02-2013, 11:44 PM   #1
Junior Member




Join Date: Mar 2013
Photos: Albums
Posts: 41
Auto white balance in M mode

I've noticed a change in white balance when shooting under fluorescent or tungsten in M mode. With the lens aperture set at "A" and the K-01 in M mode, AWB gives nice and cool color. But as soon as I take the lens off "A", AWB immediately gives a much warmer yellow cast, which I don't really like. In other words, whenever the display shows "F--" AWB changes to the warm mode. This is also the case with K or M lenses in AV mode - my favorite K-01 shooting mode with the THoog taping hack
Anyone else experienced this? Why would white balance correlate with aperture stop down mode?


Last edited by kakapo; 05-02-2013 at 11:49 PM.
05-03-2013, 12:20 AM   #2
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 5,002
QuoteOriginally posted by kakapo Quote
I've noticed a change in white balance when shooting under fluorescent or tungsten in M mode. With the lens aperture set at "A" and the K-01 in M mode, AWB gives nice and cool color. But as soon as I take the lens off "A", AWB immediately gives a much warmer yellow cast, which I don't really like. In other words, whenever the display shows "F--" AWB changes to the warm mode. This is also the case with K or M lenses in AV mode - my favorite K-01 shooting mode with the THoog taping hack
Anyone else experienced this? Why would white balance correlate with aperture stop down mode?
Yes, I've certainly noticed that, and not just on the K-01 but every model I've used. It has been suggested that since when it is not on 'A' it will only use center or spot metering (which itself is a bit of mystery as there seems to be no technical reason for that limitation) that this is also affecting the white balance (spot white balance?). So not sure exactly why, but it does happen, yes...
05-03-2013, 09:06 AM   #3
Junior Member




Join Date: Mar 2013
Photos: Albums
Posts: 41
Original Poster
Thanks vonBaloney. I'm shooting RAW anyway so this isn't a big deal. Just making sure my camera is working as designed. Maybe a white balance lens cap is all I need
05-03-2013, 09:59 AM   #4
Loyal Site Supporter
THoog's Avatar

Join Date: Aug 2012
Location: North Carolina
Photos: Gallery | Albums
Posts: 3,486
QuoteOriginally posted by kakapo Quote
my favorite K-01 shooting mode with the THoog taping hack
Gosh, I hope that's not a reference to my video skills (or lack thereof)

I've also seen the WB effect you describe, but never paid enough attention to really look into it.

05-03-2013, 12:54 PM   #5
Junior Member




Join Date: Mar 2013
Photos: Albums
Posts: 41
Original Poster
Well THoog, I have a love-hate relationship with your hack of masking the lens contacts with a piece of tape. On the one hand it greatly add usability to all my non-A lenses, making them even more awesome on the K-01. On the other hand it cruelly impedes my recovery from LBA I've somehow accumulated 10 or so of such lenses is just over a month, thinking I'd just sell the ones I don't really like. But now with them all being so usable, it's much harder to let any of them go. So there, thank you and I really hate you
05-03-2013, 01:04 PM   #6
Loyal Site Supporter
THoog's Avatar

Join Date: Aug 2012
Location: North Carolina
Photos: Gallery | Albums
Posts: 3,486
QuoteOriginally posted by kakapo Quote
So there, thank you and I really hate you
You're welcome! My work is done.

If it gives you any satisfaction, I torture myself over each new LBA acquisition, trying to decide whether to tape it or not. I've decided to tape my Rikenon P lenses (since I already modified them to defang the Ricoh pin) but leave my actual Pentax M lenses "stock" and green-button them. This new Zenitar... what to do, what to do...
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, auto white balance, awb, balance, k-01, k01, lens, mirrorless, mode, pentax k-01
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto white balance issues zvon Pentax K-r 4 02-15-2012 01:12 PM
Auto White Balance Kennuck Troubleshooting and Beginner Help 12 11-22-2011 08:51 AM
Auto Bracketing in M mode Northern Soul Troubleshooting and Beginner Help 6 09-20-2011 03:09 AM
Kx white balance in video mode hydroclops Video and Pentax HDSLRs 6 02-25-2010 11:36 AM
Auto white balance vs. daylight balance outdoors. fevbusch Pentax DSLR Discussion 7 02-18-2007 03:04 PM



All times are GMT -7. The time now is 01:36 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top